pkgsrc/devel/monodevelop/patches/patch-af
kefren eadc6401ee Use ${MAKE_PROGRAM} instead of hardcoding gmake. The latter will cause
problems on linux systems. Bump PKGREVISION. Noticed by Tobias Nygren
2010-04-17 17:11:04 +00:00

22 lines
1,012 B
Text

$NetBSD: patch-af,v 1.2 2010/04/17 17:11:05 kefren Exp $
--- src/addins/MonoDevelop.Autotools/templates/Makefile.solution.template.orig 2010-04-16 13:17:54.000000000 +0300
+++ src/addins/MonoDevelop.Autotools/templates/Makefile.solution.template 2010-04-16 13:18:08.000000000 +0300
@@ -8,14 +8,14 @@
@set . $$MAKEFLAGS; final_exit=:; \
case $$2 in --unix) shift ;; esac; \
case $$2 in *=*) dk="exit 1" ;; *k*) dk=: ;; *) dk="exit 1" ;; esac; \
- make pre-$*-hook prefix=$(prefix) ; \
+ MAKEPROGRAM pre-$*-hook prefix=$(prefix) ; \
for dir in $(call quote_each,$(SUBDIRS)); do \
case "$$dir" in \
- .) make $*-local || { final_exit="exit 1"; $$dk; };;\
- *) (cd "$$dir" && make $*) || { final_exit="exit 1"; $$dk; };;\
+ .) MAKEPROGRAM $*-local || { final_exit="exit 1"; $$dk; };;\
+ *) (cd "$$dir" && MAKEPROGRAM $*) || { final_exit="exit 1"; $$dk; };;\
esac \
done; \
- make post-$*-hook prefix=$(prefix) ; \
+ MAKEPROGRAM post-$*-hook prefix=$(prefix) ; \
$$final_exit
$(CONFIG_MAKE):