93a53fbf88
This problem results mysqld to exit on start up. 5.1/i386 5.1/amd64 5.99.38/i386 5.99.38/amd64 my_time_t int32_t int64_t int32_t int64_t time_t int32_t int32_t int64_t int64_t I confirmed to mysqld running on these four case except 5.99.38/i386. Bump PKG_REVISION.
24 lines
680 B
Text
24 lines
680 B
Text
$NetBSD: patch-ae,v 1.2 2010/08/13 14:25:35 taca Exp $
|
|
|
|
* check sizeof time_t.
|
|
* check existence of sigsend().
|
|
|
|
--- configure.in.orig 2010-07-09 12:34:57.000000000 +0000
|
|
+++ configure.in
|
|
@@ -1946,6 +1946,7 @@ if test "$ac_cv_sizeof_off_t" -eq 0
|
|
then
|
|
AC_MSG_ERROR("MySQL needs a off_t type.")
|
|
fi
|
|
+AC_CHECK_SIZEOF(time_t, 4)
|
|
|
|
dnl
|
|
dnl check if time_t is unsigned
|
|
@@ -2039,7 +2040,7 @@ AC_CHECK_HEADERS(varargs.h stdarg.h dire
|
|
paths.h semaphore.h)
|
|
|
|
# Already-done: strcasecmp
|
|
-AC_CHECK_FUNCS(lstat putenv select setenv setlocale strcoll tcgetattr)
|
|
+AC_CHECK_FUNCS(lstat putenv select setenv setlocale sigsend strcoll tcgetattr)
|
|
|
|
AC_STAT_MACROS_BROKEN
|
|
MYSQL_SIGNAL_CHECK
|