pkgsrc/databases/mysql51-server/patches/patch-ag
taca 22d40b32e1 Update mysql51-{client,server} package to 5.1.51, MySQL 5.1.51.
For full changes, please refer:
	http://dev.mysql.com/doc/refman/5.1/en/news-5-1-51.html

Here is summary for security fixes:

* Security Fix: During evaluation of arguments to extreme-value
  functions (such as LEAST() and GREATEST()), type errors did not
  propagate properly, causing the server to crash. (Bug#55826)

* Security Fix: The server could crash after materializing a derived
  table that required a temporary table for grouping. (Bug#55568)

* Security Fix: A user-variable assignment expression that is
  evaluated in a logical expression context can be precalculated in a
  temporary table for GROUP BY. However, when the expression value is
  used after creation of the temporary table, it was re-evaluated, not
  read from the table and a server crash resulted. (Bug#55564)

* Security Fix: Pre-evaluation of LIKE predicates during view
  preparation could cause a server crash. (Bug#54568)

* Security Fix: GROUP_CONCAT() and WITH ROLLUP together could cause a
  server crash. (Bug#54476)

* Security Fix: Queries could cause a server crash if the GREATEST()
  or LEAST() function had a mixed list of numeric and LONGBLOB
  arguments, and the result of such a function was processed using an
  intermediate temporary table. (Bug#54461)

* Security Fix: Queries with nested joins could cause an infinite loop
  in the server when used from stored procedures and prepared
  statements. (Bug#53544)

* Security Fix: The PolyFromWKB() function could crash the server when
  improper WKB data was passed to the function. (Bug#51875)
2010-10-06 12:37:58 +00:00

21 lines
803 B
Text

$NetBSD: patch-ag,v 1.2 2010/10/06 12:37:59 taca Exp $
--- include/Makefile.in.orig 2010-09-13 13:46:47.000000000 +0000
+++ include/Makefile.in
@@ -399,15 +399,7 @@ HEADERS_GEN_MAKE = my_config.h
HEADERS_ABI = mysql.h mysql_com.h mysql_time.h \
my_list.h my_alloc.h typelib.h mysql/plugin.h
-pkginclude_HEADERS = $(HEADERS_ABI) my_dbug.h m_string.h my_sys.h \
- my_xml.h mysql_embed.h \
- my_pthread.h my_no_pthread.h \
- decimal.h errmsg.h my_global.h my_net.h \
- my_getopt.h sslopt-longopts.h my_dir.h \
- sslopt-vars.h sslopt-case.h sql_common.h keycache.h \
- m_ctype.h my_attribute.h my_compiler.h \
- $(HEADERS_GEN_CONFIGURE) \
- $(HEADERS_GEN_MAKE)
+pkginclude_HEADERS =
noinst_HEADERS = config-win.h config-netware.h my_bit.h \
heap.h my_bitmap.h my_uctype.h \