- Include standard headers (stdlib.h, string.h, stdio.h) in misc.h to avoid conflicts with built-in declarations of functions. - Change CFLAGS= in Makefile to CFLAGS+= to use pkgsrc-provided CFLAGS. - Include termcap.buildlink3.mk to handle termcap properly. - Add DESTDIR support, use AUTO_MKDIRS. - Bump PKGREVISION. Now I can actually use it! ;)
29 lines
635 B
Text
29 lines
635 B
Text
$NetBSD: patch-ab,v 1.4 2008/07/09 05:02:06 bjs Exp $
|
|
|
|
--- misc.h.orig 1998-09-23 14:07:19.000000000 -0400
|
|
+++ misc.h
|
|
@@ -8,6 +8,11 @@
|
|
|
|
#ifndef Z_INCLUDED
|
|
|
|
+#include <sys/param.h>
|
|
+#include <stdio.h>
|
|
+#include <stdlib.h>
|
|
+#include <string.h>
|
|
+
|
|
/*
|
|
** make sure that if we have a XENIX system, that
|
|
** we also treat it as an AT and T derivative
|
|
@@ -36,12 +41,6 @@ extern int *_Z_myalloc();
|
|
/*
|
|
** lines needed to shut up lint
|
|
*/
|
|
-extern char *sprintf();
|
|
-extern char *strcat();
|
|
-extern char *strncat();
|
|
-extern char *strcpy();
|
|
-extern char *strncpy();
|
|
-extern char *malloc();
|
|
|
|
extern void Z_complain();
|
|
extern void Z_fatal();
|