fc888c69cd
sequencer. Csound is a software synthesis package in the tradition of so-called music-N languages, among which the best-known is Music V. It consists of an orchestra- and score-driven executable, written in C for portability. Since Csound is a computational language, it is highly flexible and efficient; complexity is gained only at the expense of computation time. To do: - fix pthread issues in csound5 (is breaking realtime audio) - use options.mk framework for various modules - enable portaudio module (requires audio/portaudio-devel) - port portmidi to netbsd
13 lines
593 B
Text
13 lines
593 B
Text
$NetBSD: patch-ah,v 1.1.1.1 2006/05/21 22:46:22 ben Exp $
|
|
|
|
--- frontends/CsoundVST/CsoundVSTMain.cpp.orig 2005-09-02 07:30:33.000000000 -0700
|
|
+++ frontends/CsoundVST/CsoundVSTMain.cpp
|
|
@@ -36,7 +36,7 @@ bool oome = false;
|
|
#if defined(__GNUC__) && defined(WIN32)
|
|
#define main main_plugin
|
|
extern "C" __declspec(dllexport) AEffect *main_plugin (audioMasterCallback audioMaster)
|
|
-#elif defined(LINUX) || defined(MACOSX)
|
|
+#elif defined(LINUX) || defined(MACOSX) || defined(__NetBSD__)
|
|
AEffect *main_plugin (audioMasterCallback audioMaster)
|
|
#else
|
|
AEffect *main(audioMasterCallback audioMaster)
|