fc888c69cd
sequencer. Csound is a software synthesis package in the tradition of so-called music-N languages, among which the best-known is Music V. It consists of an orchestra- and score-driven executable, written in C for portability. Since Csound is a computational language, it is highly flexible and efficient; complexity is gained only at the expense of computation time. To do: - fix pthread issues in csound5 (is breaking realtime audio) - use options.mk framework for various modules - enable portaudio module (requires audio/portaudio-devel) - port portmidi to netbsd
22 lines
534 B
Text
22 lines
534 B
Text
$NetBSD: patch-al,v 1.1.1.1 2006/05/21 22:46:22 ben Exp $
|
|
|
|
--- InOut/winFLTK.c.orig 2005-12-30 07:21:18.000000000 -0800
|
|
+++ InOut/winFLTK.c
|
|
@@ -29,7 +29,7 @@
|
|
#include <stdio.h>
|
|
#include "cwindow.h"
|
|
|
|
-#ifdef LINUX
|
|
+#if defined(LINUX) || defined(__NetBSD__)
|
|
#include <X11/Xlib.h>
|
|
#endif
|
|
|
|
@@ -54,7 +54,7 @@ static void KillGraph_FLTK(CSOUND *csoun
|
|
|
|
void set_display_callbacks(CSOUND *csound)
|
|
{
|
|
-#ifdef LINUX
|
|
+#if defined(LINUX) || defined(__NetBSD__)
|
|
Display *dpy = XOpenDisplay(NULL);
|
|
if (dpy == NULL)
|
|
return;
|