pkgsrc/net/corebird/patches/patch-data_Makefile.in
mef cb0093409d (net/corebird) Updated 1.7.3 (failing to package) to 1.7.4
(pkgsrc)
 - Add adhoc patch to make it build.

(upstream)
Changelog:
 - Fix tweet sending on 32bit architectures. #795 Wtf.
 - Fix a few spelling mistakes. #798
 - Work around a GTK+ bug increasing the window size
   when typing DMs. #796
 - Prevent the list statuses page from automatically focusing
   the delete button, potentially resulting in accidentally
   deleted lists. #811
 - Show a language selection context menu in the
   compose text view. #812
2020-08-02 22:15:05 +00:00

21 lines
561 B
Text

$NetBSD: patch-data_Makefile.in,v 1.3 2020/08/02 22:15:05 mef Exp $
* Workarounf for a lack of 'msgfmt --xml' and 'msgfmt --desktop'
--- data/Makefile.in.orig 2017-01-08 09:02:29.000000000 +0000
+++ data/Makefile.in
@@ -824,12 +824,10 @@ uninstall-man: uninstall-man1
%.desktop: %.desktop.in
- msgfmt --desktop -d $(top_srcdir)/po \
- --template $< -o $@
+ cp $^ $@
%.appdata.xml: %.appdata.xml.in
- msgfmt --xml -d $(top_srcdir)/po \
- --template $< -o $@
+ cp $^ $@
@GSETTINGS_RULES@
gschemas.compiled: Makefile $(gsettings_SCHEMAS:.xml=.valid)