Pkgsrc changes: * try to fix build failure on recent NetBSD, reported in PR 41178. * set LICENSE=gnu-gpl-v2 * marked as DESTDIR ready libstatgrab NEWS: libstatgrab 0.16 (13 March 2008) * Fix saidar build on Solaris with Sun's compiler. * Add support for FreeBSD 8.0. * Fix build on "armel" Debian port. (Thanks to Riku Voipio and Martin Guy) * Fix statgrab-make-mrtg-config on machines with no swap. (Thanks to Tom Carlson) libstatgrab 0.15 (14 July 2007) * Fix breakages in memory stats on OpenBSD that were introduced in the last release. (Thanks to David Love) * Update internal string functions and some related cleanups. (Thanks to David Love) * Fix compile warning on FreeBSD. libstatgrab 0.14 (08 January 2007) * Fix memory stats on OpenBSD. * Add colour support to saidar. (Thanks to Angelina Carlton) * Fix CPU stats on Solaris - swap and iowait were incorrectly reported. * Fix kstat related memory leaks on Solaris. (Thanks to Javier Donaire) * Fix network stats on some unusual Solaris setups. * Fix process time_spent on Linux. (Thanks to Fred Barnes) * Make interface up status check the link status as well. (Thanks to Michelangelo Vassallo) * Fix build on NetBSD 3. (Thanks to Wijnand Wiersma) * Rework curses detection code in the configure script. * Fix bug that caused saidar to crash when the window was rapidly resized. libstatgrab 0.13 (19 March 2006) * Fix build problems with recent linux kernels. * Make saidar truncate disk/inteface/mount names to fit in display. * Add WIN32 support using MINGW (not widely tested). * Fix network interface up/down status on Solaris. * Add extern "C" to header file to make linking with C++ code easier. * Fix statgrab to cope with filesystem paths containing dots. * Make NFS a legal filesystem type on all platforms. * A few minor build fixes.
14 lines
576 B
Text
14 lines
576 B
Text
$NetBSD: patch-ae,v 1.2 2009/05/16 11:46:09 obache Exp $
|
|
|
|
--- src/libstatgrab/Makefile.in.orig 2008-03-13 13:59:07.000000000 +0000
|
|
+++ src/libstatgrab/Makefile.in
|
|
@@ -58,6 +58,9 @@ am__installdirs = "$(DESTDIR)$(libdir)"
|
|
libLTLIBRARIES_INSTALL = $(INSTALL)
|
|
LTLIBRARIES = $(lib_LTLIBRARIES)
|
|
libstatgrab_la_LIBADD =
|
|
+.if ${OPSYS} == "DragonFly"
|
|
+libstatgrab_la_LIBADD += -lkinfo
|
|
+.endif
|
|
am__libstatgrab_la_SOURCES_DIST = cpu_stats.c disk_stats.c \
|
|
load_stats.c memory_stats.c network_stats.c os_info.c \
|
|
page_stats.c process_stats.c swap_stats.c user_stats.c tools.c \
|