MFSA 2010-63 Information leak via XMLHttpRequest statusText MFSA 2010-62 Copy-and-paste or drag-and-drop into designMode document allows XSS MFSA 2010-61 UTF-7 XSS by overriding document charset using <object> type attribute MFSA 2010-59 SJOW creates scope chains ending in outer object MFSA 2010-58 Crash on Mac using fuzzed font in data: URL MFSA 2010-57 Crash and remote code execution in normalizeDocument MFSA 2010-56 Dangling pointer vulnerability in nsTreeContentView MFSA 2010-55 XUL tree removal crash and remote code execution MFSA 2010-54 Dangling pointer vulnerability in nsTreeSelection MFSA 2010-53 Heap buffer overflow in nsTextFrameUtils::TransformText MFSA 2010-52 Windows XP DLL loading vulnerability MFSA 2010-51 Dangling pointer vulnerability using DOM plugin array MFSA 2010-50 Frameset integer overflow vulnerability MFSA 2010-49 Miscellaneous memory safety hazards (rv:1.9.2.9/ 1.9.1.12)
30 lines
824 B
Text
30 lines
824 B
Text
$NetBSD: patch-mm,v 1.3 2010/09/09 09:41:22 tnn Exp $
|
|
|
|
Don't link with -lCstd on Solaris when using GCC. From Tim Zingelman.
|
|
part of PR pkg/39085
|
|
|
|
--- toolkit/library/Makefile.in.orig 2010-08-24 21:32:11.000000000 +0000
|
|
+++ toolkit/library/Makefile.in
|
|
@@ -253,7 +253,10 @@ EXTRA_DSO_LDOPTS += -lbe -ltracker
|
|
endif
|
|
|
|
ifeq ($(OS_ARCH),SunOS)
|
|
-EXTRA_DSO_LDOPTS += -lelf -ldemangle -lCstd
|
|
+EXTRA_DSO_LDOPTS += -lelf -ldemangle
|
|
+ifndef GNU_CC
|
|
+EXTRA_DSO_LDOPTS += -lCstd
|
|
+endif
|
|
endif
|
|
|
|
ifeq ($(OS_ARCH),AIX)
|
|
@@ -262,6 +265,10 @@ EXTRA_DSO_LDOPTS += -bbigtoc
|
|
endif
|
|
endif
|
|
|
|
+ifeq ($(OS_ARCH),NetBSD)
|
|
+EXTRA_DSO_LDOPTS += -lossaudio
|
|
+endif
|
|
+
|
|
ifeq ($(OS_ARCH),WINNT)
|
|
EXTRA_DSO_LDOPTS += $(call EXPAND_LIBNAME,shell32 ole32 uuid version winspool comdlg32 imm32 winmm wsock32 msimg32)
|
|
ifneq (,$(MOZ_DEBUG)$(NS_TRACE_MALLOC))
|