pkgsrc/archivers/innoextract/patches/patch-CMakeLists.txt
wiz eb680e7c38 Import innoextract-1.4 as archivers/innoextract, packaged for wip
by yhardy and myself.

Inno Setup is a tool to create installers for Microsoft Windows
applications. innoextract allows to extract such installers under
non-windows systems without running the actual installer using
Wine. innoextract currently supports installers created by Inno
Setup 1.2.10 to 5.5.5.
2015-04-03 09:40:54 +00:00

17 lines
546 B
Text

$NetBSD: patch-CMakeLists.txt,v 1.1 2015/04/03 09:40:54 wiz Exp $
Fix use of CMAKE_MODULE_PATH
--- CMakeLists.txt.orig 2013-05-22 21:50:31.000000000 +0200
+++ CMakeLists.txt 2013-05-22 21:52:02.000000000 +0200
@@ -45,7 +45,9 @@
include(CheckSymbolExists)
-set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake") # For custom cmake modules
+# For custom cmake modules
+set(CMAKE_CUSTOM_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
+set(CMAKE_MODULE_PATH "${CMAKE_CUSTOM_MODULE_PATH}")
include(BuildType)
include(CompileCheck)
include(CXX11Check)