pkgsrc/net/bind9/patches/patch-af
tron a4caaa600c Update "bind9" package to version 9.3.0. Changes since version 9.2.3:
- DNSSEC is now DS based (RFC 3658).
  See also RFC 3845, doc/draft/draft-ietf-dnsext-dnssec-*.
- DNSSEC lookaside validation.
- check-names is now implemented.
- rrset-order in more complete.
- IPv4/IPv6 transition support, dual-stack-servers.
- IXFR deltas can now be generated when loading master files,
  ixfr-from-differences.
- It is now possible to specify the size of a journal, max-journal-size.
- It is now possible to define a named set of master servers to be
  used in masters clause, masters.
- The advertised EDNS UDP size can now be set, edns-udp-size.
  allow-v6-synthesis has been obsoleted.
	NOTE:
	* Zones containing MD and MF will now be rejected.
	* dig, nslookup name. now report "Not Implemented" as
	  NOTIMP rather than NOTIMPL.  This will have impact on scripts
	  that are looking for NOTIMPL.
- libbind: corresponds to that from BIND 8.4.5.
2004-10-03 09:20:41 +00:00

43 lines
1.3 KiB
Text

$NetBSD: patch-af,v 1.5 2004/10/03 09:20:41 tron Exp $
--- lib/bind/configure.in.orig 2004-03-15 10:02:44.000000000 +0900
+++ lib/bind/configure.in 2004-05-16 05:09:55.000000000 +0900
@@ -367,7 +367,8 @@
[linking with PTL2 is highly experimental and not expected to work])
CC=ptlgcc
else
- if test ! -d $LOCALBASE/pthreads
+ if test ! -d $LOCALBASE/pthreads \
+ -a ! -f /usr/include/pthread.h
then
AC_MSG_RESULT(none)
use_threads=false
@@ -375,13 +376,21 @@
if $use_threads
then
- AC_MSG_RESULT(mit-pthreads/unproven-pthreads)
- pkg="$LOCALBASE/pthreads"
- lib1="-L$pkg/lib -Wl,-R$pkg/lib"
- lib2="-lpthread -lm -lgcc -lpthread"
- LIBS="$lib1 $lib2 $LIBS"
- CPPFLAGS="$CPPFLAGS -I$pkg/include"
- STD_CINCLUDES="$STD_CINCLUDES -I$pkg/include"
+ if test -f /usr/include/pthread.h
+ then
+ AC_MSG_RESULT(native pthreads)
+ LIBS="-lpthread $LIBS"
+ CPPFLAGS="$CPPFLAGS -I/usr/include"
+ STD_CINCLUDES="$STD_CINCLUDES -I/usr/include"
+ else
+ AC_MSG_RESULT(mit-pthreads/unproven-pthreads)
+ pkg="$LOCALBASE/pthreads"
+ lib1="-L$pkg/lib -Wl,-R$pkg/lib"
+ lib2="-lpthread -lm -lgcc -lpthread"
+ LIBS="$lib1 $lib2 $LIBS"
+ CPPFLAGS="$CPPFLAGS -I$pkg/include"
+ STD_CINCLUDES="$STD_CINCLUDES -I$pkg/include"
+ fi
fi
fi
;;