pkgsrc/devel/florist/patches/patch-configure.in
marino 068f113d33 devel/florist: Install in standard library locations
These updates come from FreeBSD.  Florist was never installed in standard
GNAT library locations due to the vendor Makefile.  Fix the build and
also avoid stripping the static library which removes all the symbols,
breaking florist completely.
2014-04-30 16:27:04 +00:00

25 lines
913 B
Text

$NetBSD: patch-configure.in,v 1.6 2014/04/30 16:27:04 marino Exp $
Establish DragonFly and NetBSD configuration.
--- configure.in.orig 2009-02-17 19:15:53.000000000 +0000
+++ configure.in
@@ -113,10 +113,18 @@ case ${UNAME_SYSTEM} in
echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
cp ./configs/pconfig.LynxOS ./pconfig.h.in;
;;
+ DragonFly)
+ echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
+ cp ./configs/pconfig.DragonFly ./pconfig.h.in;
+ ;;
FreeBSD)
echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
cp ./configs/pconfig.FreeBSD ./pconfig.h.in;
;;
+ NetBSD)
+ echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
+ cp ./configs/pconfig.NetBSD ./pconfig.h.in;
+ ;;
Darwin)
echo "Using Configuration for" ${UNAME_SYSTEM} ${UNAME_RELEASE};
cp ./configs/pconfig.Darwin ./pconfig.h.in;