75c4fd4fd3
* 'done' log file contains upload log. * fix the incorrect information sent to the UI when uploading a file bigger than 2GB (only the display is buggy, the transfer works). * update .spec file to support fedora (based on Sammy Atmadja modification).
22 lines
776 B
Text
22 lines
776 B
Text
$NetBSD: patch-ae,v 1.5 2010/06/02 13:07:12 adam Exp $
|
|
|
|
--- src/keyboard.c.orig 2004-01-09 18:16:01.000000000 +0000
|
|
+++ src/keyboard.c
|
|
@@ -49,8 +49,7 @@ $Id: keyboard.c,v 1.25 2004/01/09 18:16:
|
|
|
|
#include <glib.h>
|
|
|
|
-#if !(defined(BSD) && (BSD >= 199103))
|
|
- #if defined(__GNU_LIBRARY__) && !defined(_SEM_SEMUN_UNDEFINED)
|
|
+ #if (defined(__GNU_LIBRARY__) && !defined(_SEM_SEMUN_UNDEFINED)) || defined(__DragonFly__)
|
|
/* union semun is defined by including <sys/sem.h> */
|
|
#else
|
|
/* according to X/OPEN we have to define it ourselves */
|
|
@@ -61,7 +60,6 @@ $Id: keyboard.c,v 1.25 2004/01/09 18:16:
|
|
struct seminfo *__buf; /* buffer for IPC_INFO */
|
|
};
|
|
#endif
|
|
-#endif
|
|
|
|
#include "dc_com.h"
|
|
#include "display.h"
|