pkgsrc/sysutils/xentools413/patches/patch-tools_hotplug_NetBSD_Makefile
bouyer 6c43eaffe4 Add xenkernel413 and xentools413 packages, version 4.13.1.
At this time xentools413 will only build on a very recent -current (as of
an hour ago or do - with /usr/include/xen/xenio.h 1.12 or newer)

Xen is a hypervisor which supports running multiple guest operating
systems on a single machine. Guest OSes (also called "domains")
can be either paravirtualised (i.e. make hypercalls in order to
access hardware), run in HVM (Hardware Virtualisation Mode) where
they will be presented with virtual devices, or a combination where
they use hypercalls to access hardware but manage memory themselves.
At boot, the xen kernel is loaded along with the guest kernel for
the first domain (called domain0). domain0 has privileges to access
the physical hardware (PCI and ISA devices), administrate other
domains and provide virtual devices (disks and network) to other
domains.
2020-05-26 11:12:10 +00:00

52 lines
1.6 KiB
Text

$NetBSD: patch-tools_hotplug_NetBSD_Makefile,v 1.1 2020/05/26 11:12:11 bouyer Exp $
--- tools/hotplug/NetBSD/Makefile.orig 2018-04-17 19:21:31.000000000 +0200
+++ tools/hotplug/NetBSD/Makefile 2018-04-23 16:05:01.000000000 +0200
@@ -3,12 +3,13 @@
# Xen script dir and scripts to go there.
XEN_SCRIPTS =
+XEN_SCRIPTS += locking.sh
XEN_SCRIPTS += block
XEN_SCRIPTS += vif-bridge
XEN_SCRIPTS += vif-ip
XEN_SCRIPT_DATA =
-XEN_RCD_PROG = rc.d/xencommons rc.d/xendomains rc.d/xen-watchdog rc.d/xendriverdomain
+#XEN_RCD_PROG = rc.d/xencommons rc.d/xendomains rc.d/xen-watchdog rc.d/xendriverdomain
.PHONY: all
all:
@@ -24,10 +25,11 @@
.PHONY: install-scripts
install-scripts:
- $(INSTALL_DIR) $(DESTDIR)$(XEN_SCRIPT_DIR)
+ $(INSTALL_DIR) $(DESTDIR)$(XEN_EXAMPLES_DIR)
+ $(INSTALL_DIR) $(DESTDIR)$(XEN_EXAMPLES_DIR)/scripts
set -e; for i in $(XEN_SCRIPTS); \
do \
- $(INSTALL_PROG) $$i $(DESTDIR)$(XEN_SCRIPT_DIR); \
+ $(INSTALL_PROG) $$i $(DESTDIR)$(XEN_EXAMPLES_DIR)/scripts; \
done
set -e; for i in $(XEN_SCRIPT_DATA); \
do \
@@ -41,12 +43,12 @@
.PHONY: install-rcd
install-rcd:
- $(INSTALL_DIR) $(DESTDIR)$(INITD_DIR)
- set -e; for i in $(XEN_RCD_PROG); \
- do \
- $(INSTALL_PROG) $$i $(DESTDIR)$(INITD_DIR); \
- done
- $(INSTALL_DATA) ../common/hotplugpath.sh $(DESTDIR)$(INITD_DIR)/xen-hotplugpath.sh
+# $(INSTALL_DIR) $(DESTDIR)$(INITD_DIR)
+# set -e; for i in $(XEN_RCD_PROG); \
+# do \
+# $(INSTALL_PROG) $$i $(DESTDIR)$(INITD_DIR); \
+# done
+# $(INSTALL_DATA) ../common/hotplugpath.sh $(DESTDIR)$(INITD_DIR)/xen-hotplugpath.sh
.PHONY: uninstall-rcd
uninstall-rcd: