- split patches files - always enable threading which has various advantages - it fixes the build of the Tk library - it greatly simplifies the package list handling - it provides threading support under NetBSD 1.6/1.6.x - correct default dependence in "buildlink2.mk" to "build" Bump package revision because of all these changes.
22 lines
793 B
Text
22 lines
793 B
Text
$NetBSD: patch-ad,v 1.4 2004/04/22 09:18:36 tron Exp $
|
|
|
|
--- asmcomp/power/proc.ml.orig Mon Jul 22 18:37:54 2002
|
|
+++ asmcomp/power/proc.ml Thu Apr 22 10:34:38 2004
|
|
@@ -190,7 +190,7 @@
|
|
let loc_external_arguments =
|
|
match Config.system with
|
|
"aix" | "rhapsody" -> poweropen_external_conventions 0 7 100 112
|
|
- | "elf" -> calling_conventions 0 7 100 107 outgoing 8
|
|
+ | "elf" | "bsd" -> calling_conventions 0 7 100 107 outgoing 8
|
|
| _ -> assert false
|
|
|
|
let extcall_use_push = false
|
|
@@ -244,7 +244,7 @@
|
|
Ccomp.command ("as -u -m " ^ proc ^ " -o " ^ outfile ^ " " ^ infile)
|
|
| "elf" ->
|
|
Ccomp.command ("as -u -m ppc -o " ^ outfile ^ " " ^ infile)
|
|
- | "rhapsody" ->
|
|
+ | "rhapsody" | "bsd" ->
|
|
Ccomp.command ("as -o " ^ outfile ^ " " ^ infile)
|
|
| _ -> assert false
|
|
|