pkgsrc/devel/pvs/patches/patch-aa
jschauma 55f4829ce9 Upgrade to 3.0 (previous version was actually 3.0-beta.) -> bump
PKGREVISION.
Also use buildlink2 and emacs.mk for simplicity.
2002-12-20 21:37:37 +00:00

43 lines
1.2 KiB
Text

$NetBSD: patch-aa,v 1.2 2002/12/20 21:37:40 jschauma Exp $
--- pvs.orig Thu Dec 19 22:38:25 2002
+++ pvs Thu Dec 19 22:42:32 2002
@@ -46,7 +46,7 @@
# PVSPATH should be set after installation by <PVS>/bin/relocate or by hand
# to the location of the PVS installation
-PVSPATH=/project/pvs/pvs3.0
+PVSPATH=@PREFIX@/pvs/
#-------------------------------------------------
# Nothing below this line should need modification
@@ -167,6 +167,11 @@
then echo "PVS 3.0 only runs under Solaris or Linux"; exit 1
fi
PVSARCH=sun4;;
+ NetBSD) # pretend to be a redhat linux system
+ opsys=redhat
+ majvers=5
+ othervers=4
+ PVSARCH=ix86;;
Linux) # If Linux, we need to determine the Redhat version to use.
opsys=redhat
if [ ! $majvers ]; then
@@ -228,8 +233,15 @@
PVSIMAGE="$PVSLISP"
export ALLEGRO_CL_HOME DISPLAY LD_LIBRARY_PATH
-export PVSARCH PVSIMAGE PVSPATH PATH PVSLISP PVSVERBOSE PVSTIMEOUT
-export PVSPATCHLEVEL PVSMINUSQ PVSFORCEDP PVSDEFAULTDP
+export PVSARCH PVSIMAGE PVSPATH PATH PVSLISP PVSVERBOSE
+export PVSPATCHLEVEL PVSMINUSQ PVSFORCEDP
+if [ "$PVSTIMEOUT" ]; then
+ export PVSTIMEOUT
+fi
+if [ "$PVSDEFAULTDP" ]; then
+ export PVSDEFAULTDP;
+fi
+
pvsemacsinit="-load $PVSPATH/emacs/go-pvs.el $loadafter"