# Fix compilation on some systems. # Add simplified Chinese localization. # Fix compatibility with newer GNU/automake. # Add systemd configuration file. # Automatically load if_tun on FreeBSD. # Use POSIX tree instead of linked list when libJudy is missing/disabled. # Fix C pointer aliasing violations. # Fix compilation with FreeBSD 7.2 or later.
28 lines
1.1 KiB
Text
28 lines
1.1 KiB
Text
$NetBSD: patch-ah,v 1.4 2019/01/05 21:46:05 schmonz Exp $
|
|
|
|
Install client-hook to the correct location.
|
|
|
|
--- misc/Makefile.in.orig 2013-05-23 15:51:51.000000000 +0000
|
|
+++ misc/Makefile.in
|
|
@@ -337,8 +337,8 @@ install-confSCRIPTS: $(conf_SCRIPTS)
|
|
@$(NORMAL_INSTALL)
|
|
@list='$(conf_SCRIPTS)'; test -n "$(confdir)" || list=; \
|
|
if test -n "$$list"; then \
|
|
- echo " $(MKDIR_P) '$(DESTDIR)$(confdir)'"; \
|
|
- $(MKDIR_P) "$(DESTDIR)$(confdir)" || exit 1; \
|
|
+ echo " $(MKDIR_P) '$(DESTDIR)$(examplesdir)'"; \
|
|
+ $(MKDIR_P) "$(DESTDIR)$(examplesdir)" || exit 1; \
|
|
fi; \
|
|
for p in $$list; do \
|
|
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
|
@@ -357,8 +357,8 @@ install-confSCRIPTS: $(conf_SCRIPTS)
|
|
while read type dir files; do \
|
|
if test "$$dir" = .; then dir=; else dir=/$$dir; fi; \
|
|
test -z "$$files" || { \
|
|
- echo " $(INSTALL_SCRIPT) $$files '$(DESTDIR)$(confdir)$$dir'"; \
|
|
- $(INSTALL_SCRIPT) $$files "$(DESTDIR)$(confdir)$$dir" || exit $$?; \
|
|
+ echo " $(INSTALL_SCRIPT) $$files '$(DESTDIR)$(examplesdir)$$dir'"; \
|
|
+ $(INSTALL_SCRIPT) $$files "$(DESTDIR)$(examplesdir)$$dir" || exit $$?; \
|
|
} \
|
|
; done
|
|
|