pkgsrc/www/vimb/patches/patch-Makefile
leot ca32e062e3 vimb: Update to 3.4.0
Changes:
3.4.0
=====
Added
-----
* Allow to show video in fullscreen, without statusbar and inputbox, if requested.
* Added option `--no-maximize` to no start with maximized window #483.
* New setting `prevent-newwindow` to enforce opening links into same window
  even if they are crafted by `target="_blank"` or using `window.open(...)` #544.

Changed
-------
* Increased min required webkit version to 2.20.x.
* Use man page date instead of build date to make reproducible builds.
* URLs shown on statusbar and title are now shown as punicode if they contain
  homographs.

Fixed
-----
* Fix out-of-bounds buffer access in parse_command (Thanks to Sören Tempel) #529.
* Fixed none shown hint labels by Content-Security-Policy headers #531.
* Fixed segfault on JavaScript `window.close()` call #537.
* Fixed no char inserted in input mode after timeout and imap/inoremap
  candidate #546.
2019-03-31 20:52:16 +00:00

16 lines
507 B
Text

$NetBSD: patch-Makefile,v 1.1 2019/03/31 20:52:16 leot Exp $
Backport upstream commit 0eda3ec2ac78577a08ace4c18cd9e912a56609e6
to fix the build for vimb released versions.
--- Makefile.orig 2019-03-26 22:47:03.000000000 +0000
+++ Makefile
@@ -3,7 +3,7 @@ include config.mk
all: version.h src.subdir-all
-version.h: Makefile .git/index
+version.h: Makefile $(wildcard .git/index)
@echo "create $@"
$(Q)v="$$(git describe --tags 2>/dev/null)"; \
echo "#define VERSION \"$${v:-$(version)}\"" > $@