pkgsrc/emulators/pearpc/patches/patch-ad
ghen 6b9136eb08 - update pearpc to 0.4
- move options to options.mk file and reorganize a bit
- sort PLIST
- grab MAINTAINERship

ok by xtraeme.

ChangeLog for pearpc-0.4:
	- CPU: stfiwx implemented
	- config: "ppc_start_fullscreen" for starting in fullscreen mode
	- POSIX: allow bridging of tun device
	- use FISTTP instruction on SSE3 aware processors
	- merged native_cd branch from Alexander Stockinger
	- endianess fixes
	- warn that the generic CPU is slow
	- better detection of HFS+ volumes
	- support for DVD-Drives
	- correctly check for NASM
	- Work-around for graphic errors in Mac OS X 10.1
	- POSIX/Linux: fall back to 1 GHz if /proc/cpuinfo doesn't provide cpu
	  frequency
	- 3c90x emulation fixed
	- some PROM fixed for yaboot
	- alteration of x86asm interface to be more programmer friendly
	- use transparent cursors instead of altering cursor visibility (hack
	  for using PearPC with remote desktop)
	- DVD emulation implemented.  Fixes problems with Tiger installation
	- Updated the read_effective_* commands to be faster !!! REGRESSED !!!
	- fixed lvalue casts (compiles now with gcc 4.x)
	- booting from disks with bootfile about 4 GiB limit fixed
2005-12-22 19:27:36 +00:00

12 lines
346 B
Text

$NetBSD: patch-ad,v 1.1 2005/12/22 19:27:36 ghen Exp $
--- src/system/osapi/posix/sysethtun.cc.orig 2005-12-21 15:01:35.000000000 +0100
+++ src/system/osapi/posix/sysethtun.cc
@@ -33,6 +33,7 @@
#include <cstring>
#include <unistd.h>
#include <sys/wait.h>
+#include <sys/select.h>
#include "system/sysethtun.h"
#include "tools/snprintf.h"