3fd37557f7
* Set LICENSE. Changelog: http://mozilla.6506.n7.nabble.com/ANNOUNCE-NSPR-4-10-Release-td280660.html -------------- NSPR 4.10 has the following bug fixes: * Bug 331169: Obviate PR_Sleep before PR_GetConnectStatus on Windows. Fixed by Brian Smith. * Bug 687033: Support Windows/arm. Fixed by Makoto Kato (partially checked in). * Bug 687033: Remove WINCE and Win9x support partially. * Bug 844513: Add AddressSanitizer (ASan) memory check annotations to PLArena. Fixed by Mats Palmgren. * Bug 849089: Simple changes to make NSPR's configure.in work with the current version of autoconf. * Bug 856196: Fix compiler warnings and clean up code in NSPR 4.10. * Bug 859066: Fix warning in nsprpub/pr/src/misc/prnetdb.c. * Bug 859830: Deprecate ANDROID_VERSION in favor of android/api-level.h. Fixed by Vicamo Yang. * Bug 861434: Make PR_SetThreadPriority() change priorities relatively to the main process instead of using absolute values on Linux. Fixed by Gabriele Svelto. * Bug 871064L: _PR_InitThreads() should not call PR_SetThreadPriority.
22 lines
610 B
Text
22 lines
610 B
Text
$NetBSD: patch-ab,v 1.8 2013/07/20 08:57:20 ryoon Exp $
|
|
|
|
--- nsprpub/pr/include/md/_netbsd.h.orig 2012-03-06 13:13:52.000000000 +0000
|
|
+++ nspr/pr/include/md/_netbsd.h
|
|
@@ -47,7 +47,7 @@
|
|
#define HAVE_DLL
|
|
#define USE_DLFCN
|
|
#define _PR_HAVE_SOCKADDR_LEN
|
|
-#define _PR_NO_LARGE_FILES
|
|
+#define _PR_HAVE_LARGE_OFF_T
|
|
#define _PR_STAT_HAS_ST_ATIMESPEC
|
|
#define _PR_POLL_AVAILABLE
|
|
#define _PR_USE_POLL
|
|
@@ -75,6 +75,8 @@
|
|
#define JB_SP_INDEX 2
|
|
#elif defined(__mips__)
|
|
#define JB_SP_INDEX 4
|
|
+#elif defined(__amd64__)
|
|
+#define JB_SP_INDEX 6
|
|
#elif defined(__alpha__)
|
|
#define JB_SP_INDEX 34
|
|
#elif defined(__arm32__)
|