This repository has been archived on 2024-04-07. You can view files and clone it, but cannot push or open issues or pull requests.
nixos-config/user/pass.nix

27 lines
618 B
Nix

{ config, pkgs, lib, inputs, ... }: {
config = {
programs.password-store = {
enable = true;
package = pkgs.pass.withExtensions (ex: with ex; [
pass-otp
]);
};
services = {
pass-secret-service.enable = true;
git-sync = {
enable = true;
repositories.password-store = {
uri = "git@git.disroot.org:lelgenio/password-store";
path = toString config.programs.password-store.settings.PASSWORD_STORE_DIR;
};
};
};
home.packages = with pkgs; [
wpass
_gpg-unlock
qtpass
readQrCode
];
};
}