This repository has been archived on 2024-04-07. You can view files and clone it, but cannot push or open issues or pull requests.
nixos-config/user/ssh.nix

20 lines
397 B
Nix

{ config, pkgs, lib, ... }:
let inherit (pkgs.uservars) username mail;
in {
config = {
programs.ssh.enable = true;
programs.ssh.matchBlocks = {
monolith = {
user = "lelgenio";
hostname = "lelgenio.1337.cx";
port = 9022;
};
phantom = {
user = "root";
hostname = "phantom.lelgenio.xyz";
port = 9022;
};
};
};
}