PKGBUILDS/proton-caller-git/0001-revision.patch
2022-02-19 22:32:52 -06:00

87 lines
2.3 KiB
Diff

From 9dbdef54f689cc246c90cdac61b2c018c1869310 Mon Sep 17 00:00:00 2001
From: FabioLolix <fabio.loli@disroot.org>
Date: Fri, 11 Dec 2020 19:22:24 +0100
Subject: [PATCH] revision
---
.SRCINFO | 5 +++--
PKGBUILD | 26 +++++++++++++-------------
2 files changed, 16 insertions(+), 15 deletions(-)
diff --git a/.SRCINFO b/.SRCINFO
index 72d30bc..00b57d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = proton-caller-git
pkgdesc = Run any Windows program through Proton
- pkgver = 1.4.0
+ pkgver = 1.3.2.r10.g3b2fc50
pkgrel = 1
url = https://github.com/caverym/Proton-Caller/
arch = x86_64
license = GPL3
+ makedepends = git
depends = steam
depends = dxvk
- depends = git
+ provides = proton-caller
conflicts = proton-caller
source = git+https://github.com/caverym/Proton-Caller.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1351c94..fd696e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,7 @@
# Maintainer: Avery Murray <averylapine@gmail.com>
-_pkgname=proton-call
pkgname=proton-caller-git
-__pkgname=Proton-Caller
-pkgver=1.4.0
+pkgver=1.3.2.r10.g3b2fc50
pkgrel=1
pkgdesc="Run any Windows program through Proton"
arch=('x86_64')
@@ -12,25 +10,27 @@ license=('GPL3')
depends=(
'steam'
'dxvk'
- 'git'
)
+makedepends=('git')
+provides=(proton-caller)
conflicts=(proton-caller)
-source=("git+https://github.com/caverym/$__pkgname.git")
+source=("git+https://github.com/caverym/Proton-Caller.git")
sha256sums=('SKIP')
+pkgver() {
+ cd Proton-Caller
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd Proton-Caller
make
}
package() {
- ls
- mkdir -p "$pkgdir"/usr/share/licenses/proton-call/
- mkdir -p "$pkgdir"/usr/bin/
- mkdir -p "$pkgdir"/usr/share/man/man6/
- install -g 0 -o 0 $__pkgname/proton-call "$pkgdir"/usr/bin/
- install -g 0 -o 0 $__pkgname/LICENSE "$pkgdir"/usr/share/licenses/proton-call/
- install -g 0 -o 0 -m 0644 $__pkgname/manual/proton-call.6 "$pkgdir"/usr/share/man/man6/
- gzip -f "$pkgdir"/usr/share/man/man6/proton-call.6
+ cd Proton-Caller
+ install -Dm755 proton-call "$pkgdir"/usr/bin/proton-call
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 manual/proton-call.6 "$pkgdir"/usr/share/man/man6/proton-call.6
}
--
2.29.2