gnu: Add aws-c-compression.

* gnu/packages/c.scm (aws-c-compression): New variable.
* gnu/packages/patches/aws-c-compression-cmake-prefix.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Greg Hogan 2021-04-30 13:59:30 +00:00 committed by Ludovic Courtès
parent d9b8cfd6c6
commit 2069238cb3
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 41 additions and 0 deletions

View File

@ -870,6 +870,7 @@ dist_patch_DATA = \
%D%/packages/patches/avidemux-install-to-lib.patch \
%D%/packages/patches/awesome-reproducible-png.patch \
%D%/packages/patches/aws-c-cal-cmake-prefix.patch \
%D%/packages/patches/aws-c-compression-cmake-prefix.patch \
%D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
%D%/packages/patches/aws-c-http-cmake-prefix.patch \
%D%/packages/patches/aws-c-http-disable-networking-tests.patch\

View File

@ -743,3 +743,30 @@ low level functionality for coroutines.")
specifications.")
(home-page "https://github.com/awslabs/aws-c-http")
(license license:asl2.0)))
(define-public aws-c-compression
(package
(name "aws-c-compression")
(version "0.2.13")
(source (origin
(method git-fetch)
(uri (git-reference
(url (string-append "https://github.com/awslabs/" name))
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"0zqfxi0fdgapfsfgvsindv63pq7vyl1s376qkpv4jgflyb1v6gp5"))
(patches (search-patches "aws-c-compression-cmake-prefix.patch"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
'("-DBUILD_SHARED_LIBS=ON")))
(propagated-inputs
`(("aws-c-common" ,aws-c-common)))
(synopsis "Amazon Web Services compression library")
(description
"This library provides a C99 implementation of compression algorithms,
currently limited to Huffman encoding and decoding.")
(home-page "https://github.com/awslabs/aws-c-compression")
(license license:asl2.0)))

View File

@ -0,0 +1,13 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,6 +5,10 @@ if (POLICY CMP0069)
cmake_policy(SET CMP0069 NEW) # Enable LTO/IPO if available in the compiler, see AwsCFlags
endif()
+if (DEFINED ENV{CMAKE_PREFIX_PATH})
+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
+endif()
+
if (DEFINED CMAKE_PREFIX_PATH)
file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
endif()