This plugin writes a msg header summary to a log file (Default: ~/Mail/NewLog)

on arrival of new mail *after* sorting.

PR:		ports/95481
Submitted by:	Pawel Pekala <c0rn@o2.pl>
This commit is contained in:
Pav Lucistnik 2006-04-29 15:02:56 +00:00
parent 8280754ea7
commit 0ca6315ec5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=160786
9 changed files with 97 additions and 0 deletions

View file

@ -528,6 +528,7 @@
SUBDIR += sylpheed-claws-etpan_privacy
SUBDIR += sylpheed-claws-fetchinfo
SUBDIR += sylpheed-claws-mailmbox
SUBDIR += sylpheed-claws-newmail
SUBDIR += sylpheed-claws-perl
SUBDIR += sylpheed-claws-smime
SUBDIR += sylpheed2

View file

@ -0,0 +1,28 @@
# New ports collection makefile for: sylpheed-claws-newmail
# Date created: 7 April 2006
# Whom: Pawel Pekala <c0rn@o2.pl>
#
# $FreeBSD$
#
PORTNAME= newmail
PORTVERSION= 0.0.3
CATEGORIES= mail
MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
PKGNAMEPREFIX= sylpheed-claws-
MAINTAINER= c0rn@o2.pl
COMMENT= Message header summary logging plugin for sylpheed-claws
BUILD_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
RUN_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_AUTOTOOLS= autoconf:259
PLIST_FILES=lib/sylpheed-claws/plugins/newmail.a \
lib/sylpheed-claws/plugins/newmail.la \
lib/sylpheed-claws/plugins/newmail.so
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
MD5 (newmail-0.0.3.tar.gz) = 47127ccef56a0b218aab3a4d8c2eacb8
SHA256 (newmail-0.0.3.tar.gz) = 0f2671675bdf924d0f2d316fc3fad8d9db641b96a5638f9008504f4239f720f3
SIZE (newmail-0.0.3.tar.gz) = 316825

View file

@ -0,0 +1,15 @@
--- configure.ac.orig Fri Apr 7 16:17:27 2006
+++ configure.ac Fri Apr 7 16:19:51 2006
@@ -45,7 +45,11 @@
dnl check for sylpheed-claws
PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 1.9.100.93)
-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
+if test -z $prefix ; then
+ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
+else
+ SYLPHEED_CLAWS_PLUGINDIR=${prefix}/lib/sylpheed-claws/plugins
+fi
AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
AC_SUBST(SYLPHEED_CLAWS_LIBS)
AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)

View file

@ -0,0 +1,2 @@
This plugin writes a msg header summary to a log file (Default: ~/Mail/NewLog)
on arrival of new mail *after* sorting.

View file

@ -0,0 +1,28 @@
# New ports collection makefile for: sylpheed-claws-newmail
# Date created: 7 April 2006
# Whom: Pawel Pekala <c0rn@o2.pl>
#
# $FreeBSD$
#
PORTNAME= newmail
PORTVERSION= 0.0.3
CATEGORIES= mail
MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
PKGNAMEPREFIX= sylpheed-claws-
MAINTAINER= c0rn@o2.pl
COMMENT= Message header summary logging plugin for sylpheed-claws
BUILD_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
RUN_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_AUTOTOOLS= autoconf:259
PLIST_FILES=lib/sylpheed-claws/plugins/newmail.a \
lib/sylpheed-claws/plugins/newmail.la \
lib/sylpheed-claws/plugins/newmail.so
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
MD5 (newmail-0.0.3.tar.gz) = 47127ccef56a0b218aab3a4d8c2eacb8
SHA256 (newmail-0.0.3.tar.gz) = 0f2671675bdf924d0f2d316fc3fad8d9db641b96a5638f9008504f4239f720f3
SIZE (newmail-0.0.3.tar.gz) = 316825

View file

@ -0,0 +1,15 @@
--- configure.ac.orig Fri Apr 7 16:17:27 2006
+++ configure.ac Fri Apr 7 16:19:51 2006
@@ -45,7 +45,11 @@
dnl check for sylpheed-claws
PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 1.9.100.93)
-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
+if test -z $prefix ; then
+ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
+else
+ SYLPHEED_CLAWS_PLUGINDIR=${prefix}/lib/sylpheed-claws/plugins
+fi
AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
AC_SUBST(SYLPHEED_CLAWS_LIBS)
AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)

View file

@ -0,0 +1,2 @@
This plugin writes a msg header summary to a log file (Default: ~/Mail/NewLog)
on arrival of new mail *after* sorting.