- Update to 3.20110702
- Un-break build PR: ports/158667 Submitted by: Fraser Tweedale <frase@frase.id.au> (maintainer)
This commit is contained in:
parent
4bfa1d79aa
commit
0f8d3c8c38
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=278696
6 changed files with 46 additions and 34 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= git-annex
|
||||
PORTVERSION= 0.20110601
|
||||
PORTVERSION= 3.20110702
|
||||
CATEGORIES= devel haskell
|
||||
MASTER_SITES= http://git.kitenet.net/?p=git-annex.git;a=snapshot;sf=tgz;h=refs/tags/
|
||||
DISTFILES= ${PORTVERSION}
|
||||
|
@ -20,24 +20,32 @@ BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
|
|||
hs-pcre-light>=0:${PORTSDIR}/devel/hs-pcre-light \
|
||||
hs-utf8-string>=0:${PORTSDIR}/devel/hs-utf8-string \
|
||||
hs-SHA>=0:${PORTSDIR}/security/hs-SHA \
|
||||
hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc
|
||||
hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc \
|
||||
hs-curl>0:${PORTSDIR}/ftp/hs-curl \
|
||||
git:${PORTSDIR}/devel/git \
|
||||
rsync:${PORTSDIR}/net/rsync
|
||||
|
||||
RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
|
||||
hs-MissingH>=0:${PORTSDIR}/devel/hs-MissingH \
|
||||
hs-pcre-light>=0:${PORTSDIR}/devel/hs-pcre-light \
|
||||
hs-utf8-string>=0:${PORTSDIR}/devel/hs-utf8-string \
|
||||
hs-SHA>=0:${PORTSDIR}/security/hs-SHA \
|
||||
hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc
|
||||
|
||||
BROKEN= does not configure
|
||||
hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc \
|
||||
hs-curl>0:${PORTSDIR}/ftp/hs-curl \
|
||||
git:${PORTSDIR}/devel/git \
|
||||
rsync:${PORTSDIR}/net/rsync
|
||||
|
||||
USE_PERL5= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
MAN1= git-annex.1 git-annex-shell.1
|
||||
MAN1= git-annex.1 \
|
||||
git-annex-shell.1 \
|
||||
git-union-merge.1
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
PLIST_FILES= bin/git-annex \
|
||||
bin/git-annex-shell
|
||||
bin/git-annex-shell \
|
||||
bin/git-union-merge
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (git-annex/0.20110601) = 2718e5634a4384d8a2a284bac66f1cff76d2c048b6c57662c24c575a97e9193b
|
||||
SIZE (git-annex/0.20110601) = 358008
|
||||
SHA256 (git-annex/3.20110702) = 66d633bcbd49d4a34b241222bf83f35e85af3207454de3fde4afaf1dd1409580
|
||||
SIZE (git-annex/3.20110702) = 378351
|
||||
|
|
|
@ -1,14 +1,12 @@
|
|||
diff --git a/Makefile b/Makefile
|
||||
index 286c3a6..3ed7a59 100644
|
||||
--- Makefile
|
||||
+++ Makefile
|
||||
--- ./Makefile.orig 2011-07-02 21:08:05.000000000 +0200
|
||||
+++ ./Makefile 2011-08-01 09:35:21.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-PREFIX=/usr
|
||||
+PREFIX=/usr/local
|
||||
+PREFIX?=/usr/local
|
||||
IGNORE=-ignore-package monads-fd
|
||||
GHCFLAGS=-O2 -Wall $(IGNORE) -fspec-constr-count=5
|
||||
ifdef PROFILE
|
||||
@@ -37,12 +37,8 @@ git-annex-shell.1: doc/git-annex-shell.mdwn
|
||||
@@ -43,12 +43,8 @@
|
||||
install: all
|
||||
install -d $(DESTDIR)$(PREFIX)/bin
|
||||
install $(bins) $(DESTDIR)$(PREFIX)/bin
|
||||
|
@ -22,8 +20,8 @@ index 286c3a6..3ed7a59 100644
|
|||
+ install -m 0644 $(mans) $(DESTDIR)$(PREFIX)/man/man1
|
||||
|
||||
test: $(bins)
|
||||
if ! $(GHCMAKE) -O0 test; then \
|
||||
@@ -59,21 +55,7 @@ testcoverage: $(bins)
|
||||
@if ! $(GHCMAKE) -O0 test; then \
|
||||
@@ -65,21 +61,7 @@
|
||||
@hpc report test --exclude=Main --exclude=QC
|
||||
@hpc markup test --exclude=Main --exclude=QC --destdir=.hpc >/dev/null
|
||||
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= git-annex
|
||||
PORTVERSION= 0.20110601
|
||||
PORTVERSION= 3.20110702
|
||||
CATEGORIES= devel haskell
|
||||
MASTER_SITES= http://git.kitenet.net/?p=git-annex.git;a=snapshot;sf=tgz;h=refs/tags/
|
||||
DISTFILES= ${PORTVERSION}
|
||||
|
@ -20,24 +20,32 @@ BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
|
|||
hs-pcre-light>=0:${PORTSDIR}/devel/hs-pcre-light \
|
||||
hs-utf8-string>=0:${PORTSDIR}/devel/hs-utf8-string \
|
||||
hs-SHA>=0:${PORTSDIR}/security/hs-SHA \
|
||||
hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc
|
||||
hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc \
|
||||
hs-curl>0:${PORTSDIR}/ftp/hs-curl \
|
||||
git:${PORTSDIR}/devel/git \
|
||||
rsync:${PORTSDIR}/net/rsync
|
||||
|
||||
RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
|
||||
hs-MissingH>=0:${PORTSDIR}/devel/hs-MissingH \
|
||||
hs-pcre-light>=0:${PORTSDIR}/devel/hs-pcre-light \
|
||||
hs-utf8-string>=0:${PORTSDIR}/devel/hs-utf8-string \
|
||||
hs-SHA>=0:${PORTSDIR}/security/hs-SHA \
|
||||
hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc
|
||||
|
||||
BROKEN= does not configure
|
||||
hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc \
|
||||
hs-curl>0:${PORTSDIR}/ftp/hs-curl \
|
||||
git:${PORTSDIR}/devel/git \
|
||||
rsync:${PORTSDIR}/net/rsync
|
||||
|
||||
USE_PERL5= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
MAN1= git-annex.1 git-annex-shell.1
|
||||
MAN1= git-annex.1 \
|
||||
git-annex-shell.1 \
|
||||
git-union-merge.1
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
PLIST_FILES= bin/git-annex \
|
||||
bin/git-annex-shell
|
||||
bin/git-annex-shell \
|
||||
bin/git-union-merge
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (git-annex/0.20110601) = 2718e5634a4384d8a2a284bac66f1cff76d2c048b6c57662c24c575a97e9193b
|
||||
SIZE (git-annex/0.20110601) = 358008
|
||||
SHA256 (git-annex/3.20110702) = 66d633bcbd49d4a34b241222bf83f35e85af3207454de3fde4afaf1dd1409580
|
||||
SIZE (git-annex/3.20110702) = 378351
|
||||
|
|
|
@ -1,14 +1,12 @@
|
|||
diff --git a/Makefile b/Makefile
|
||||
index 286c3a6..3ed7a59 100644
|
||||
--- Makefile
|
||||
+++ Makefile
|
||||
--- ./Makefile.orig 2011-07-02 21:08:05.000000000 +0200
|
||||
+++ ./Makefile 2011-08-01 09:35:21.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-PREFIX=/usr
|
||||
+PREFIX=/usr/local
|
||||
+PREFIX?=/usr/local
|
||||
IGNORE=-ignore-package monads-fd
|
||||
GHCFLAGS=-O2 -Wall $(IGNORE) -fspec-constr-count=5
|
||||
ifdef PROFILE
|
||||
@@ -37,12 +37,8 @@ git-annex-shell.1: doc/git-annex-shell.mdwn
|
||||
@@ -43,12 +43,8 @@
|
||||
install: all
|
||||
install -d $(DESTDIR)$(PREFIX)/bin
|
||||
install $(bins) $(DESTDIR)$(PREFIX)/bin
|
||||
|
@ -22,8 +20,8 @@ index 286c3a6..3ed7a59 100644
|
|||
+ install -m 0644 $(mans) $(DESTDIR)$(PREFIX)/man/man1
|
||||
|
||||
test: $(bins)
|
||||
if ! $(GHCMAKE) -O0 test; then \
|
||||
@@ -59,21 +55,7 @@ testcoverage: $(bins)
|
||||
@if ! $(GHCMAKE) -O0 test; then \
|
||||
@@ -65,21 +61,7 @@
|
||||
@hpc report test --exclude=Main --exclude=QC
|
||||
@hpc markup test --exclude=Main --exclude=QC --destdir=.hpc >/dev/null
|
||||
|
||||
|
|
Loading…
Reference in a new issue