multimedia/butt: update 0.1.27 -> 0.1.40

PR:		253377
Changes:	https://danielnoethen.de/butt/Changelog.html
This commit is contained in:
Kurt Jaeger 2024-03-16 22:28:51 +01:00
parent 8d98869f0d
commit 3e9a8d8c51
4 changed files with 25 additions and 16 deletions

View File

@ -1,8 +1,7 @@
PORTNAME= butt
PORTVERSION= 0.1.27
PORTREVISION= 3
PORTVERSION= 0.1.40
CATEGORIES= multimedia graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MASTER_SITES= https://danielnoethen.de/butt/release/${PORTVERSION}/
MAINTAINER= pi@FreeBSD.org
COMMENT= Broadcast SHOUTcast and Icecast streams
@ -10,7 +9,8 @@ WWW= https://danielnoethen.de/butt/
LICENSE= GPLv2
LIB_DEPENDS= libdbus-1.so:devel/dbus \
LIB_DEPENDS= libcurl.so:ftp/curl \
libdbus-1.so:devel/dbus \
libFLAC.so:audio/flac \
libfdk-aac.so:audio/fdk-aac \
libfltk_images.so:x11-toolkits/fltk \
@ -27,6 +27,13 @@ USES= autoreconf compiler:c++11-lang gettext \
gmake jpeg pkgconfig xorg ssl uidfix
USE_XORG= x11 xrender xcursor xfixes xext xft xinerama
GNU_CONFIGURE= yes
PLIST_FILES= bin/butt share/locale/de/LC_MESSAGES/butt.mo
CFLAGS+= -I/usr/local/include
LDFLAGS+= -L/usr/local/lib -lintl
PLIST_FILES= bin/butt \
share/locale/de/LC_MESSAGES/butt.mo \
share/locale/es/LC_MESSAGES/butt.mo \
share/locale/fr/LC_MESSAGES/butt.mo \
share/locale/nl/LC_MESSAGES/butt.mo \
share/locale/pt_BR/LC_MESSAGES/butt.mo
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1609088325
SHA256 (butt-0.1.27.tar.gz) = e19a9b457414d2ca68947b49f4c3180ca8b3210b1c4f3925d71eacf1d47bab87
SIZE (butt-0.1.27.tar.gz) = 1081649
TIMESTAMP = 1710623303
SHA256 (butt-0.1.40.tar.gz) = c1a835efb50843a6290642795d097162d4dd04514d3b9abe04b0ff0a25241a80
SIZE (butt-0.1.40.tar.gz) = 1572022

View File

@ -0,0 +1,10 @@
--- src/FLTK/fl_funcs.cpp.orig 2024-03-16 22:11:54.230417000 +0100
+++ src/FLTK/fl_funcs.cpp 2024-03-16 22:12:06.912058000 +0100
@@ -19,6 +19,7 @@
#include <signal.h>
#include <time.h>
#include <sys/stat.h>
+#include <sys/syslimits.h>
#ifndef WIN32
#include <sys/wait.h>

View File

@ -1,13 +1,5 @@
--- src/Makefile.am.orig 2020-12-27 21:27:17.416688000 +0100
+++ src/Makefile.am 2020-12-27 21:27:34.578674000 +0100
@@ -25,7 +25,6 @@
if WINDOWS
butt_SOURCES += resource.rc currentTrack.h currentTrack.cpp
AM_CPPFLAGS += -DHAVE_LIBFDK_AAC
-LDADD = -lintl
endif
if OSX
@@ -38,6 +37,7 @@
if FREEBSD