New port: zh-cce.
Yet another Chinese console. onsole Chinese Environment - display Chinese (GB) on console CCE is a Console Chinese Environment like WZCE, yact & chdrv that lets you display and input Chinese (GB) at the console. Input methods include PinYin, WuBi, ShuangPin and ZiranMa. I made slightly difference against original PR. Treat distro patch `as-is', instead of bloating our repo. PR: ports/37255 Submitted by: Statue <statue@softwareliberty.org>
This commit is contained in:
parent
96ec407787
commit
4df311db14
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=63932
8 changed files with 127 additions and 0 deletions
|
@ -18,6 +18,7 @@
|
|||
SUBDIR += bind8
|
||||
SUBDIR += bitchx
|
||||
SUBDIR += c2t
|
||||
SUBDIR += cce
|
||||
SUBDIR += celvis
|
||||
SUBDIR += chinput
|
||||
SUBDIR += chinput2
|
||||
|
|
32
chinese/cce/Makefile
Normal file
32
chinese/cce/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
|||
# New ports collection makefile for: cce
|
||||
# Date created: 10 Mar 2001
|
||||
# Whom: Shen Chuan-Hsing
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= cce
|
||||
PORTVERSION= 0.36
|
||||
CATEGORIES= chinese
|
||||
MASTER_SITES= http://programmer.lib.sjtu.edu.cn/cce/ \
|
||||
ftp://freebsd.sinica.edu.tw/pub/statue/cce/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-05052000
|
||||
|
||||
PATCH_SITES= ${MASTER_SITES}
|
||||
PATCHFILES= cce-0.36_security.ukai-lin-fok.patch.gz
|
||||
PATCH_DIST_ARGS= -d ${WRKSRC} -p1
|
||||
|
||||
MAINTAINER= statue@freebsd.sinica.edu.tw
|
||||
|
||||
MAN1= cce.1
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
pre-configure:
|
||||
(cd ${WRKSRC} && ${LN} -fs Makefile.FreeBSD Makefile )
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
post-patch:
|
||||
.if ${OSVERSION} > 500012
|
||||
@${FIND} ${WRKSRC}/src/ -name "*.c" | ${XARGS} ${PERL} -pi.bak -e 's,machine/console.h>,sys/consio.h>\n#include <sys/fbio.h>\n#include <sys/kbio.h>\n,'
|
||||
.endif
|
||||
.include <bsd.port.post.mk>
|
2
chinese/cce/distinfo
Normal file
2
chinese/cce/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (cce-0.36-05052000.tar.gz) = 994f4bb42e6cdd833e235b52f28018dc
|
||||
MD5 (cce-0.36_security.ukai-lin-fok.patch.gz) = 16e695c266e36ff6d320615531403874
|
16
chinese/cce/files/patch-config.FreeBSD
Normal file
16
chinese/cce/files/patch-config.FreeBSD
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- config.FreeBSD.orig Sun Sep 5 06:36:36 1999
|
||||
+++ config.FreeBSD Fri Apr 19 22:53:55 2002
|
||||
@@ -1,9 +1,9 @@
|
||||
INCDIR = ../include
|
||||
TOPDIR =
|
||||
-BINDIR = $(TOPDIR)/usr/bin
|
||||
-LIBDIR = $(TOPDIR)/usr/lib/cce
|
||||
-MANDIR = $(TOPDIR)/usr/share/man/man1
|
||||
-FONTDIR = $(TOPDIR)/usr/lib/cce
|
||||
+BINDIR = $(TOPDIR)/usr/local/bin
|
||||
+LIBDIR = $(TOPDIR)/usr/local/lib/cce
|
||||
+MANDIR = $(TOPDIR)/usr/local/man/man1
|
||||
+FONTDIR = $(TOPDIR)/usr/local/lib/cce
|
||||
CCECFG = cce.cfg
|
||||
|
||||
OPTS = -DHAS_MOUSE -DCONFIG_NAME=\"$(LIBDIR)/$(CCECFG)\" -I$(INCDIR) \
|
43
chinese/cce/files/patch-src::cce.cfg
Normal file
43
chinese/cce/files/patch-src::cce.cfg
Normal file
|
@ -0,0 +1,43 @@
|
|||
--- src/cce.cfg.orig Sun Feb 18 23:00:32 2001
|
||||
+++ src/cce.cfg Sun Feb 18 23:01:01 2001
|
||||
@@ -24,14 +24,14 @@
|
||||
#
|
||||
#
|
||||
gb: Font
|
||||
- /usr/lib/cce/8x16.bin
|
||||
- /usr/lib/cce/gb16fs.bin
|
||||
+ /usr/local/lib/cce/8x16.bin
|
||||
+ /usr/local/lib/cce/gb16fs.bin
|
||||
big5:
|
||||
- /usr/lib/cce/8x16.bin
|
||||
- /usr/lib/cce/taipei16.bin
|
||||
+ /usr/local/lib/cce/8x16.bin
|
||||
+ /usr/local/lib/cce/taipei16.bin
|
||||
jis:
|
||||
- /usr/lib/cce/7x14rk.bin
|
||||
- /usr/lib/cce/k14.bin
|
||||
+ /usr/local/lib/cce/7x14rk.bin
|
||||
+ /usr/local/lib/cce/k14.bin
|
||||
|
||||
* Input Methods
|
||||
# Ctrl+Alt+0 PinYin Input Method
|
||||
@@ -39,8 +39,8 @@
|
||||
# Ctrl+Alt+1-8 you can define below
|
||||
#
|
||||
gb: InputMethod
|
||||
- /usr/lib/cce/pinyin.tab
|
||||
- /usr/lib/cce/wubi.tab
|
||||
+ /usr/local/lib/cce/pinyin.tab
|
||||
+ /usr/local/lib/cce/wubi.tab
|
||||
|
||||
big5:
|
||||
|
||||
@@ -134,7 +134,7 @@
|
||||
zh_TW.big5:
|
||||
ISO8859-1 BIG5.HKU-0
|
||||
|
||||
-zh_CN.ugb: Coding
|
||||
+zh_CN.EUC: Coding
|
||||
ISO8859-1 GB2312.1980-0 GB
|
||||
|
||||
ko_KR.euc:
|
1
chinese/cce/pkg-comment
Normal file
1
chinese/cce/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
GB Chinese console
|
6
chinese/cce/pkg-descr
Normal file
6
chinese/cce/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
Console Chinese Environment - display Chinese (GB) on console
|
||||
CCE is a Console Chinese Environment like WZCE, yact & chdrv that
|
||||
lets you display and input Chinese (GB) at the console. Input
|
||||
methods include PinYin, WuBi, ShuangPin and ZiranMa.
|
||||
|
||||
WWW: http://programmer.lib.sjtu.edu.cn/cce/cce.html
|
26
chinese/cce/pkg-plist
Normal file
26
chinese/cce/pkg-plist
Normal file
|
@ -0,0 +1,26 @@
|
|||
bin/cce
|
||||
lib/cce/8x16.bin
|
||||
lib/cce/bdf2bin
|
||||
lib/cce/cce.cfg
|
||||
lib/cce/cin2tab
|
||||
lib/cce/gb16fs.bin
|
||||
lib/cce/pinyin.map
|
||||
lib/cce/pinyin.tab
|
||||
lib/cce/pinyin.tab.lx
|
||||
lib/cce/pinyin.tab.phr
|
||||
lib/cce/sharefont
|
||||
lib/cce/shuangpin.tab
|
||||
lib/cce/shuangpin.tab.lx
|
||||
lib/cce/shuangpin.tab.phr
|
||||
lib/cce/sysphrase.tab
|
||||
lib/cce/tab2cin
|
||||
lib/cce/tab2txt
|
||||
lib/cce/txt2tab
|
||||
lib/cce/usrphrase.tab
|
||||
lib/cce/wubi.tab
|
||||
lib/cce/wubi.tab.lx
|
||||
lib/cce/wubi.tab.phr
|
||||
lib/cce/ziranma.tab
|
||||
lib/cce/ziranma.tab.lx
|
||||
lib/cce/ziranma.tab.phr
|
||||
@dirrm lib/cce
|
Loading…
Reference in a new issue