EIJIRO English - Japanese Dictionary (EPWING V1 format)
This commit is contained in:
parent
e2d6082a71
commit
52d76f653c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36168
7 changed files with 95 additions and 0 deletions
|
@ -42,6 +42,7 @@
|
|||
SUBDIR += edict-fpw
|
||||
SUBDIR += edict-sdic
|
||||
SUBDIR += ee
|
||||
SUBDIR += eijiro-fpw
|
||||
SUBDIR += elisa10x8
|
||||
SUBDIR += elisa8x8
|
||||
SUBDIR += elisp-manual
|
||||
|
|
57
japanese/eijiro-fpw/Makefile
Normal file
57
japanese/eijiro-fpw/Makefile
Normal file
|
@ -0,0 +1,57 @@
|
|||
# New ports collection makefile for: EIJIRO Dictionary - JIS X 4081 version
|
||||
# Date created: 2000.11.28
|
||||
# Whom: Satoshi Taoka <taoka@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= eijiro-fpw
|
||||
PORTVERSION= 1.0b
|
||||
CATEGORIES= japanese
|
||||
MASTER_SITES= http://openlab.ring.gr.jp/edict/fpw/dist/eijiro/
|
||||
DISTNAME= ${PORTNAME}${PORTVERSION}-src
|
||||
|
||||
MAINTAINER= taoka@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/share/doc/freepwing/fpwutils.mk:${PORTSDIR}/japanese/freepwing \
|
||||
catdump:${PORTSDIR}/japanese/epwutil \
|
||||
nkf:${PORTSDIR}/japanese/nkf \
|
||||
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
|
||||
|
||||
RESTRICTED= "The original dictionary is not free"
|
||||
USE_GMAKE= yes
|
||||
WRKSRC= ${WRKDIR}/eijiro-fpw${PORTVERSION}
|
||||
DICT_PATH?= /cdrom
|
||||
SRCFILE?= EIJI37??.TXT
|
||||
MAKE_ENV= PORT_SRCFILE=${DICT_PATH}/${SRCFILE}
|
||||
|
||||
post-extract:
|
||||
@if [ ! -f ${DICT_PATH}/${SRCFILE} ]; then \
|
||||
${ECHO} "###################################################"; \
|
||||
${ECHO} "I cannot find a file ${DICT_PATH}/${SRCFILE}"; \
|
||||
${ECHO} "Specify the Eijiro Dictionary file with the full path"; \
|
||||
${ECHO} "and excecute the following command again:"; \
|
||||
${ECHO} " make DICT_PATH=${DICT_PATH} SRCFILE=${SRCFILE}"; \
|
||||
${ECHO} ""; \
|
||||
${ECHO} "Notice: DICT_PATH must be a full path to the file."; \
|
||||
${ECHO} "###################################################"; \
|
||||
${FALSE}; \
|
||||
fi
|
||||
${CP} ${LOCALBASE}/share/doc/freepwing/fpwutils.mk ${WRKSRC}
|
||||
|
||||
post-build:
|
||||
cd ${WRKSRC}; nkf -eSd catalogs.sjis > catalogs.txt; \
|
||||
catdump -u catalogs.txt catalogs
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/share/dict/eijiro-fpw/eijiro/data
|
||||
${INSTALL_DATA} ${WRKSRC}/honmon ${PREFIX}/share/dict/eijiro-fpw/eijiro/data
|
||||
${INSTALL_DATA} ${WRKSRC}/catalogs ${PREFIX}/share/dict/eijiro-fpw
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/eijiro-fpw
|
||||
.for i in readme.sjis
|
||||
${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/doc/eijiro-fpw
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
japanese/eijiro-fpw/distinfo
Normal file
1
japanese/eijiro-fpw/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (eijiro-fpw1.0b-src.tar.gz) = fd4da7feb5d7211d651c84ffbe3cc416
|
12
japanese/eijiro-fpw/files/patch-aa
Normal file
12
japanese/eijiro-fpw/files/patch-aa
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- ../orig/eijiro-fpw1.0b/Makefile Sun Oct 8 23:40:55 2000
|
||||
+++ Makefile Thu Dec 21 12:03:11 2000
|
||||
@@ -17,7 +17,8 @@
|
||||
#
|
||||
EIJIROVER = 37
|
||||
SRCDIR = .
|
||||
-SRCFILE := $(wildcard ${SRCDIR}/EIJI${EIJIROVER}??.TXT)
|
||||
+#SRCFILE := $(wildcard ${SRCDIR}/EIJI${EIJIROVER}??.TXT)
|
||||
+SRCFILE=${PORT_SRCFILE}
|
||||
#SRCFILE = test.txt
|
||||
|
||||
#
|
1
japanese/eijiro-fpw/pkg-comment
Normal file
1
japanese/eijiro-fpw/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
EIJIRO English - Japanese Dictionary (EPWING V1 format)
|
16
japanese/eijiro-fpw/pkg-descr
Normal file
16
japanese/eijiro-fpw/pkg-descr
Normal file
|
@ -0,0 +1,16 @@
|
|||
Eijiro is a dictionary compiled by E.D.P. For details, such as how to
|
||||
obtain the whole data, visit EDP's Web site.
|
||||
|
||||
WWW: http://member.nifty.ne.jp/eijiro/
|
||||
|
||||
-- E.D.P.
|
||||
|
||||
Data in this port are converted from the original dictionary into JIS
|
||||
X 4081 format (that is a subset of EPWING V1) by FreePWING. So this
|
||||
can be used by EPWING viewers on Unix and the other OS (e.g. Windows
|
||||
or MacOS).
|
||||
|
||||
o URL for this converted dictionary:
|
||||
WWW: http://openlab.ring.gr.jp/edict/fpw/
|
||||
|
||||
-- S.TAOKA
|
7
japanese/eijiro-fpw/pkg-plist
Normal file
7
japanese/eijiro-fpw/pkg-plist
Normal file
|
@ -0,0 +1,7 @@
|
|||
share/dict/eijiro-fpw/eijiro/data/honmon
|
||||
share/dict/eijiro-fpw/catalogs
|
||||
@dirrm share/dict/eijiro-fpw/eijiro/data
|
||||
@dirrm share/dict/eijiro-fpw/eijiro
|
||||
@dirrm share/dict/eijiro-fpw
|
||||
share/doc/eijiro-fpw/readme.sjis
|
||||
@dirrm share/doc/eijiro-fpw
|
Loading…
Reference in a new issue