archivers/quazip: upgrade to 0.7.6

- the project has moved to github.
This commit is contained in:
Tobias C. Berner 2019-01-05 14:10:17 +00:00
parent 02c5ac36ee
commit 5819a2bdea
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=489340
5 changed files with 8 additions and 35 deletions

View file

@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= quazip
DISTVERSION= 0.7.3
PORTREVISION= 3
DISTVERSION= 0.7.6
CATEGORIES= archivers
MASTER_SITES= SF
PKGNAMESUFFIX= -${FLAVOR}
MAINTAINER= kde@FreeBSD.org
@ -17,6 +15,8 @@ FLAVORS= qt5 qt4
FLAVOR?= ${FLAVORS:[1]}
USES= cmake
USE_GITHUB= yes
GH_ACCOUNT= stachenov
USE_LDCONFIG= yes
. if ${FLAVOR} == qt4

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1486376312
SHA256 (quazip-0.7.3.tar.gz) = 2ad4f354746e8260d46036cde1496c223ec79765041ea28eb920ced015e269b5
SIZE (quazip-0.7.3.tar.gz) = 439536
TIMESTAMP = 1546696187
SHA256 (stachenov-quazip-0.7.6_GH0.tar.gz) = 4118a830a375a81211956611cc34b1b5b4ddc108c126287b91b40c2493046b70
SIZE (stachenov-quazip-0.7.6_GH0.tar.gz) = 149029

View file

@ -1,27 +0,0 @@
Properly link quazip_static against its dependencies
From the looks of r256, it appears that the target_link_libraries() call in
quazip/CMakeLists.txt was modified with the intention of linking both
${QUAZIP_LIB_TARGET_NAME} and quazip_static against all required libraries.
However, target_link_libraries()'s syntax is such that the first argument is
the library that all other arguments will be linked against. In other words,
libquazip(5).so will link against quazip_static, which is not what is desired.
Creator: Raphael Kubo da Costa
https://sourceforge.net/p/quazip/patches/28/
Index: quazip/CMakeLists.txt
===================================================================
--- quazip/CMakeLists.txt.orig 2016-01-03 06:01:40 UTC
+++ quazip/CMakeLists.txt
@@ -25,7 +25,8 @@ endif ()
set_target_properties(${QUAZIP_LIB_TARGET_NAME} quazip_static PROPERTIES VERSION 1.0.0 SOVERSION 1 DEBUG_POSTFIX d)
# Link against ZLIB_LIBRARIES if needed (on Windows this variable is empty)
-target_link_libraries(${QUAZIP_LIB_TARGET_NAME} quazip_static ${QT_QTMAIN_LIBRARY} ${QTCORE_LIBRARIES} ${ZLIB_LIBRARIES})
+target_link_libraries(quazip_static ${QT_QTMAIN_LIBRARY} ${QTCORE_LIBRARIES} ${ZLIB_LIBRARIES})
+target_link_libraries(${QUAZIP_LIB_TARGET_NAME} ${QT_QTMAIN_LIBRARY} ${QTCORE_LIBRARIES} ${ZLIB_LIBRARIES})
install(FILES ${PUBLIC_HEADERS} DESTINATION include/quazip${QUAZIP_LIB_VERSION_SUFFIX})
install(TARGETS ${QUAZIP_LIB_TARGET_NAME} quazip_static LIBRARY DESTINATION ${LIB_DESTINATION} ARCHIVE DESTINATION ${LIB_DESTINATION} RUNTIME DESTINATION ${LIB_DESTINATION})

View file

@ -1,4 +1,4 @@
QuaZIP is a simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package that
can be used to access ZIP archives. It uses Trolltech's Qt toolkit.
WWW: http://quazip.sourceforge.net/
WWW: https://github.com/stachenov/quazip

View file

@ -1,6 +1,6 @@
include/quazip%%QTVER_SUFFIX%%/JlCompress.h
include/quazip%%QTVER_SUFFIX%%/crypt.h
include/quazip%%QTVER_SUFFIX%%/ioapi.h
include/quazip%%QTVER_SUFFIX%%/minizip_crypt.h
include/quazip%%QTVER_SUFFIX%%/quaadler32.h
include/quazip%%QTVER_SUFFIX%%/quachecksum32.h
include/quazip%%QTVER_SUFFIX%%/quacrc32.h