games/emptyepsilon: Update 2020.11.23 -> 2021.03.16
Reported by: portscout
This commit is contained in:
parent
aeb3628206
commit
75342d7b16
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=568716
4 changed files with 76 additions and 30 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= emptyepsilon
|
||||
DISTVERSIONPREFIX= EE-
|
||||
DISTVERSION= 2020.11.23
|
||||
DISTVERSION= 2021.03.16
|
||||
CATEGORIES= games
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
|
@ -15,10 +15,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
|||
LIB_DEPENDS= libsfml-system.so:devel/sfml
|
||||
|
||||
USES= cmake compiler:c++11-lib gl xorg
|
||||
USE_GL= gl glu
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= daid
|
||||
GH_PROJECT= EmptyEpsilon SeriousProton:sproton
|
||||
USE_GL= gl glu
|
||||
|
||||
CMAKE_ARGS= -DSERIOUS_PROTON_DIR="${WRKSRC_sproton}/"
|
||||
|
||||
post-patch:
|
||||
|
@ -26,6 +28,8 @@ post-patch:
|
|||
${WRKSRC_sproton}/src/resources.cpp
|
||||
@${REINPLACE_CMD} -e 's|loadFromFile("resources/"|loadFromFile("${DATADIR}/resources/"|' \
|
||||
${WRKSRC_sproton}/src/postProcessManager.cpp
|
||||
@${REINPLACE_CMD} -e 's|uint32_t bswap32(uint32_t value)|uint32_t bswap32_(uint32_t value)|' \
|
||||
${WRKSRC_sproton}/src/i18n.cpp
|
||||
|
||||
post-install:
|
||||
@${MV} ${STAGEDIR}${PREFIX}/bin/EmptyEpsilon ${STAGEDIR}${PREFIX}/bin/emptyepsilon
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
TIMESTAMP = 1606274108
|
||||
SHA256 (daid-EmptyEpsilon-EE-2020.11.23_GH0.tar.gz) = 339df2f3b57135663cb7bd253d7e157c3c5d457137bc6ed4c9651f48e8e6bf0c
|
||||
SIZE (daid-EmptyEpsilon-EE-2020.11.23_GH0.tar.gz) = 271083907
|
||||
SHA256 (daid-SeriousProton-EE-2020.11.23_GH0.tar.gz) = 7552ab3b2a82735401aba2215ae5bcae5fa2c9946b709ff77e0c2cc5a60abc23
|
||||
SIZE (daid-SeriousProton-EE-2020.11.23_GH0.tar.gz) = 1172772
|
||||
TIMESTAMP = 1616032119
|
||||
SHA256 (daid-EmptyEpsilon-EE-2021.03.16_GH0.tar.gz) = 79abaaf787f154f2bceda2b942c695a4e0d03b555cbf47e3349398d13cc27670
|
||||
SIZE (daid-EmptyEpsilon-EE-2021.03.16_GH0.tar.gz) = 281045878
|
||||
SHA256 (daid-SeriousProton-EE-2021.03.16_GH0.tar.gz) = 2eb18fa8b20c994482f24da54f99c7f7ecdbfbd1a926942aa0ec3dd98c880e76
|
||||
SIZE (daid-SeriousProton-EE-2021.03.16_GH0.tar.gz) = 1174918
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- CMakeLists.txt.orig 2019-09-10 10:55:00 UTC
|
||||
--- CMakeLists.txt.orig 2021-03-16 13:36:34 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -464,16 +464,16 @@ else()
|
||||
@@ -536,25 +536,25 @@ else()
|
||||
install(TARGETS ${EXECUTABLE_NAME} RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR})
|
||||
endif()
|
||||
|
||||
|
@ -12,7 +12,16 @@
|
|||
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
|
||||
- COMMENT "Building script reference documentation.")
|
||||
- add_custom_target(script_reference ALL DEPENDS ${CMAKE_BINARY_DIR}/script_reference.html)
|
||||
- install(FILES ${CMAKE_BINARY_DIR}/script_reference.html DESTINATION .)
|
||||
-
|
||||
- # Matches install logic above.
|
||||
- if(WIN32)
|
||||
- install(FILES ${CMAKE_BINARY_DIR}/script_reference.html DESTINATION .)
|
||||
- elseif(APPLE)
|
||||
- install(FILES ${CMAKE_BINARY_DIR}/script_reference.html DESTINATION "EmptyEpsilon.app/Contents/Resources")
|
||||
- elseif(NOT ANDROID)
|
||||
- # DOCDIR already has PROJECT_NAME (EmptyEpsilon) appended (from CMake docs)
|
||||
- install(FILES ${CMAKE_BINARY_DIR}/script_reference.html DESTINATION "${CMAKE_INSTALL_FULL_DOCDIR}")
|
||||
- endif()
|
||||
-endif()
|
||||
+#find_package(PythonInterp)
|
||||
+#if(PYTHONINTERP_FOUND)
|
||||
|
@ -22,8 +31,17 @@
|
|||
+# WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
|
||||
+# COMMENT "Building script reference documentation.")
|
||||
+# add_custom_target(script_reference ALL DEPENDS ${CMAKE_BINARY_DIR}/script_reference.html)
|
||||
+# install(FILES ${CMAKE_BINARY_DIR}/script_reference.html DESTINATION .)
|
||||
+#
|
||||
+# # Matches install logic above.
|
||||
+# if(WIN32)
|
||||
+# install(FILES ${CMAKE_BINARY_DIR}/script_reference.html DESTINATION .)
|
||||
+# elseif(APPLE)
|
||||
+# install(FILES ${CMAKE_BINARY_DIR}/script_reference.html DESTINATION "EmptyEpsilon.app/Contents/Resources")
|
||||
+# elseif(NOT ANDROID)
|
||||
+# # DOCDIR already has PROJECT_NAME (EmptyEpsilon) appended (from CMake docs)
|
||||
+# install(FILES ${CMAKE_BINARY_DIR}/script_reference.html DESTINATION "${CMAKE_INSTALL_FULL_DOCDIR}")
|
||||
+# endif()
|
||||
+#endif()
|
||||
|
||||
set(CPACK_PACKAGE_EXECUTABLES ${EXECUTABLE_NAME})
|
||||
set(CPACK_PACKAGE_FILE_NAME "${CMAKE_PROJECT_NAME}")
|
||||
add_custom_target(update_locale
|
||||
COMMAND sed -i "/^#: /d" resources/locale/en.po
|
||||
|
|
|
@ -38,15 +38,11 @@ bin/emptyepsilon
|
|||
%%DATADIR%%/resources/ammo_box_specular.png
|
||||
%%DATADIR%%/resources/asteroid.obj
|
||||
%%DATADIR%%/resources/asteroid.png
|
||||
%%DATADIR%%/resources/basicShader.frag
|
||||
%%DATADIR%%/resources/basicShader.vert
|
||||
%%DATADIR%%/resources/beam_blue.png
|
||||
%%DATADIR%%/resources/beam_green.png
|
||||
%%DATADIR%%/resources/beam_orange.png
|
||||
%%DATADIR%%/resources/beam_purple.png
|
||||
%%DATADIR%%/resources/beam_yellow.png
|
||||
%%DATADIR%%/resources/billboardShader.frag
|
||||
%%DATADIR%%/resources/billboardShader.vert
|
||||
%%DATADIR%%/resources/blackHole.png
|
||||
%%DATADIR%%/resources/blackHole3d.png
|
||||
%%DATADIR%%/resources/button.wav
|
||||
|
@ -56,7 +52,6 @@ bin/emptyepsilon
|
|||
%%DATADIR%%/resources/explosion.wav
|
||||
%%DATADIR%%/resources/fire_ring.png
|
||||
%%DATADIR%%/resources/fire_sphere_texture.png
|
||||
%%DATADIR%%/resources/glitch.frag
|
||||
%%DATADIR%%/resources/gui/BackgroundCrosses.png
|
||||
%%DATADIR%%/resources/gui/BackgroundGradient.png
|
||||
%%DATADIR%%/resources/gui/BackgroundGradientOffset.png
|
||||
|
@ -87,6 +82,8 @@ bin/emptyepsilon
|
|||
%%DATADIR%%/resources/gui/fonts/BebasNeue Light.otf
|
||||
%%DATADIR%%/resources/gui/fonts/BebasNeue Regular.otf
|
||||
%%DATADIR%%/resources/gui/fonts/BebasNeue Thin.otf
|
||||
%%DATADIR%%/resources/gui/fonts/BigShouldersDisplay-ExtraBold.ttf
|
||||
%%DATADIR%%/resources/gui/fonts/BigShouldersDisplay-SemiBold.ttf
|
||||
%%DATADIR%%/resources/gui/fonts/LICENSE
|
||||
%%DATADIR%%/resources/gui/icons/coolant.png
|
||||
%%DATADIR%%/resources/gui/icons/docking.png
|
||||
|
@ -155,23 +152,22 @@ bin/emptyepsilon
|
|||
%%DATADIR%%/resources/music/combat/neocrey - Last Cyber Dance.ogg
|
||||
%%DATADIR%%/resources/music/source.txt
|
||||
%%DATADIR%%/resources/noise.png
|
||||
%%DATADIR%%/resources/objectShaderB.frag
|
||||
%%DATADIR%%/resources/objectShaderB.vert
|
||||
%%DATADIR%%/resources/objectShaderBI.frag
|
||||
%%DATADIR%%/resources/objectShaderBI.vert
|
||||
%%DATADIR%%/resources/objectShaderBS.frag
|
||||
%%DATADIR%%/resources/objectShaderBS.vert
|
||||
%%DATADIR%%/resources/objectShaderBSI.frag
|
||||
%%DATADIR%%/resources/objectShaderBSI.vert
|
||||
%%DATADIR%%/resources/particle.png
|
||||
%%DATADIR%%/resources/planetShader.frag
|
||||
%%DATADIR%%/resources/planetShader.vert
|
||||
%%DATADIR%%/resources/planets/atmosphere.png
|
||||
%%DATADIR%%/resources/planets/clouds-1.png
|
||||
%%DATADIR%%/resources/planets/clouds-2.png
|
||||
%%DATADIR%%/resources/planets/clouds-3.png
|
||||
%%DATADIR%%/resources/planets/gas-1.png
|
||||
%%DATADIR%%/resources/planets/gas-2.png
|
||||
%%DATADIR%%/resources/planets/gas-3.png
|
||||
%%DATADIR%%/resources/planets/moon-1.png
|
||||
%%DATADIR%%/resources/planets/moon-2.png
|
||||
%%DATADIR%%/resources/planets/moon-3.png
|
||||
%%DATADIR%%/resources/planets/planet-1.png
|
||||
%%DATADIR%%/resources/planets/planet-2.png
|
||||
%%DATADIR%%/resources/planets/planet-3.png
|
||||
%%DATADIR%%/resources/planets/planet-4.png
|
||||
%%DATADIR%%/resources/planets/planet-5.png
|
||||
%%DATADIR%%/resources/planets/star-1.png
|
||||
%%DATADIR%%/resources/radarCutoff.png
|
||||
%%DATADIR%%/resources/radar_adv_gunship.png
|
||||
|
@ -382,13 +378,40 @@ bin/emptyepsilon
|
|||
%%DATADIR%%/resources/sfx/nuke_explosion.wav
|
||||
%%DATADIR%%/resources/sfx/rlaunch.wav
|
||||
%%DATADIR%%/resources/sfx/source.txt
|
||||
%%DATADIR%%/resources/shaders/basic.frag
|
||||
%%DATADIR%%/resources/shaders/basic.vert
|
||||
%%DATADIR%%/resources/shaders/basicColor.frag
|
||||
%%DATADIR%%/resources/shaders/basicColor.vert
|
||||
%%DATADIR%%/resources/shaders/basicShader.frag
|
||||
%%DATADIR%%/resources/shaders/basicShader.vert
|
||||
%%DATADIR%%/resources/shaders/billboard.frag
|
||||
%%DATADIR%%/resources/shaders/billboard.vert
|
||||
%%DATADIR%%/resources/shaders/billboardShader.frag
|
||||
%%DATADIR%%/resources/shaders/billboardShader.vert
|
||||
%%DATADIR%%/resources/shaders/glitch.frag
|
||||
%%DATADIR%%/resources/shaders/objectShaderB.frag
|
||||
%%DATADIR%%/resources/shaders/objectShaderB.vert
|
||||
%%DATADIR%%/resources/shaders/objectShaderBI.frag
|
||||
%%DATADIR%%/resources/shaders/objectShaderBI.vert
|
||||
%%DATADIR%%/resources/shaders/objectShaderBS.frag
|
||||
%%DATADIR%%/resources/shaders/objectShaderBS.vert
|
||||
%%DATADIR%%/resources/shaders/objectShaderBSI.frag
|
||||
%%DATADIR%%/resources/shaders/objectShaderBSI.vert
|
||||
%%DATADIR%%/resources/shaders/particles.frag
|
||||
%%DATADIR%%/resources/shaders/particles.vert
|
||||
%%DATADIR%%/resources/shaders/planetShader.frag
|
||||
%%DATADIR%%/resources/shaders/planetShader.vert
|
||||
%%DATADIR%%/resources/shaders/spacedust.frag
|
||||
%%DATADIR%%/resources/shaders/spacedust.vert
|
||||
%%DATADIR%%/resources/shaders/starbox.frag
|
||||
%%DATADIR%%/resources/shaders/starbox.vert
|
||||
%%DATADIR%%/resources/shaders/warp.frag
|
||||
%%DATADIR%%/resources/shield_circle.png
|
||||
%%DATADIR%%/resources/shield_down.wav
|
||||
%%DATADIR%%/resources/shield_hit_effect.png
|
||||
%%DATADIR%%/resources/shield_up.wav
|
||||
%%DATADIR%%/resources/sphere.obj
|
||||
%%DATADIR%%/resources/vocal_self_destruction.wav
|
||||
%%DATADIR%%/resources/warp.frag
|
||||
%%DATADIR%%/resources/waypoint.png
|
||||
%%DATADIR%%/resources/wormHole1.png
|
||||
%%DATADIR%%/resources/wormHole2.png
|
||||
|
@ -398,7 +421,7 @@ bin/emptyepsilon
|
|||
%%DATADIR%%/scripts/border_defend_station.lua
|
||||
%%DATADIR%%/scripts/comms_ship.lua
|
||||
%%DATADIR%%/scripts/comms_station.lua
|
||||
%%DATADIR%%/scripts/comms_station_scenario_03_central_command.lua
|
||||
%%DATADIR%%/scripts/comms_station_scenario_06_central_command.lua
|
||||
%%DATADIR%%/scripts/comms_supply_drop.lua
|
||||
%%DATADIR%%/scripts/ee.lua
|
||||
%%DATADIR%%/scripts/factionInfo.lua
|
||||
|
@ -434,6 +457,7 @@ bin/emptyepsilon
|
|||
%%DATADIR%%/scripts/scenario_60_captureFlag.lua
|
||||
%%DATADIR%%/scripts/scenario_62_whatTheDickens.lua
|
||||
%%DATADIR%%/scripts/scenario_81_pvp.lua
|
||||
%%DATADIR%%/scripts/scenario_88_chaos.lua
|
||||
%%DATADIR%%/scripts/scenario_99_battlefield.lua
|
||||
%%DATADIR%%/scripts/science_db.lua
|
||||
%%DATADIR%%/scripts/shipTemplates.lua
|
||||
|
|
Loading…
Reference in a new issue