The objective of the PlaneShift is to create a virtual fantasy world in which a
player can start as a peasant in search of fame and become a hero. First of all PlaneShift is a Role Playing Game. Be sure to read our Roleplay guidelines or you will not be able to play this game. We will focus our efforts in the reproduction of a real world with politics, economy, many non-player-characters controlled by the server that will bring to life our world even without players connected! We want to give FREE access to everyone, without the need to either purchase the game or pay a monthly fee. Servers and bandwidth will be donated by sponsors. Our virtual world is persistent, and this means you can connect to it at every hour of day or night and you will always find players and npcs wandering our realms. You will be able to disconnect and reconnect again, the server saves the actual status of your character including his possessions. You will use a client program to interact with our world, that enables you to have a 3D view of the surroundings. WWW: http://www.planeshift.it PR: ports/94720 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
This commit is contained in:
parent
16f793124c
commit
8234e7b908
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=166335
12 changed files with 710 additions and 0 deletions
|
@ -502,6 +502,7 @@
|
|||
SUBDIR += pioneers
|
||||
SUBDIR += pipenightdreams
|
||||
SUBDIR += pipepanic
|
||||
SUBDIR += planeshift
|
||||
SUBDIR += plonx
|
||||
SUBDIR += pmars
|
||||
SUBDIR += pmars-sdl
|
||||
|
|
149
games/planeshift/Makefile
Normal file
149
games/planeshift/Makefile
Normal file
|
@ -0,0 +1,149 @@
|
|||
# New ports collection makefile for: planeshift
|
||||
# Date created: 2006-03-17
|
||||
# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= planeshift
|
||||
PORTVERSION= 0.3.013
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= #
|
||||
NO_CHECKSUM= ${DISTFILES}
|
||||
|
||||
MAINTAINER= acardenas@bsd.org.pe
|
||||
COMMENT= First 3D MMORPG to be free for players
|
||||
|
||||
BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam \
|
||||
cs-config:${PORTSDIR}/graphics/crystalspace \
|
||||
cel-config:${PORTSDIR}/graphics/crystalentitylayer \
|
||||
${LOCALBASE}/lib/libbfd.a:${PORTSDIR}/devel/libbfd
|
||||
LIB_DEPENDS= cal3d.11:${PORTSDIR}/graphics/cal3d-devel \
|
||||
curl.3:${PORTSDIR}/ftp/curl
|
||||
|
||||
USE_BZIP2= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_AUTOTOOLS= automake:15:env autoconf:259:env
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_LIBS}
|
||||
LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib
|
||||
CRYSTAL= ${LOCALBASE}
|
||||
CEL= ${LOCALBASE}
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ARGS= --enable-cpu-specific-optimizations=no
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" CRYSTAL="${CRYSTAL}" CEL="${CEL}"
|
||||
SUB_FILES= pkg-message planeshift pssetup updater psserver
|
||||
PLANEDIR= lib/${PORTNAME}
|
||||
PLIST_SUB= PLANEDIR=${PLANEDIR}
|
||||
|
||||
JAM_CMD= jam
|
||||
|
||||
OPTIONS= MYSQL "MySQL support for server mode " off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_MYSQL)
|
||||
CONFIGURE_ARGS+= --with-mysqlclient
|
||||
USE_MYSQL= yes
|
||||
LIB_DEPENDS+= WN.2:${PORTSDIR}/textproc/wordnet
|
||||
PLIST_SUB+= MYSQL="" \
|
||||
EXAMPLE=""
|
||||
MYSQL_FLAG= true
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-mysqlclient=no
|
||||
PLIST_SUB+= MYSQL="@comment " \
|
||||
EXAMPLE="@comment "
|
||||
.endif
|
||||
|
||||
CVS_CMD?= cvs -z3
|
||||
CVS_DATE= 2006-03-01 00:00:00
|
||||
CVS_SITES?= pserver:anonymous@planeshift.cvs.sourceforge.net:/cvsroot/planeshift
|
||||
CVS_MODULE= ${PORTNAME}
|
||||
|
||||
do-fetch:
|
||||
@if test ! -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ; then \
|
||||
${MKDIR} ${DISTDIR}/${DISTNAME} && \
|
||||
cd ${DISTDIR}/${DISTNAME}; \
|
||||
for CVS_SITE in ${CVS_SITES}; do \
|
||||
${ECHO_MSG} ">> Attempting to check out from $${CVS_SITE}."; \
|
||||
if ${CVS_CMD} -d:$${CVS_SITE} co -D "${CVS_DATE}" ${CVS_MODULE}; \
|
||||
then \
|
||||
cd ${DISTDIR}; \
|
||||
${ECHO_MSG} ">> Creating dist tarball in ${DISTDIR}"; \
|
||||
${ECHO_MSG} ">> \"${DISTNAME}${EXTRACT_SUFX}\"."; \
|
||||
${MV} ${DISTNAME}/${CVS_MODULE} \
|
||||
${DISTNAME}/${CVS_MODULE:H}/${DISTNAME}; \
|
||||
${TAR} -cj \
|
||||
-X ${FILESDIR}/tarignore \
|
||||
-f ${DISTNAME}${EXTRACT_SUFX} \
|
||||
-C ${DISTNAME}/${CVS_MODULE:H} \
|
||||
${DISTNAME}; \
|
||||
${RM} -rf ${DISTDIR}/${DISTNAME}; \
|
||||
exit; \
|
||||
fi \
|
||||
done; \
|
||||
${RM} -rf ${DISTDIR}/${DISTNAME}; \
|
||||
${ECHO_MSG} ">> CVS checkout failed."; \
|
||||
exit 1; \
|
||||
fi
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|%%AUTOHEADER%%|${AUTOHEADER}|g' -e 's|%%AUTOCONF%%|${AUTOCONF}|g' \
|
||||
${WRKSRC}/autogen.sh
|
||||
@cd ${WRKSRC}/src && \
|
||||
${FIND} * -type f -name "*.c" -exec \
|
||||
${REINPLACE_CMD} -i "" -e 's|malloc.h|stdlib.h|g' "{}" \;
|
||||
|
||||
pre-configure:
|
||||
@cd ${WRKSRC} && ${SH} autogen.sh
|
||||
|
||||
do-build:
|
||||
@cd ${WRKSRC} && \
|
||||
${JAM_CMD} -q
|
||||
|
||||
post-build:
|
||||
@${REINPLACE_CMD} -e 's|<mirror id="1" name="local" url="http://192.168.2.19/updater/" />| \
|
||||
<mirror id="1" name="mir1" url="http://psmirror.pfdev.net/psupdater/" \
|
||||
repository="repository.zip\" files="" /> \
|
||||
<mirror id="2" name="mir2" url="http://planeshift.mirror.thumbnail.cz/psupdater/" \
|
||||
repository="repository.zip" files="" /> \
|
||||
<mirror id="3" name="mir3" url="http://www.psmirror.org/psupdater/" \
|
||||
repository="repository.zip" files="" /> \
|
||||
<mirror id="4" name="mir4" url="http://psmirror.u24.solone.net/psupdater/" \
|
||||
repository="repository.zip" files="" /> \
|
||||
<mirror id="5" name="backp" url="http://laanx.fragnetics.com/updater_hidden/" \
|
||||
repository="repository.zip" files="" />|g' ${WRKSRC}/updaterconfig.xml
|
||||
|
||||
@${REINPLACE_CMD} -e 's|<module>docs</module>|<!-- <module>docs</module> -->|g' -e \
|
||||
's|<module>root</module>|<!-- <module>root</module> -->|g' ${WRKSRC}/updaterconfig.xml
|
||||
do-install:
|
||||
@${MKDIR} ${PREFIX}/${PLANEDIR}
|
||||
.for FILE in ase_2_spr eedit paws_generic pawseditor psclient psnpcclient psserver pssetup texparse updater
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${FILE} ${PREFIX}/${PLANEDIR}
|
||||
.endfor
|
||||
|
||||
.for FILE in *.cfg *.xml
|
||||
${INSTALL_DATA} ${WRKSRC}/${FILE} ${PREFIX}/${PLANEDIR}
|
||||
.endfor
|
||||
|
||||
.for DIRE in art data
|
||||
@${MKDIR} ${PREFIX}/${PLANEDIR}/${DIRE}
|
||||
@cd ${WRKSRC}/${DIRE} && \
|
||||
${FIND} * -type d -exec ${MKDIR} "${PREFIX}/${PLANEDIR}/${DIRE}/{}" \; && \
|
||||
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${PREFIX}/${PLANEDIR}/${DIRE}/{}" \;
|
||||
.endfor
|
||||
|
||||
.if defined(MYSQL_FLAG)
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/psserver ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/dbmysql.so ${PREFIX}/${PLANEDIR}
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
@cd ${WRKSRC}/src/server/database/mysql && \
|
||||
${FIND} * -name "*.sql" -exec ${INSTALL_DATA} "{}" "${EXAMPLESDIR}/{}" \;
|
||||
.endif
|
||||
|
||||
@${INSTALL_SCRIPT} ${WRKDIR}/planeshift ${WRKDIR}/updater ${WRKDIR}/pssetup ${PREFIX}/bin
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
1
games/planeshift/distinfo
Normal file
1
games/planeshift/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
Source code is retrieved via CVS
|
16
games/planeshift/files/patch-autogen.sh
Normal file
16
games/planeshift/files/patch-autogen.sh
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- autogen.sh.orig Fri Mar 17 22:07:40 2006
|
||||
+++ autogen.sh Fri Mar 17 16:52:53 2006
|
||||
@@ -13,11 +13,11 @@
|
||||
cat $i >> $MACROFILE
|
||||
done
|
||||
|
||||
-autoheader
|
||||
+%%AUTOHEADER%%
|
||||
rc=$?
|
||||
|
||||
if test $rc -eq 0; then
|
||||
- autoconf
|
||||
+ %%AUTOCONF%%
|
||||
rc=$?
|
||||
fi
|
||||
|
120
games/planeshift/files/pkg-message.in
Normal file
120
games/planeshift/files/pkg-message.in
Normal file
|
@ -0,0 +1,120 @@
|
|||
#################################################################################
|
||||
|
||||
CLIENT ONLY
|
||||
-----------
|
||||
|
||||
1) Need to download all necessary files for planeshift (art and data directory).
|
||||
|
||||
# updater --auto
|
||||
|
||||
This download 200M aprox.
|
||||
|
||||
2) After to update data and art directory, you need to make some changes in
|
||||
files into data directory. I don't know about the problem with <?Include and
|
||||
<?Template tag defined. The solution is changing these tag to lowercase.
|
||||
|
||||
# find data -type f -exec sed -i '' -e 's|<?Template|<?template|g' -e \
|
||||
's|<?Endtemplate|<?endtemplate|g' -e 's|<?Include|<?include|g' "{}" \;
|
||||
|
||||
3) Also, I had problem with cg-base file into data/shader/snippets directory. I
|
||||
solved it modifying some lines.
|
||||
|
||||
<?template _List_$LIST$ ?><?endtemplate?>
|
||||
|
||||
<?template _List_$LIST$ ?>
|
||||
<?_List_$LIST$?>
|
||||
<?$ITEM$?>
|
||||
<?endtemplate?>
|
||||
|
||||
<?_List_$LIST$?>
|
||||
|
||||
to
|
||||
|
||||
<?!template _List_$LIST$ ?><?!endtemplate?>
|
||||
|
||||
<?!template _List_$LIST$ ?>
|
||||
<?!_List_$LIST$?>
|
||||
<?!$ITEM$?>
|
||||
<?!endtemplate?>
|
||||
|
||||
<?!_List_$LIST$?>
|
||||
|
||||
4) Modify psclient.cfg and change line:
|
||||
|
||||
Planeshift.GUI.Skin.Ingame = /this/art/skins/cvs.zip
|
||||
|
||||
to
|
||||
|
||||
Planeshift.GUI.Skin.Ingame = /this/art/skins/default.zip
|
||||
|
||||
5) For play online, you need create an account
|
||||
|
||||
http://laanx.fragnetics.com/register/
|
||||
|
||||
6) Edit planeshift.cfg file and modify these lines:
|
||||
|
||||
; Change values if you want.
|
||||
Video.ScreenWidth = 800
|
||||
Video.ScreenHeight = 600
|
||||
; Performs better in 32 bit display mode
|
||||
Video.ScreenDepth = 32
|
||||
Video.FullScreen = true
|
||||
Planeshift.Connection.User = PlaneshiftAccount
|
||||
|
||||
7) Start planeshift using root account once.
|
||||
8) Finally you can start planeshift using simple user account
|
||||
9) Enjoy it ;)
|
||||
|
||||
SERVER ONLY
|
||||
-----------
|
||||
|
||||
1) Start MySQL server
|
||||
|
||||
# sh /usr/local/etc/rc.d/mysql-server start
|
||||
|
||||
2) Login MySQL console
|
||||
|
||||
# mysql -u username -ppassword
|
||||
|
||||
default username is root with no password
|
||||
|
||||
3) Create database and user account
|
||||
|
||||
mysql>create database planeshift;
|
||||
mysql>GRANT ALL PRIVILEGES ON *.* TO planeshift@localhost IDENTIFIED BY \
|
||||
'planeshift' WITH GRANT OPTION;
|
||||
mysql>quit
|
||||
|
||||
# cd %%EXAMPLESDIR%%
|
||||
|
||||
# mysql -u planeshift -pplaneshift
|
||||
|
||||
mysql> use planeshift;
|
||||
mysql> source create_all.sql;
|
||||
mysql> quit
|
||||
|
||||
4) Copy worldnet's dict directory to planeshift's data directory
|
||||
|
||||
# cd /usr/local/share/WordNet
|
||||
# mkdir /usr/X11R6/lib/planeshift/data/dict
|
||||
# cp * /usr/X11R6/lib/planeshift/data/dict
|
||||
|
||||
5) Start planeshift server
|
||||
|
||||
# psserver
|
||||
|
||||
Type the following in "PS Server" prompt:
|
||||
|
||||
loadmap npcroom
|
||||
spawn
|
||||
ready
|
||||
|
||||
6) Planeshift client can use these accounts for login
|
||||
|
||||
Vengeance/keith
|
||||
acraig/andrew
|
||||
guest/guest
|
||||
|
||||
7) Enjoy it ;)
|
||||
|
||||
#################################################################################
|
8
games/planeshift/files/planeshift.in
Normal file
8
games/planeshift/files/planeshift.in
Normal file
|
@ -0,0 +1,8 @@
|
|||
#!/bin/csh
|
||||
|
||||
export CRYSTAL=%%X11BASE%%/lib/planeshift
|
||||
export CEL=%%X11BASE%%/lib/cel
|
||||
export CSCONFPATH=%%X11BASE%%/etc/crystalspace
|
||||
|
||||
cd %%PREFIX%%/lib/planeshift
|
||||
exec ./psclient $1
|
8
games/planeshift/files/psserver.in
Normal file
8
games/planeshift/files/psserver.in
Normal file
|
@ -0,0 +1,8 @@
|
|||
#!/bin/sh
|
||||
|
||||
export CRYSTAL=%%X11BASE%%/lib/planeshift
|
||||
export CEL=%%X11BASE%%/lib/cel
|
||||
export CSCONFPATH=%%X11BASE%%/etc/crystalspace
|
||||
|
||||
cd %%PREFIX%%/lib/planeshift
|
||||
exec ./psserver $1
|
8
games/planeshift/files/pssetup.in
Normal file
8
games/planeshift/files/pssetup.in
Normal file
|
@ -0,0 +1,8 @@
|
|||
#!/bin/sh
|
||||
|
||||
export CRYSTAL=%%X11BASE%%/lib/planeshift
|
||||
export CEL=%%X11BASE%%/lib/cel
|
||||
export CSCONFPATH=%%X11BASE%%/etc/crystalspace
|
||||
|
||||
cd %%PREFIX%%/lib/planeshift
|
||||
exec ./pssetup $1
|
1
games/planeshift/files/tarignore
Normal file
1
games/planeshift/files/tarignore
Normal file
|
@ -0,0 +1 @@
|
|||
CVS
|
8
games/planeshift/files/updater.in
Normal file
8
games/planeshift/files/updater.in
Normal file
|
@ -0,0 +1,8 @@
|
|||
#!/bin/sh
|
||||
|
||||
export CRYSTAL=%%X11BASE%%/lib/planeshift
|
||||
export CEL=%%X11BASE%%/lib/cel
|
||||
export CSCONFPATH=%%X11BASE%%/etc/crystalspace
|
||||
|
||||
cd %%PREFIX%%/lib/planeshift
|
||||
exec ./updater $1
|
21
games/planeshift/pkg-descr
Normal file
21
games/planeshift/pkg-descr
Normal file
|
@ -0,0 +1,21 @@
|
|||
The objective of the PlaneShift is to create a virtual fantasy world in which a
|
||||
player can start as a peasant in search of fame and become a hero. First of all
|
||||
PlaneShift is a Role Playing Game. Be sure to read our Roleplay guidelines or
|
||||
you will not be able to play this game. We will focus our efforts in the
|
||||
reproduction of a real world with politics, economy, many non-player-characters
|
||||
controlled by the server that will bring to life our world even without players
|
||||
connected!
|
||||
|
||||
We want to give FREE access to everyone, without the need to either purchase
|
||||
the game or pay a monthly fee. Servers and bandwidth will be donated by
|
||||
sponsors.
|
||||
|
||||
Our virtual world is persistent, and this means you can connect to it at every
|
||||
hour of day or night and you will always find players and npcs wandering our
|
||||
realms. You will be able to disconnect and reconnect again, the server saves
|
||||
the actual status of your character including his possessions.
|
||||
|
||||
You will use a client program to interact with our world, that enables you to
|
||||
have a 3D view of the surroundings.
|
||||
|
||||
WWW: http://www.planeshift.it
|
369
games/planeshift/pkg-plist
Normal file
369
games/planeshift/pkg-plist
Normal file
|
@ -0,0 +1,369 @@
|
|||
bin/planeshift
|
||||
bin/updater
|
||||
bin/pssetup
|
||||
%%MYSQL%%bin/psserver
|
||||
%%EXAMPLE%%share/examples/planeshift/accessrules.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/accounts.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/action_locations.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/alliances.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/armorvsweapon.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/bad_names.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/bans.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/buddy_list.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/command_access.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/commonstrings.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/create_all.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/char_adv.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/char_creation.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/char_skills.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/char_traits.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/character_marriage_details.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/character_quests.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/characters.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/deletechar.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/deletenpc.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/deletenpc_mb.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/drop.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/factions.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/gm_command_log.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/guildlevels.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/guilds.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/hunt_locations.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/item_animations.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/item_categories.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/item_instances.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/item_stats.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/loot_modifiers.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/loot_rule_details.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/loot_rules.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/merchant_item_cats.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/migration.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/movement_base.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/movement_extras.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/movement_require.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/movement_variant.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/natural_resources.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/npc_bad_text.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/npc_disallowed_words.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/npc_kas.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/npc_responses.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/npc_spawn_ranges.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/npc_spawn_rules.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/npc_synonyms.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/npc_trigger_groups.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/npc_triggers.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/petitions.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/player_spells.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/progress_events.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/quest_scripts.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/quests.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/race_info.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/sc_npc_definitions.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/sectors.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/security_levels.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/server_options.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/skills.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/spell_glyphs.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/spells.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/sys_modules.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/sys_privileges.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/sys_privileges_list.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/sys_programs.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/tips.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/trade_autocontainers.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/trade_combinations.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/trade_constraints.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/trade_patterns.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/trade_transformations.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/trainer_skills.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/traits.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/upgrade_schema.sql
|
||||
%%EXAMPLE%%share/examples/planeshift/ways.sql
|
||||
%%PLANEDIR%%/art/README
|
||||
%%PLANEDIR%%/art/apps.zip
|
||||
%%PLANEDIR%%/art/eedit.zip
|
||||
%%PLANEDIR%%/art/effects/marker01.png
|
||||
%%PLANEDIR%%/art/effects/raindrop.png
|
||||
%%PLANEDIR%%/art/effects/snow.jpg
|
||||
%%PLANEDIR%%/art/fakemodels.zip
|
||||
%%PLANEDIR%%/art/models.zip
|
||||
%%PLANEDIR%%/art/music/ComplexWind3.ogg
|
||||
%%PLANEDIR%%/art/music/README
|
||||
%%PLANEDIR%%/art/music/effects/PS_Thunder1.wav
|
||||
%%PLANEDIR%%/art/music/effects/PS_Thunder2.wav
|
||||
%%PLANEDIR%%/art/music/effects/PS_Thunder3.wav
|
||||
%%PLANEDIR%%/art/music/effects/PS_Thunder4.wav
|
||||
%%PLANEDIR%%/art/music/effects/PS_Thunder5.wav
|
||||
%%PLANEDIR%%/art/music/effects/PS_heavyrain.ogg
|
||||
%%PLANEDIR%%/art/music/effects/PS_lightrain.ogg
|
||||
%%PLANEDIR%%/art/music/effects/Storm_exclamation.wav
|
||||
%%PLANEDIR%%/art/music/effects/attack3.ogg
|
||||
%%PLANEDIR%%/art/music/effects/chaching.wav
|
||||
%%PLANEDIR%%/art/music/effects/gasps8.wav
|
||||
%%PLANEDIR%%/art/music/effects/halleluj.wav
|
||||
%%PLANEDIR%%/art/music/effects/heal1.ogg
|
||||
%%PLANEDIR%%/art/music/effects/heal2.ogg
|
||||
%%PLANEDIR%%/art/music/effects/ouch!.wav
|
||||
%%PLANEDIR%%/art/music/effects/sucks.wav
|
||||
%%PLANEDIR%%/art/music/gui/ccreate/back.wav
|
||||
%%PLANEDIR%%/art/music/gui/ccreate/decstat.wav
|
||||
%%PLANEDIR%%/art/music/gui/ccreate/incstat.wav
|
||||
%%PLANEDIR%%/art/music/gui/ccreate/infotext.wav
|
||||
%%PLANEDIR%%/art/music/gui/ccreate/next.wav
|
||||
%%PLANEDIR%%/art/music/gui/ccreate/quit.wav
|
||||
%%PLANEDIR%%/art/music/gui/jingle_splash.ogg
|
||||
%%PLANEDIR%%/art/music/gui/menu/btconn.wav
|
||||
%%PLANEDIR%%/art/music/gui/menu/btcreate.wav
|
||||
%%PLANEDIR%%/art/music/gui/menu/btndown.wav
|
||||
%%PLANEDIR%%/art/music/gui/menu/btquit.wav
|
||||
%%PLANEDIR%%/art/music/torch_test.wav
|
||||
%%PLANEDIR%%/art/pawseditor.zip
|
||||
%%PLANEDIR%%/art/psclient-setup.zip
|
||||
%%PLANEDIR%%/art/racelib.xml
|
||||
%%PLANEDIR%%/art/runes/README
|
||||
%%PLANEDIR%%/art/runes/azure/air.bmp
|
||||
%%PLANEDIR%%/art/runes/azure/bond.bmp
|
||||
%%PLANEDIR%%/art/runes/azure/dome.bmp
|
||||
%%PLANEDIR%%/art/runes/azure/fly.bmp
|
||||
%%PLANEDIR%%/art/runes/azure/gas.bmp
|
||||
%%PLANEDIR%%/art/runes/azure/humanoid.bmp
|
||||
%%PLANEDIR%%/art/runes/azure/mind.bmp
|
||||
%%PLANEDIR%%/art/runes/azure/sleep.bmp
|
||||
%%PLANEDIR%%/art/runes/azure/sound.bmp
|
||||
%%PLANEDIR%%/art/sfxfiles.dtd
|
||||
%%PLANEDIR%%/art/shaders/colorize.xml
|
||||
%%PLANEDIR%%/art/shaders/particle_basic.xml
|
||||
%%PLANEDIR%%/art/skins/cvs.zip
|
||||
%%PLANEDIR%%/art/soundlib.xml
|
||||
%%PLANEDIR%%/art/sounds/gui/bttn_cancel.ogg
|
||||
%%PLANEDIR%%/art/sounds/gui/bttn_ok.ogg
|
||||
%%PLANEDIR%%/art/sounds/gui/bttn_quit.ogg
|
||||
%%PLANEDIR%%/art/sounds/gui/bttn_scrolldown.ogg
|
||||
%%PLANEDIR%%/art/sounds/gui/bttn_scrollup.ogg
|
||||
%%PLANEDIR%%/art/sounds/gui/bttn_shortcut.ogg
|
||||
%%PLANEDIR%%/art/sounds/gui/bttn_toolbar.ogg
|
||||
%%PLANEDIR%%/art/things/items.zip
|
||||
%%PLANEDIR%%/art/things/potions.zip
|
||||
%%PLANEDIR%%/art/things/weapons.zip
|
||||
%%PLANEDIR%%/art/world/.cvsignore
|
||||
%%PLANEDIR%%/art/world/lighting.xml
|
||||
%%PLANEDIR%%/art/world/npcroom.zip
|
||||
%%PLANEDIR%%/art/world/podium.zip
|
||||
%%PLANEDIR%%/art/world/sound.xml
|
||||
%%PLANEDIR%%/ase_2_spr
|
||||
%%PLANEDIR%%/data/config/setupwindow.xml
|
||||
%%PLANEDIR%%/data/config/skinwindow.xml
|
||||
%%PLANEDIR%%/data/eedit/camera.xml
|
||||
%%PLANEDIR%%/data/eedit/editeffect.xml
|
||||
%%PLANEDIR%%/data/eedit/eedit.xml
|
||||
%%PLANEDIR%%/data/eedit/error.xml
|
||||
%%PLANEDIR%%/data/eedit/filenavigation.xml
|
||||
%%PLANEDIR%%/data/eedit/fps.xml
|
||||
%%PLANEDIR%%/data/eedit/imagelist.xml
|
||||
%%PLANEDIR%%/data/eedit/inputbox/editanchor.xml
|
||||
%%PLANEDIR%%/data/eedit/inputbox/editanchorkeyframe.xml
|
||||
%%PLANEDIR%%/data/eedit/inputbox/float.xml
|
||||
%%PLANEDIR%%/data/eedit/inputbox/list.xml
|
||||
%%PLANEDIR%%/data/eedit/inputbox/newanchor.xml
|
||||
%%PLANEDIR%%/data/eedit/inputbox/newanchorkeyframe.xml
|
||||
%%PLANEDIR%%/data/eedit/inputbox/string.xml
|
||||
%%PLANEDIR%%/data/eedit/inputbox/vec3.xml
|
||||
%%PLANEDIR%%/data/eedit/inputbox/yesno.xml
|
||||
%%PLANEDIR%%/data/eedit/keys.xml
|
||||
%%PLANEDIR%%/data/eedit/keys_def.xml
|
||||
%%PLANEDIR%%/data/eedit/loadeffect.xml
|
||||
%%PLANEDIR%%/data/eedit/loadmap.xml
|
||||
%%PLANEDIR%%/data/eedit/position.xml
|
||||
%%PLANEDIR%%/data/eedit/render.xml
|
||||
%%PLANEDIR%%/data/eedit/shortcuts.xml
|
||||
%%PLANEDIR%%/data/eedit/target.xml
|
||||
%%PLANEDIR%%/data/effects/examples/obj_quad.eff
|
||||
%%PLANEDIR%%/data/effects/examples/obj_spire.eff
|
||||
%%PLANEDIR%%/data/effects/examples/obj_star.eff
|
||||
%%PLANEDIR%%/data/effects/misc/entitylabel.eff
|
||||
%%PLANEDIR%%/data/effects/misc/marker.eff
|
||||
%%PLANEDIR%%/data/effects/misc/target.eff
|
||||
%%PLANEDIR%%/data/gui/activemagicwindow.xml
|
||||
%%PLANEDIR%%/data/gui/birth.xml
|
||||
%%PLANEDIR%%/data/gui/borderlist.xml
|
||||
%%PLANEDIR%%/data/gui/buddy.xml
|
||||
%%PLANEDIR%%/data/gui/configcamera.xml
|
||||
%%PLANEDIR%%/data/gui/configchat.xml
|
||||
%%PLANEDIR%%/data/gui/configchatfilter.xml
|
||||
%%PLANEDIR%%/data/gui/configdetails.xml
|
||||
%%PLANEDIR%%/data/gui/configentityinter.xml
|
||||
%%PLANEDIR%%/data/gui/configentitylabels.xml
|
||||
%%PLANEDIR%%/data/gui/configkeys.xml
|
||||
%%PLANEDIR%%/data/gui/configmouse.xml
|
||||
%%PLANEDIR%%/data/gui/configpvp.xml
|
||||
%%PLANEDIR%%/data/gui/configsound.xml
|
||||
%%PLANEDIR%%/data/gui/configwindow.xml
|
||||
%%PLANEDIR%%/data/gui/containerdesc.xml
|
||||
%%PLANEDIR%%/data/gui/control.xml
|
||||
%%PLANEDIR%%/data/gui/control_styles.xml
|
||||
%%PLANEDIR%%/data/gui/craft.xml
|
||||
%%PLANEDIR%%/data/gui/credits_config.xml
|
||||
%%PLANEDIR%%/data/gui/creditswindow.xml
|
||||
%%PLANEDIR%%/data/gui/charcreate.xml
|
||||
%%PLANEDIR%%/data/gui/chardescwindow.xml
|
||||
%%PLANEDIR%%/data/gui/charpick.xml
|
||||
%%PLANEDIR%%/data/gui/chat.xml
|
||||
%%PLANEDIR%%/data/gui/chatmenu.xml
|
||||
%%PLANEDIR%%/data/gui/childhood.xml
|
||||
%%PLANEDIR%%/data/gui/detailwindow.xml
|
||||
%%PLANEDIR%%/data/gui/eedit.xml
|
||||
%%PLANEDIR%%/data/gui/exchange.xml
|
||||
%%PLANEDIR%%/data/gui/filenavigation.xml
|
||||
%%PLANEDIR%%/data/gui/fingering.xml
|
||||
%%PLANEDIR%%/data/gui/glyph.xml
|
||||
%%PLANEDIR%%/data/gui/gmaddeditaction.xml
|
||||
%%PLANEDIR%%/data/gui/gmguiwindow.xml
|
||||
%%PLANEDIR%%/data/gui/gmspawn.xml
|
||||
%%PLANEDIR%%/data/gui/group.xml
|
||||
%%PLANEDIR%%/data/gui/guildwindow.xml
|
||||
%%PLANEDIR%%/data/gui/helpwindow.xml
|
||||
%%PLANEDIR%%/data/gui/ignorewindow.xml
|
||||
%%PLANEDIR%%/data/gui/infowindow.xml
|
||||
%%PLANEDIR%%/data/gui/interact.xml
|
||||
%%PLANEDIR%%/data/gui/inventory.xml
|
||||
%%PLANEDIR%%/data/gui/itemdesc.xml
|
||||
%%PLANEDIR%%/data/gui/lifeevents.xml
|
||||
%%PLANEDIR%%/data/gui/loadwindow.xml
|
||||
%%PLANEDIR%%/data/gui/loginwindow.xml
|
||||
%%PLANEDIR%%/data/gui/loot.xml
|
||||
%%PLANEDIR%%/data/gui/merchant.xml
|
||||
%%PLANEDIR%%/data/gui/money.xml
|
||||
%%PLANEDIR%%/data/gui/ok.xml
|
||||
%%PLANEDIR%%/data/gui/parents.xml
|
||||
%%PLANEDIR%%/data/gui/paths.xml
|
||||
%%PLANEDIR%%/data/gui/paws_generic.xml
|
||||
%%PLANEDIR%%/data/gui/petition.xml
|
||||
%%PLANEDIR%%/data/gui/petitiongm.xml
|
||||
%%PLANEDIR%%/data/gui/petstatwindow.xml
|
||||
%%PLANEDIR%%/data/gui/questnotebook.xml
|
||||
%%PLANEDIR%%/data/gui/questrewardwindow.xml
|
||||
%%PLANEDIR%%/data/gui/quitinfo.xml
|
||||
%%PLANEDIR%%/data/gui/readbook.xml
|
||||
%%PLANEDIR%%/data/gui/shortcutwindow.xml
|
||||
%%PLANEDIR%%/data/gui/skillwindow.xml
|
||||
%%PLANEDIR%%/data/gui/smallinventory.xml
|
||||
%%PLANEDIR%%/data/gui/spell_effect.xml
|
||||
%%PLANEDIR%%/data/gui/spellcancelwindow.xml
|
||||
%%PLANEDIR%%/data/gui/spellwindow.xml
|
||||
%%PLANEDIR%%/data/gui/splash.xml
|
||||
%%PLANEDIR%%/data/gui/styles.xml
|
||||
%%PLANEDIR%%/data/gui/summary.xml
|
||||
%%PLANEDIR%%/data/gui/widgetconfigwindow.xml
|
||||
%%PLANEDIR%%/data/gui/yesno.xml
|
||||
%%PLANEDIR%%/data/gui/zodiacs.xml
|
||||
%%PLANEDIR%%/data/guikeys.xml
|
||||
%%PLANEDIR%%/data/help.xml
|
||||
%%PLANEDIR%%/data/npcbehave.xml
|
||||
%%PLANEDIR%%/data/npcdefs.xml
|
||||
%%PLANEDIR%%/data/options/.cvsignore
|
||||
%%PLANEDIR%%/data/options/camera_def.xml
|
||||
%%PLANEDIR%%/data/options/chat_def.xml
|
||||
%%PLANEDIR%%/data/options/entityinter_def.xml
|
||||
%%PLANEDIR%%/data/options/entitylabels_def.xml
|
||||
%%PLANEDIR%%/data/options/keys_def.xml
|
||||
%%PLANEDIR%%/data/options/mouse_def.xml
|
||||
%%PLANEDIR%%/data/options/pvp_def.xml
|
||||
%%PLANEDIR%%/data/options/shortcutcommands_def.xml
|
||||
%%PLANEDIR%%/data/options/sound_def.xml
|
||||
%%PLANEDIR%%/data/partview/colorprops.xml
|
||||
%%PLANEDIR%%/data/partview/emitterprops.xml
|
||||
%%PLANEDIR%%/data/partview/environmentprops.xml
|
||||
%%PLANEDIR%%/data/partview/forceprops.xml
|
||||
%%PLANEDIR%%/data/partview/imagelist.xml
|
||||
%%PLANEDIR%%/data/partview/materialprops.xml
|
||||
%%PLANEDIR%%/data/partview/materiallist.xml
|
||||
%%PLANEDIR%%/data/partview/menubar.xml
|
||||
%%PLANEDIR%%/data/partview/otherprops.xml
|
||||
%%PLANEDIR%%/data/partview/particleprops.xml
|
||||
%%PLANEDIR%%/data/partview/pscollapsable.xml
|
||||
%%PLANEDIR%%/data/partview/pslist.xml
|
||||
%%PLANEDIR%%/data/partview/psscrollpane.xml
|
||||
%%PLANEDIR%%/data/partview/stateprops.xml
|
||||
%%PLANEDIR%%/data/partview/systemprops.xml
|
||||
%%PLANEDIR%%/data/pawseditor/filenavigation.xml
|
||||
%%PLANEDIR%%/data/pawseditor/imagelist.xml
|
||||
%%PLANEDIR%%/data/pawseditor/keys_def.xml
|
||||
%%PLANEDIR%%/data/pawseditor/pebackground.xml
|
||||
%%PLANEDIR%%/data/pawseditor/pemenu.xml
|
||||
%%PLANEDIR%%/data/pawseditor/peskinselector.xml
|
||||
%%PLANEDIR%%/data/pawseditor/pewidgettree.xml
|
||||
%%PLANEDIR%%/data/phonics.xml
|
||||
%%PLANEDIR%%/data/prefs.xml
|
||||
%%PLANEDIR%%/data/pvp_regions.xml
|
||||
%%PLANEDIR%%/data/races/descriptions.xml
|
||||
%%PLANEDIR%%/data/races/quickpaths.xml
|
||||
%%PLANEDIR%%/data/rpgrules.xml
|
||||
%%PLANEDIR%%/data/schemas/effects.xsd
|
||||
%%PLANEDIR%%/data/schemas/sounds.xsd
|
||||
%%PLANEDIR%%/data/servers.xml
|
||||
%%PLANEDIR%%/data/ttf/arial.ttf
|
||||
%%PLANEDIR%%/data/ttf/ariali.ttf
|
||||
%%PLANEDIR%%/data/ttf/becker-m.ttf
|
||||
%%PLANEDIR%%/data/ttf/comic.ttf
|
||||
%%PLANEDIR%%/data/ttf/cour.ttf
|
||||
%%PLANEDIR%%/data/ttf/cupandtalon.ttf
|
||||
%%PLANEDIR%%/data/ttf/readme.txt
|
||||
%%PLANEDIR%%/data/ttf/scurlock.ttf
|
||||
%%PLANEDIR%%/data/ttf/verdana.ttf
|
||||
%%PLANEDIR%%/data/updater/serverlist.xml
|
||||
%%PLANEDIR%%/data/updater/updaterwindow.xml
|
||||
%%PLANEDIR%%/data/zoneinfo.xml
|
||||
%%MYSQL%%%%PLANEDIR%%/dbmysql.so
|
||||
%%PLANEDIR%%/eedit
|
||||
%%PLANEDIR%%/eedit.cfg
|
||||
%%PLANEDIR%%/npcclient.cfg
|
||||
%%PLANEDIR%%/partview.cfg
|
||||
%%PLANEDIR%%/paws_generic
|
||||
%%PLANEDIR%%/paws_generic.cfg
|
||||
%%PLANEDIR%%/pawseditor
|
||||
%%PLANEDIR%%/pawseditor.cfg
|
||||
%%PLANEDIR%%/planeshift.cfg
|
||||
%%PLANEDIR%%/psclient
|
||||
%%PLANEDIR%%/psclient.cfg
|
||||
%%PLANEDIR%%/psnpcclient
|
||||
%%PLANEDIR%%/psserver
|
||||
%%PLANEDIR%%/psserver.cfg
|
||||
%%PLANEDIR%%/pssetup
|
||||
%%PLANEDIR%%/pssetup.cfg
|
||||
%%PLANEDIR%%/psupdater.cfg
|
||||
%%PLANEDIR%%/texparse
|
||||
%%PLANEDIR%%/updater
|
||||
%%PLANEDIR%%/updaterconfig.xml
|
||||
%%PLANEDIR%%/vfs.cfg
|
||||
%%EXAMPLE%%@dirrm share/examples/planeshift
|
||||
@dirrmtry %%PLANEDIR%%/art/effects
|
||||
@dirrmtry %%PLANEDIR%%/art/music/effects
|
||||
@dirrmtry %%PLANEDIR%%/art/music/gui/ccreate
|
||||
@dirrmtry %%PLANEDIR%%/art/music/gui/menu
|
||||
@dirrmtry %%PLANEDIR%%/art/music/gui
|
||||
@dirrmtry %%PLANEDIR%%/art/music
|
||||
@dirrmtry %%PLANEDIR%%/art/runes/azure
|
||||
@dirrmtry %%PLANEDIR%%/art/runes
|
||||
@dirrmtry %%PLANEDIR%%/art/shaders
|
||||
@dirrmtry %%PLANEDIR%%/art/skins
|
||||
@dirrmtry %%PLANEDIR%%/art/sounds/gui
|
||||
@dirrmtry %%PLANEDIR%%/art/sounds
|
||||
@dirrmtry %%PLANEDIR%%/art/things
|
||||
@dirrmtry %%PLANEDIR%%/art/world
|
||||
@dirrmtry %%PLANEDIR%%/art
|
||||
@dirrmtry %%PLANEDIR%%/data/config
|
||||
@dirrmtry %%PLANEDIR%%/data/eedit/inputbox
|
||||
@dirrmtry %%PLANEDIR%%/data/eedit
|
||||
@dirrmtry %%PLANEDIR%%/data/effects/examples
|
||||
@dirrmtry %%PLANEDIR%%/data/effects/misc
|
||||
@dirrmtry %%PLANEDIR%%/data/effects
|
||||
@dirrmtry %%PLANEDIR%%/data/gui
|
||||
@dirrmtry %%PLANEDIR%%/data/options
|
||||
@dirrmtry %%PLANEDIR%%/data/partview
|
||||
@dirrmtry %%PLANEDIR%%/data/pawseditor
|
||||
@dirrmtry %%PLANEDIR%%/data/races
|
||||
@dirrmtry %%PLANEDIR%%/data/schemas
|
||||
@dirrmtry %%PLANEDIR%%/data/ttf
|
||||
@dirrmtry %%PLANEDIR%%/data/updater
|
||||
@dirrmtry %%PLANEDIR%%/data
|
||||
@unexec rmdir %D/%%PLANEDIR%% >/dev/null 2>&1 || echo "Remove manually the extra files into data and art directories (200M aprox.). Also you could move data and art directory to some backup directory."
|
Loading…
Reference in a new issue