- Update to 0.5.7a
PR: ports/139166 Submitted by: Timothy Beyer <beyert@cs.ucr.edu> Approved by: maintainer
This commit is contained in:
parent
ce5103d877
commit
9367deaf27
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=244825
3 changed files with 18 additions and 26 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libmp3splt
|
||||
PORTVERSION= 0.5.4
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 0.5.7a
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= SF/mp3splt/${PORTNAME}/${PORTVERSION}
|
||||
|
||||
|
@ -20,11 +19,13 @@ USE_AUTOTOOLS= libltdl
|
|||
|
||||
OPTIONS= MP3 "mp3 support" on \
|
||||
ID3 "id3tag support for the mp3" on \
|
||||
VORBIS "ogg vorbis support" on
|
||||
VORBIS "ogg vorbis support" on \
|
||||
NLS "native language support" on
|
||||
|
||||
PLIST_DIRS= include/libmp3splt lib/libmp3splt
|
||||
PLIST_FILES= include/libmp3splt/mp3splt.h lib/libmp3splt.so.0 \
|
||||
lib/libmp3splt.so lib/libmp3splt.la lib/libmp3splt.a
|
||||
lib/libmp3splt.so lib/libmp3splt.la lib/libmp3splt.a \
|
||||
share/aclocal/mp3splt.m4
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -59,6 +60,16 @@ PLIST_FILES+= lib/libmp3splt/libsplt_ogg.a \
|
|||
lib/libmp3splt/libsplt_ogg.so.0
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_NLS)
|
||||
CONFIGURE_ARGS+= --disable-nls
|
||||
.else
|
||||
USE_GETTEXT= yes
|
||||
LANGUAGES= de fr
|
||||
.for language in ${LANGUAGES}
|
||||
PLIST_FILES+= share/locale/${language}/LC_MESSAGES/libmp3splt.mo
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
|
||||
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (libmp3splt-0.5.4.tar.gz) = a65f63dc9c176dabff3c6c85c4c3bf2c
|
||||
SHA256 (libmp3splt-0.5.4.tar.gz) = 3c454d5a49316f549bb21f3875a55c2ce37d2510d41f72136fa8cfe6fbaff9f6
|
||||
SIZE (libmp3splt-0.5.4.tar.gz) = 462620
|
||||
MD5 (libmp3splt-0.5.7a.tar.gz) = 93fd67d55b500735f1c42d260518505d
|
||||
SHA256 (libmp3splt-0.5.7a.tar.gz) = e0e945b681315037f960e2929477e3357ba9c76cde1e29a19d8e1d371a9e123e
|
||||
SIZE (libmp3splt-0.5.7a.tar.gz) = 535747
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
--- src/cddb.c.orig
|
||||
+++ src/cddb.c
|
||||
@@ -393,6 +393,16 @@
|
||||
//we read the file line by line
|
||||
while (fgets(line, 2048, file_input)!=NULL)
|
||||
{
|
||||
+ //if windows file with '\r', then pretend is a unix file
|
||||
+ if (strlen(line) > 1)
|
||||
+ {
|
||||
+ if (line[strlen(line)-2] == '\r')
|
||||
+ {
|
||||
+ line[strlen(line)-2] = '\n';
|
||||
+ line[strlen(line)-1] = '\0';
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
type = SPLT_CUE_NOTHING;
|
||||
|
||||
//we read strings from file TRACK,TITLE,AUDIO,PERFORMER,INDEX
|
Loading…
Reference in a new issue