games/spacezero: Remove expired port
2023-06-03 games/spacezero: broken, abandoned upstream, depends on deprecated gtk2
This commit is contained in:
parent
16c38f9952
commit
a26d38830d
6 changed files with 1 additions and 102 deletions
1
MOVED
1
MOVED
|
@ -7618,3 +7618,4 @@ dns/validns||2023-06-03|Has expired: Last upstream release was 10 years ago and
|
|||
sysutils/cfengine319||2023-06-03|Has expired: Upstream EOL reached on 2022-06-30
|
||||
sysutils/cfengine-masterfiles319||2023-06-03|Removed, part of expired sysutils/cfengine319
|
||||
net-mgmt/nrpe3|net-mgmt/nrpe|2023-06-03|Has expired: Fails to build with recent OpenSSL so use net-mgmt/nrpe
|
||||
games/spacezero||2023-06-03|Has expired: broken, abandoned upstream, depends on deprecated gtk2
|
||||
|
|
|
@ -927,7 +927,6 @@
|
|||
SUBDIR += solarus-quest-editor
|
||||
SUBDIR += solver
|
||||
SUBDIR += spacejunk
|
||||
SUBDIR += spacezero
|
||||
SUBDIR += speak
|
||||
SUBDIR += species
|
||||
SUBDIR += spellcast
|
||||
|
|
|
@ -1,53 +0,0 @@
|
|||
PORTNAME= spacezero
|
||||
PORTVERSION= 0.86.01
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20${PORTVERSION:R}/
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= 2D Real Time Strategy space combat game
|
||||
WWW= http://spacezero.sourceforge.net/
|
||||
|
||||
LICENSE= GPLv3+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libvorbisfile.so:audio/libvorbis
|
||||
|
||||
BROKEN= Error: no fonts found in your system
|
||||
DEPRECATED= broken, abandoned upstream, depends on deprecated gtk2
|
||||
EXPIRATION_DATE=2023-06-03
|
||||
|
||||
USES= openal:al,alut gnome pkgconfig xorg
|
||||
USE_GNOME= gtk20
|
||||
USE_XORG= x11
|
||||
MAKE_ARGS= DATADIR="${DATADIR}" \
|
||||
INSTALL_DATA_DIR="${DATADIR}"
|
||||
ALL_TARGET= ${PORTNAME}
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
LDFLAGS_i386= -Wl,-znotext
|
||||
|
||||
PORTDOCS= *
|
||||
PORTDATA= *
|
||||
PLIST_FILES= bin/${PORTNAME} \
|
||||
share/pixmaps/${PORTNAME}.ico
|
||||
|
||||
DESKTOP_ENTRIES="SpaceZero" \
|
||||
"" \
|
||||
"${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
|
||||
"${PORTNAME}" \
|
||||
"Game;StrategyGame;" \
|
||||
""
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/html/manual_files/space.ico ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.ico
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
|
||||
cd ${WRKSRC}/dat && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
|
||||
|
||||
do-install-DOCS-on:
|
||||
cd ${WRKSRC}/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
TIMESTAMP = 1669376333
|
||||
SHA256 (spacezero-0.86.01.tar.gz) = 8588a73051e35e35e6d9123b5beb39f3574623c64e8dc4f33b4e4f3003b73296
|
||||
SIZE (spacezero-0.86.01.tar.gz) = 2317419
|
|
@ -1,34 +0,0 @@
|
|||
--- Makefile.orig 2022-11-23 18:14:49 UTC
|
||||
+++ Makefile
|
||||
@@ -1,4 +1,4 @@
|
||||
-CC = /usr/bin/gcc
|
||||
+CC ?= /usr/bin/gcc
|
||||
#CC=gcc
|
||||
|
||||
BINDIR= ./bin
|
||||
@@ -31,8 +31,8 @@ GTKLIBS=`$(PKG_CONFIG) --libs gtk+-2.0`
|
||||
GTKLIBS12=`gtk-config --cflags`
|
||||
GTKFLAGS12=`gtk-config --libs`
|
||||
|
||||
-CFLAGS= -Wall --pedantic -fno-common -I./include -DDATADIR=\"$(DATADIR)\" -DINSTALL_DATA_DIR=\"$(INSTALL_DATA_DIR)\"
|
||||
-LDFLAGS= $(SOUNDFLAGS) $(GTKLIBS) -lX11 -lm -lpthread
|
||||
+CFLAGS+= -Wall --pedantic -fno-common -I./include -DDATADIR=\"$(DATADIR)\" -DINSTALL_DATA_DIR=\"$(INSTALL_DATA_DIR)\"
|
||||
+LDFLAGS+= $(SOUNDFLAGS) $(GTKLIBS) -lX11 -lm -lpthread
|
||||
|
||||
CFLAGS12= -Wall -I./include -DGTK12 -DDATADIR=\"$(DATADIR)\" -DINSTALL_DATA_DIR=\"$(INSTALL_DATA_DIR)\"
|
||||
LDFLAGS12= $(SOUNDFLAGS) $(GTKLIBS12) -lX11 -lm -lpthread
|
||||
@@ -51,7 +51,7 @@ PROGRAM_SRCS=$(SRCPATH)spacezero.c $(SRCPATH)objects.c
|
||||
all: dirs spacezero
|
||||
|
||||
spacezero: $(PROGRAM_OBJS)
|
||||
- $(CC) $(PROGRAM_OBJS) $(LDFLAGS) $(CFLAGS) -g -o $(PROGRAM)
|
||||
+ $(CC) $(PROGRAM_OBJS) $(LDFLAGS) $(CFLAGS) -o $(PROGRAM)
|
||||
|
||||
gtk12: $(PROGRAM_SRCS)
|
||||
$(CC) `gtk-config --cflags` $(PROGRAM_SRCS) $(LDFLAGS12) $(CFLAGS12) -g -o $(PROGRAM) `gtk-config --libs`
|
||||
@@ -101,4 +101,4 @@ mrproper: clean
|
||||
# add -pg for profile
|
||||
# $(CC) -pg $(CFLAGS) $(GTKFLAGS) -c $< -o $@
|
||||
# add -g for debug
|
||||
- $(CC) -g $(CFLAGS) $(GTKFLAGS) -c $< -o $@
|
||||
+ $(CC) $(CFLAGS) $(GTKFLAGS) -c $< -o $@
|
|
@ -1,11 +0,0 @@
|
|||
SpaceZero is a Real Time Strategy 2D space combat game for two
|
||||
players over a network.
|
||||
|
||||
The objective is to conquer the universe, defeating all enemies.
|
||||
|
||||
At starting point you have only one ship and one planet, but you
|
||||
have gold to buy more ships to conquer more planets.
|
||||
|
||||
All ships can be controlled by the computer (automatic mode) or by
|
||||
the player (manual mode). You can easily change among your ships,
|
||||
controlling all of them independently.
|
Loading…
Reference in a new issue