Fixup port net/gtk+licq:
- Build with pspell support. - Remove unnecessary USE_AUTOMAKE. - Properly defined optional GNOME support. - Only install GNOME helppages if building with GNOME support. - Fix build so that licq_*_gui is shared module, not static archive. - Fix pkg-plist. - Fix patch-src::options_dialog.cpp and patch-src::plugin_dialog.cpp to include - unistd.h instead of sys/unistd.h. - Bump PORTREVISION for all the fixes. PR: 26404 Submitted by: maintainer
This commit is contained in:
parent
46aa7c0001
commit
ba8fb14482
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41045
4 changed files with 47 additions and 18 deletions
|
@ -7,33 +7,38 @@
|
|||
|
||||
PORTNAME= gtk+licq
|
||||
PORTVERSION= 0.50.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://gtk.licq.org/download/
|
||||
|
||||
MAINTAINER= ishmael27@home.com
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/licq/licq_icqd.h:${PORTSDIR}/net/licq
|
||||
LIB_DEPENDS= pspell.4:${PORTSDIR}/textproc/pspell
|
||||
RUN_DEPENDS= licq:${PORTSDIR}/net/licq
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_GTK= yes
|
||||
WANT_GNOME= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_AUTOMAKE= yes
|
||||
|
||||
.if defined(WITHOUT_GNOME)
|
||||
CONFIGURE_ARGS= --disable-gnome
|
||||
GUITYPE= gtk
|
||||
.else
|
||||
GUITYPE= gnome
|
||||
.endif
|
||||
|
||||
PLIST_SUB= GUITYPE=${GUITYPE}
|
||||
|
||||
CONFIGURE_ENV= CPPFLAGS=-"I${LOCALBASE}/include" \
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
|
||||
post-install:
|
||||
strip ${PREFIX}/lib/licq/licq_${GUITYPE}_gui.a
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.if defined(HAVE_GNOME)
|
||||
USE_GNOME= yes
|
||||
CONFIGURE_ARGS= --enable-gnome
|
||||
.else
|
||||
CONFIGURE_ARGS= --disable-gnome
|
||||
post-patch:
|
||||
@${PERL5} -pi -e \
|
||||
's|^SUBDIRS\ =.*|SUBDIRS\ =\ |' ${WRKSRC}/doc/Makefile.in
|
||||
.endif
|
||||
|
||||
post-configure:
|
||||
@${PERL5} -pi -e \
|
||||
's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
|
||||
${WRKSRC}/libtool
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -3,7 +3,7 @@
|
|||
@@ -1,5 +1,6 @@
|
||||
#include "gtk-gui.h"
|
||||
|
||||
+#include <sys/unistd.h>
|
||||
+#include <unistd.h>
|
||||
#include <sys/time.h>
|
||||
#include <stdio.h>
|
||||
#include <sys/types.h>
|
||||
|
|
|
@ -3,7 +3,7 @@
|
|||
@@ -1,5 +1,6 @@
|
||||
#include "gtk-gui.h"
|
||||
|
||||
+#include <sys/unistd.h>
|
||||
+#include <unistd.h>
|
||||
#include <sys/time.h>
|
||||
#include <stdio.h>
|
||||
#include <sys/types.h>
|
||||
|
|
|
@ -1,4 +1,24 @@
|
|||
lib/licq/licq_%%GUITYPE%%_gui.a
|
||||
%%GNOME:%%lib/licq/licq_gnome_gui.so
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/arvancedusage.html
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/authors.html
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/bugs.html
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/docbook.css
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/goodstuff.html
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_applet.png
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_chatwindow.png
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_infowindow.png
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_mainwindow.png
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_optionwindow.png
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_regwindow.png
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_searchwindow.png
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_sendwindow.png
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_viewwindow.png
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/index.html
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/license.html
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/prefs.html
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/topic.dat
|
||||
%%GNOME:%%share/gnome/help/gtk+licq/C/usage.html
|
||||
%%NOGNOME:%%lib/licq/licq_gtk_gui.so
|
||||
share/licq/gtk-gui/pixmaps/arrow.xpm
|
||||
share/licq/gtk-gui/pixmaps/chatBeep.xpm
|
||||
share/licq/gtk-gui/pixmaps/chatBold.xpm
|
||||
|
@ -21,6 +41,10 @@ share/licq/gtk-gui/pixmaps/sideways_strippeddownlogo.xpm
|
|||
share/locale/de/LC_MESSAGES/gtk+licq.mo
|
||||
share/locale/es/LC_MESSAGES/gtk+licq.mo
|
||||
share/locale/pt/LC_MESSAGES/gtk+licq.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/gtk+licq.mo
|
||||
share/locale/ru/LC_MESSAGES/gtk+licq.mo
|
||||
%%GNOME:%%@dirrm share/gnome/help/gtk+licq/C/images
|
||||
%%GNOME:%%@dirrm share/gnome/help/gtk+licq/C
|
||||
%%GNOME:%%@dirrm share/gnome/help/gtk+licq
|
||||
@dirrm share/licq/gtk-gui/pixmaps
|
||||
@dirrm share/licq/gtk-gui
|
||||
|
|
Loading…
Reference in a new issue