freebsd-ports/dns/adns/files/patch-ab
Will Andrews 63eef36fd6 Add adns, an asynchronous DNS resolver library that provides a way to do
nslookups in a non-blocking manner. The adns distribution also comes with
some utilities similar to dig, host, nslookup, etc.

The port that I'm importing rips out the ${PORTOBJFORMAT} checking and
also trims the extra stuff in pkg/DESCR, which the original submission
contained.

PR:		17510
Submitted by:	Kostya Lukin <lukin@sapa.ivcme.elektra.ru>
Reviewed by:	billf, mharo
2000-04-02 05:37:29 +00:00

30 lines
769 B
Text

--- dynamic/Makefile.in.orig Fri Oct 15 21:57:50 1999
+++ dynamic/Makefile.in Mon Mar 20 18:41:21 2000
@@ -24,7 +24,7 @@
srcdir= @srcdir@
VPATH= @srcdir@
-TARGETS= $(SHLIBFILE) $(SHLIBSONAME) $(SHLIBFORLINK)
+TARGETS= $(SHLIBFILE) $(SHLIBFORLINK)
include $(srcdir)/../settings.make
include $(srcdir)/../src/adns.make
@@ -32,16 +32,12 @@
install:
$(INSTALL_PROGRAM) $(SHLIBFILE) $(lib_dir)/$(SHLIBFILE)
- ln -sf $(SHLIBFILE) $(lib_dir)/$(SHLIBSONAME)
uninstall:
- rm -f $(lib_dir)/$(SHLIBFILE) $(lib_dir)/$(SHLIBSONAME)
+ rm -f $(lib_dir)/$(SHLIBFILE)
$(SHLIBFORLINK):
- ln -s $(SHLIBSONAME) $(SHLIBFORLINK)
-
-$(SHLIBSONAME):
- ln -s $(SHLIBFILE) $(SHLIBSONAME)
+ ln -s $(SHLIBFILE) $(SHLIBFORLINK)
$(SHLIBFILE): $(ALLOBJS)
rm -f $@