freebsd-ports/x11-toolkits/xmhtml/files/patch-ad

24 lines
669 B
Text

--- lib/Makefile.orig Wed Feb 3 19:43:26 1999
+++ lib/Makefile Tue Nov 2 01:28:54 1999
@@ -25,7 +25,7 @@
# Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. #
##############################################################################
#
-LIBRARY=libXmHTML.a
+LIBRARY=libXmHTML.la
# Target to make
TARGET=$(LIBRARY)
@@ -44,9 +44,9 @@
@(set -x; cd common; $(MAKE) all $(pass_flags) )
$(TARGET):: common $(PLATFORM)
- $(RM) $@ \
- $(AR) $@ common/*.o $(PLATFORM)/*.o
- $(RANLIB) $@
+ $(RM) $@
+ $(CC) -o $@ common/*.lo $(PLATFORM)/*.lo \
+ -rpath ${PREFIX}/lib -version-info 1:2
depend::
@( for dir in $(SUBDIRS) ; do \