Include the FreeType2 component of PIL. Bump revision.
This commit is contained in:
parent
6a5f9caaa4
commit
0c0f09f97e
4 changed files with 8 additions and 15 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.26 2006/06/20 23:32:36 minskim Exp $
|
||||
# $NetBSD: Makefile,v 1.27 2007/01/20 15:17:20 joerg Exp $
|
||||
|
||||
DISTNAME= Imaging-1.1.5
|
||||
PKGNAME= ${PYPKGPREFIX}-imaging-1.1.5
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= graphics python
|
||||
MASTER_SITES= http://effbot.org/downloads/
|
||||
|
||||
|
@ -21,6 +21,7 @@ post-install:
|
|||
${PREFIX}/${PYINC}/PIL )
|
||||
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../graphics/freetype2/buildlink3.mk"
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../graphics/jpeg/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 2005/10/12 14:48:44 drochner Exp $
|
||||
@comment $NetBSD: PLIST,v 1.8 2007/01/20 15:17:20 joerg Exp $
|
||||
${PYINC}/PIL/ImPlatform.h
|
||||
${PYINC}/PIL/Imaging.h
|
||||
${PYSITELIB}/PIL.pth
|
||||
|
@ -225,5 +225,6 @@ ${PYSITELIB}/PIL/__init__.py
|
|||
${PYSITELIB}/PIL/__init__.pyc
|
||||
${PYSITELIB}/PIL/__init__.pyo
|
||||
${PYSITELIB}/PIL/_imaging.so
|
||||
${PYSITELIB}/PIL/_imagingft.so
|
||||
@dirrm ${PYINC}/PIL
|
||||
@dirrm ${PYSITELIB}/PIL
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.9 2005/10/12 14:48:44 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.10 2007/01/20 15:17:20 joerg Exp $
|
||||
|
||||
SHA1 (python/Imaging-1.1.5.tar.gz) = 06705b31b534a15aef827bccc87dceb9ebc51b9f
|
||||
RMD160 (python/Imaging-1.1.5.tar.gz) = 99ca581f2f96d1112f6c36eccdf96da1ac014a04
|
||||
Size (python/Imaging-1.1.5.tar.gz) = 429570 bytes
|
||||
SHA1 (patch-ab) = ccf70356bba6d5628d8cc40c1101dc4338bb6a55
|
||||
SHA1 (patch-ab) = 8f2738dd72765490ea124e508331c2b7596d687e
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ab,v 1.4 2005/10/12 14:48:44 drochner Exp $
|
||||
$NetBSD: patch-ab,v 1.5 2007/01/20 15:17:20 joerg Exp $
|
||||
|
||||
--- setup.py.orig 2005-03-23 19:16:40.000000000 +0100
|
||||
+++ setup.py
|
||||
|
@ -24,15 +24,6 @@ $NetBSD: patch-ab,v 1.4 2005/10/12 14:48:44 drochner Exp $
|
|||
add_directory(library_dirs, "/usr/lib")
|
||||
add_directory(include_dirs, "/usr/include")
|
||||
|
||||
@@ -210,7 +204,7 @@ class pil_build_ext(build_ext):
|
||||
if find_library_file(self, "tiff"):
|
||||
feature.tiff = "tiff"
|
||||
|
||||
- if find_library_file(self, "freetype"):
|
||||
+ if 0:
|
||||
# look for freetype2 include files
|
||||
freetype_version = 0
|
||||
for dir in include_dirs:
|
||||
@@ -433,7 +427,7 @@ if __name__ == "__main__":
|
||||
package_dir={"": "PIL"},
|
||||
packages=[""],
|
||||
|
|
Loading…
Reference in a new issue