Remove unnecessary patch, int i is now declared in this function.

No functional change.
This commit is contained in:
maya 2016-08-14 16:27:33 +00:00
parent 210b2bb0f9
commit 119b4fd524
2 changed files with 1 additions and 17 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.49 2016/08/03 12:06:47 maya Exp $
$NetBSD: distinfo,v 1.50 2016/08/14 16:27:33 maya Exp $
SHA1 (ffmpeg-2.8.7.tar.xz) = 8c0fb21703cf77442338a26f2f645eda68bde6b2
RMD160 (ffmpeg-2.8.7.tar.xz) = ed757d4ed2763af3260ad13937f072831058d52d
@ -9,6 +9,5 @@ SHA1 (patch-configure) = 330e73d68491b7b27b88df9055a7bdbb913b37e3
SHA1 (patch-doc_Makefile) = 48d3b3ccd800303a73fcda79e78533228f79d750
SHA1 (patch-libavcodec_x86_ac3dsp_init.c) = f997271f4f4604987591d7f17c571aaaa8a6188a
SHA1 (patch-libavutil_common.h) = de36efed3a8a2069e170e5afe77eb122a46d14b2
SHA1 (patch-libavutil_opencl.c) = 00ea04f9febe60b9428ac8c3b7e14ae01a955685
SHA1 (patch-libavutil_x86_asm.h) = 85c5403e97449639253d3c97391dfbb4cadb2548
SHA1 (patch-libavutil_x86_cpu.c) = 499b0fc3081971a2bba2724bd051aab14c531239

View file

@ -1,15 +0,0 @@
$NetBSD: patch-libavutil_opencl.c,v 1.3 2016/01/16 17:04:33 leot Exp $
Fix undeclared identifier error.
--- libavutil/opencl.c.orig 2016-01-15 16:58:37.000000000 +0000
+++ libavutil/opencl.c
@@ -457,7 +457,7 @@ cl_program av_opencl_compile(const char
cl_program program = NULL;
LOCK_OPENCL;
- for (i = 0; i < opencl_ctx.kernel_code_count; i++) {
+ for (int i = 0; i < opencl_ctx.kernel_code_count; i++) {
// identify a program using a unique name within the kernel source
ptr = av_stristr(opencl_ctx.kernel_code[i].kernel_string, program_name);
if (ptr && !opencl_ctx.kernel_code[i].is_compiled) {