Update to 0.9.0:
New in 0.9.0: 2004-11-30: - Documentation updates - KII target improvements - minor fixes to button and symbol handling - handle labels correctly now - merge improvements from the FreeBSD ports tree - works on Windows using MinGW w/o requiring special Makefiles. - task scheduler as an abstraction for platform independent threads. - DirectX target improvements - Tries to use the actual keyboard layout, and only fall back to the hardcoded defines when that does not work. - Makes shift and caps lock bring you capital letters. - Dead keys support (GIIK_VOID in sym, synthetic press/release events if non-matching key is hit after the dead key). - Renamed Caps, Num and Scroll to CapsLock, NumLock etc. - Mouse wheel support. - Support for up to 8 mouse buttons (2 previously). - Support for emPtrRelative. - Preliminary support for emPtrRelative. - Fixed a bug so that a lot of surplus emPtrAbsolute events are killed. - Support for various game controllers. - The mouse and the keyboard are separated into two devices. - Emulates key repeat messages. New in 0.8.7: 2004-11-30: * hotfix: input-linux-evdev: fix compiling error where KEY_103RD is not defined (SuSE 9.1) * minor buildsystem update * use more length bounded string operations
This commit is contained in:
parent
0d0a486642
commit
1825c7529a
8 changed files with 53 additions and 32 deletions
|
@ -1,11 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.14 2005/02/21 20:26:11 hubertf Exp $
|
||||
# $NetBSD: Makefile,v 1.15 2005/03/25 02:46:49 wiz Exp $
|
||||
|
||||
DISTNAME= libgii-0.8.6.src
|
||||
DISTNAME= libgii-0.9.0.src
|
||||
PKGNAME= ${DISTNAME:S/.src//}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ftp://ftp.ggi-project.org/pub/packages/ggi/ggi/v2.0/ \
|
||||
http://www.ggi-project.org/ftp/ggi/v2.0/ \
|
||||
MASTER_SITES= ftp://ftp.ggi-project.org/pub/packages/ggi/ggi/v2.1/ \
|
||||
http://www.ggi-project.org/ftp/ggi/v2.1/ \
|
||||
${MASTER_SITE_SOURCEFORGE:=ggi/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
|
|
|
@ -1,11 +1,16 @@
|
|||
@comment $NetBSD: PLIST,v 1.6 2004/09/22 08:09:36 jlam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.7 2005/03/25 02:46:49 wiz Exp $
|
||||
bin/mhub
|
||||
bin/xsendbut
|
||||
include/ggi/errors.h
|
||||
include/ggi/events.h
|
||||
include/ggi/gg-defs.h
|
||||
include/ggi/gg.h
|
||||
include/ggi/gii-defs.h
|
||||
include/ggi/gii-unix.h
|
||||
include/ggi/gii.h
|
||||
include/ggi/input/cocoa.h
|
||||
include/ggi/input/directx.h
|
||||
include/ggi/input/kii.h
|
||||
include/ggi/input/lin_kbd.h
|
||||
include/ggi/input/xwin.h
|
||||
include/ggi/internal/gii-dl.h
|
||||
|
@ -28,18 +33,36 @@ lib/ggi/input/xwin.la
|
|||
lib/libgg.la
|
||||
lib/libgii.la
|
||||
man/man1/mhub.1
|
||||
man/man1/xsendbut.1
|
||||
man/man3/GG_SCHED_TICKS2USECS.3
|
||||
man/man3/GG_SCHED_USECS2TICKS.3
|
||||
man/man3/gg-error.3
|
||||
man/man3/gg-types.3
|
||||
man/man3/ggAddTask.3
|
||||
man/man3/ggCleanupForceExit.3
|
||||
man/man3/ggCurTime.3
|
||||
man/man3/ggDelTask.3
|
||||
man/man3/ggExit.3
|
||||
man/man3/ggFreeModule.3
|
||||
man/man3/ggGetSwarType.3
|
||||
man/man3/ggGetSymbolAddress.3
|
||||
man/man3/ggGetUserDir.3
|
||||
man/man3/ggInit.3
|
||||
man/man3/ggLoadModule.3
|
||||
man/man3/ggLock.3
|
||||
man/man3/ggLockCreate.3
|
||||
man/man3/ggLockDestroy.3
|
||||
man/man3/ggRegisterCleanup.3
|
||||
man/man3/ggTimeBase.3
|
||||
man/man3/ggTryLock.3
|
||||
man/man3/ggUSleep.3
|
||||
man/man3/ggUSlumber.3
|
||||
man/man3/ggUnlock.3
|
||||
man/man3/ggUnregisterCleanup.3
|
||||
man/man3/ggi-error.3
|
||||
man/man3/ggstrlcat.3
|
||||
man/man3/ggstrlcpy.3
|
||||
man/man3/gii-error.3
|
||||
man/man3/giiAddEventMask.3
|
||||
man/man3/giiClose.3
|
||||
man/man3/giiEventPoll.3
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.2 2004/10/03 00:14:55 tv Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.3 2005/03/25 02:46:49 wiz Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
LIBGII_BUILDLINK3_MK:= ${LIBGII_BUILDLINK3_MK}+
|
||||
|
@ -11,8 +11,7 @@ BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nlibgii}
|
|||
BUILDLINK_PACKAGES+= libgii
|
||||
|
||||
.if !empty(LIBGII_BUILDLINK3_MK:M+)
|
||||
BUILDLINK_DEPENDS.libgii+= libgii>=0.8.3
|
||||
BUILDLINK_RECOMMENDED.libgii+= libgii>=0.8.6nb1
|
||||
BUILDLINK_DEPENDS.libgii+= libgii>=0.9.0
|
||||
BUILDLINK_PKGSRCDIR.libgii?= ../../graphics/libgii
|
||||
|
||||
USE_X11= yes
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.10 2005/02/24 08:45:09 agc Exp $
|
||||
$NetBSD: distinfo,v 1.11 2005/03/25 02:46:49 wiz Exp $
|
||||
|
||||
SHA1 (libgii-0.8.6.src.tar.bz2) = c2ba5b2605c7e9ff73e7786ebf229667efe44a0d
|
||||
RMD160 (libgii-0.8.6.src.tar.bz2) = 914e0cfa5a331f0ccbc23b1f243720347d821667
|
||||
Size (libgii-0.8.6.src.tar.bz2) = 395625 bytes
|
||||
SHA1 (patch-aa) = 16bcb98d49fde5119c645d8eec3679663c826c0a
|
||||
SHA1 (patch-ae) = 92ac54c2fa1375c99b9acca4443d27b9bca61821
|
||||
SHA1 (patch-af) = 08d35ebfd60c67027ae6ed09b729c4ac3196c19d
|
||||
SHA1 (patch-ag) = 806b0876ca7f8e6b172cb5253c96602f864bce0b
|
||||
SHA1 (libgii-0.9.0.src.tar.bz2) = b7b075d62b51ec6e51e50e60a348bea2699cde67
|
||||
RMD160 (libgii-0.9.0.src.tar.bz2) = e6a2f15a7926db86ed1475681584b695f6bbfd8e
|
||||
Size (libgii-0.9.0.src.tar.bz2) = 505030 bytes
|
||||
SHA1 (patch-aa) = 3dd014586dc16b95125336539d74b6040bd9eb0a
|
||||
SHA1 (patch-ae) = e6396eb643c89dc24a3b51109a5dc3264c12a30e
|
||||
SHA1 (patch-af) = 44c23eb8fd16ccde9a942643e30625fc96ca2169
|
||||
SHA1 (patch-ag) = a223af4dd1aec691406d7bc295b3d002185de747
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.4 2004/09/20 22:37:08 wiz Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2005/03/25 02:46:49 wiz Exp $
|
||||
|
||||
--- Makefile.in.orig 2004-09-14 21:28:36.000000000 +0200
|
||||
--- Makefile.in.orig 2004-11-30 21:56:24.000000000 +0100
|
||||
+++ Makefile.in
|
||||
@@ -209,7 +209,7 @@ target_alias = @target_alias@
|
||||
@@ -255,7 +255,7 @@ target_alias = @target_alias@
|
||||
# multiple AUTOMAKE_OPTIONS lines only confuses automake 1.6
|
||||
AUTOMAKE_OPTIONS = 1.4 foreign
|
||||
SUBDIRS = include gg gii input filter demos doc m4 dist
|
||||
SUBDIRS = include gg gii input filter regress demos doc m4 dist
|
||||
-giiconfdatadir = ${sysconfdir}/${ggi_subdir}
|
||||
+giiconfdatadir = ${prefix}/share/examples/ggi
|
||||
giiconfdata_DATA = libgii.conf
|
||||
DISTCLEANFILES = libgii.conf
|
||||
EXTRA_DIST = ChangeLog.1999 ChangeLog FAQ INSTALL.autoconf autogen.sh
|
||||
EXTRA_DIST = ChangeLog.1999 ChangeLog FAQ INSTALL.autoconf \
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-ae,v 1.4 2004/09/20 22:37:08 wiz Exp $
|
||||
$NetBSD: patch-ae,v 1.5 2005/03/25 02:46:49 wiz Exp $
|
||||
|
||||
--- configure.orig 2004-09-14 21:29:33.000000000 +0200
|
||||
--- configure.orig 2004-11-30 21:56:28.000000000 +0100
|
||||
+++ configure
|
||||
@@ -17503,7 +17503,7 @@ cat >>confdefs.h <<_ACEOF
|
||||
_ACEOF
|
||||
@@ -20024,7 +20024,7 @@ _ACEOF
|
||||
|
||||
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
-#define GIICONFDIR "$PATHTAG$static_sysconfdir/$ggi_subdir"
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-af,v 1.2 2004/09/20 22:37:08 wiz Exp $
|
||||
$NetBSD: patch-af,v 1.3 2005/03/25 02:46:49 wiz Exp $
|
||||
|
||||
--- filter/mouse/Makefile.in.orig 2004-09-14 21:28:45.000000000 +0200
|
||||
--- filter/mouse/Makefile.in.orig 2004-11-30 21:56:00.000000000 +0100
|
||||
+++ filter/mouse/Makefile.in
|
||||
@@ -210,7 +210,7 @@ mouse_la_SOURCES = filter.c
|
||||
@@ -256,7 +256,7 @@ mouse_la_SOURCES = filter.c
|
||||
mouse_la_LDFLAGS = ${extra_libraries} -module -no-undefined -avoid-version \
|
||||
-export-symbols ${srcdir}/EXPSYMS
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ag,v 1.2 2004/09/20 22:37:08 wiz Exp $
|
||||
$NetBSD: patch-ag,v 1.3 2005/03/25 02:46:49 wiz Exp $
|
||||
|
||||
--- filter/keytrans/Makefile.in.orig 2004-09-14 21:28:43.000000000 +0200
|
||||
--- filter/keytrans/Makefile.in.orig 2004-11-30 21:55:59.000000000 +0100
|
||||
+++ filter/keytrans/Makefile.in
|
||||
@@ -210,7 +210,7 @@ keytrans_la_SOURCES = filter.c
|
||||
@@ -256,7 +256,7 @@ keytrans_la_SOURCES = filter.c
|
||||
keytrans_la_LDFLAGS = ${extra_libraries} -module -no-undefined -avoid-version \
|
||||
-export-symbols ${srcdir}/EXPSYMS
|
||||
|
||||
|
|
Loading…
Reference in a new issue