glib2: fix update builds on macOS.

Use DYLD_LIBRARY_PATH (searched first) instead of
DYLD_FALLBACK_LIBRARY_PATH (searched last) to find newly built libraries
even if an earlier version is already installed.
This commit is contained in:
schmonz 2023-08-22 14:09:37 +00:00
parent 75389b626a
commit 3315d03841
2 changed files with 19 additions and 19 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.312 2023/07/11 05:54:33 adam Exp $
$NetBSD: distinfo,v 1.313 2023/08/22 14:09:37 schmonz Exp $
BLAKE2s (glib-2.76.4.tar.xz) = feba1f5bb8ae7a2f37d322490f218021dfd2a934289df2c3dccf4c7ee8af2a5d
SHA512 (glib-2.76.4.tar.xz) = f76932dc5090a44880373228e2b162f338415d06f7c90f2950eab1a43bb191c56a1797da4d377594f6a999197fef4defb848039259cfa4105bb68288a928f5b7
@ -12,7 +12,7 @@ SHA1 (patch-gio_gunixcredentialsmessage.c) = c13119ddd6262db7c03e53857e987f0c495
SHA1 (patch-gio_gunixmounts.c) = 48b6945fde5b1721ca246eb7e79f73b5b480e816
SHA1 (patch-gio_inotify_inotify-kernel.c) = 78544b4c32ef3b44e8721b1c07407f46a9e8c8a4
SHA1 (patch-gio_meson.build) = 317da05e008d7bbdbc4c02c3057e8bef514fafae
SHA1 (patch-gio_tests_meson.build) = 6e02b4b16b7e668e91b6d308b70c3e5492aef038
SHA1 (patch-gio_tests_meson.build) = 9fa1bdc65768c288d273298a75280485b7bff350
SHA1 (patch-glib_gatomic.c) = deb2e74010523ad41ce141aa2f49b807ba2672e6
SHA1 (patch-glib_gatomic.h) = d1c39c3594a5c89d196349e5eafb5512795f55f8
SHA1 (patch-glib_genviron.c) = dd25be36536d56dfe933225d785eb65f753c4a97

View file

@ -1,82 +1,82 @@
$NetBSD: patch-gio_tests_meson.build,v 1.7 2023/05/20 11:53:10 bacon Exp $
$NetBSD: patch-gio_tests_meson.build,v 1.8 2023/08/22 14:09:37 schmonz Exp $
Work around PR pkg/57399. + DYLD_LIBRARY_PATH for macOS
--- gio/tests/meson.build 2023-02-23 21:54:27.000000000 +0800
+++ gio/tests/meson.build 2023-05-16 13:37:44.000000000 +0800
@@ -662,6 +662,10 @@
--- gio/tests/meson.build.orig 2023-07-06 15:39:47.000000000 +0000
+++ gio/tests/meson.build
@@ -756,6 +756,10 @@ if not meson.is_cross_build()
plugin_resources_c = custom_target('plugin-resources.c',
input : 'test4.gresource.xml',
output : 'plugin-resources.c',
+ env : {
+ 'LC_ALL': 'en_US.UTF-8',
+ 'DYLD_FALLBACK_LIBRARY_PATH': '@0@/glib:@0@/gio:@0@/gobject:@0@/gmodule'.replace('@0@', meson.project_build_root())
+ 'DYLD_LIBRARY_PATH': '@0@/glib:@0@/gio:@0@/gobject:@0@/gmodule'.replace('@0@', meson.project_build_root())
+ },
command : [glib_compile_resources,
compiler_type,
'--target=@OUTPUT@',
@@ -690,6 +694,10 @@
@@ -785,6 +789,10 @@ if not meson.is_cross_build()
test_gresource = custom_target('test.gresource',
input : 'test.gresource.xml',
output : 'test.gresource',
+ env : {
+ 'LC_ALL': 'en_US.UTF-8',
+ 'DYLD_FALLBACK_LIBRARY_PATH': '@0@/glib:@0@/gio:@0@/gobject:@0@/gmodule'.replace('@0@', meson.project_build_root())
+ 'DYLD_LIBRARY_PATH': '@0@/glib:@0@/gio:@0@/gobject:@0@/gmodule'.replace('@0@', meson.project_build_root())
+ },
command : [glib_compile_resources,
compiler_type,
'--target=@OUTPUT@',
@@ -704,6 +712,10 @@
@@ -799,6 +807,10 @@ if not meson.is_cross_build()
test_resources2_c = custom_target('test_resources2.c',
input : 'test3.gresource.xml',
output : 'test_resources2.c',
+ env : {
+ 'LC_ALL': 'en_US.UTF-8',
+ 'DYLD_FALLBACK_LIBRARY_PATH': '@0@/glib:@0@/gio:@0@/gobject:@0@/gmodule'.replace('@0@', meson.project_build_root())
+ 'DYLD_LIBRARY_PATH': '@0@/glib:@0@/gio:@0@/gobject:@0@/gmodule'.replace('@0@', meson.project_build_root())
+ },
command : [glib_compile_resources,
compiler_type,
'--target=@OUTPUT@',
@@ -717,6 +729,10 @@
@@ -812,6 +824,10 @@ if not meson.is_cross_build()
test_resources2_h = custom_target('test_resources2.h',
input : 'test3.gresource.xml',
output : 'test_resources2.h',
+ env : {
+ 'LC_ALL': 'en_US.UTF-8',
+ 'DYLD_FALLBACK_LIBRARY_PATH': '@0@/glib:@0@/gio:@0@/gobject:@0@/gmodule'.replace('@0@', meson.project_build_root())
+ 'DYLD_LIBRARY_PATH': '@0@/glib:@0@/gio:@0@/gobject:@0@/gmodule'.replace('@0@', meson.project_build_root())
+ },
command : [glib_compile_resources,
compiler_type,
'--target=@OUTPUT@',
@@ -731,6 +747,10 @@
@@ -826,6 +842,10 @@ if not meson.is_cross_build()
input : 'test2.gresource.xml',
depends : big_test_resource,
output : 'test_resources.c',
+ env : {
+ 'LC_ALL': 'en_US.UTF-8',
+ 'DYLD_FALLBACK_LIBRARY_PATH': '@0@/glib:@0@/gio:@0@/gobject:@0@/gmodule'.replace('@0@', meson.project_build_root())
+ 'DYLD_LIBRARY_PATH': '@0@/glib:@0@/gio:@0@/gobject:@0@/gmodule'.replace('@0@', meson.project_build_root())
+ },
command : [glib_compile_resources,
compiler_type,
'--target=@OUTPUT@',
@@ -744,6 +764,10 @@
@@ -839,6 +859,10 @@ if not meson.is_cross_build()
digit_test_resources_c = custom_target('digit_test_resources.c',
input : '111_digit_test.gresource.xml',
output : 'digit_test_resources.c',
+ env : {
+ 'LC_ALL': 'en_US.UTF-8',
+ 'DYLD_FALLBACK_LIBRARY_PATH': '@0@/glib:@0@/gio:@0@/gobject:@0@/gmodule'.replace('@0@', meson.project_build_root())
+ 'DYLD_LIBRARY_PATH': '@0@/glib:@0@/gio:@0@/gobject:@0@/gmodule'.replace('@0@', meson.project_build_root())
+ },
command : [glib_compile_resources,
compiler_type,
'--target=@OUTPUT@',
@@ -757,6 +781,10 @@
@@ -852,6 +876,10 @@ if not meson.is_cross_build()
digit_test_resources_h = custom_target('digit_test_resources.h',
input : '111_digit_test.gresource.xml',
output : 'digit_test_resources.h',
+ env : {
+ 'LC_ALL': 'en_US.UTF-8',
+ 'DYLD_FALLBACK_LIBRARY_PATH': '@0@/glib:@0@/gio:@0@/gobject:@0@/gmodule'.replace('@0@', meson.project_build_root())
+ 'DYLD_LIBRARY_PATH': '@0@/glib:@0@/gio:@0@/gobject:@0@/gmodule'.replace('@0@', meson.project_build_root())
+ },
command : [glib_compile_resources,
compiler_type,