librime: update to 1.8.3.
1.8.3 ### Bug Fixes * skip key combos with super modifier 1.8.2 Bug fixes 1.8.1 Bug fixes 1.8.0 ### Bug Fixes * **algo, dict:** add an extra set of parenthesis to std::min ... * **charset_filter:** Update `is_extended_cjk` to compatible with Unicode 15 * **chord_composer:** first key missing from raw input * **chord_composer:** invisible placeholder char prepended to output * **ci:** download and extract boost * **ci:** install Rime plugins' dependencies * **ci:** no hardcoded boost version in ci scripts * **dict_compiler:** shrink .reverse.bin file to fit after build * **reverse_lookup_dictionary:** writing data to overflow buffer * **setup:** avoid glog log macros conflict with macros of Windows * fix missing control paths issue * qualify std::exp after including <cmath> * **ci:** update ci script for windows * **dictionary:** had unsorted chunks after the previous chunk ended * **editor:** `back_syllable` should reopen selected words * replace bintry mirror with jfrog ### Features * **api:** get_state_label returns the state label for UI display * **ci:** add GitHub action ci support * **ci:** add pull request ci * **ci:** add tag release ci * **context:** allow composing with zero input * **key_binder:** single select a radio group option * **key_binder:** toggle the switch defined at index `toggle: '@n'` * **navigator,selector:** vertical navigation * **plugins:** support plugin specs in slug@branch format * **selector:** handle repeated key until release * add windows ci job * delete selected candidate * half/full-shape labels for more characters * **simplifier:** can be configured to return empty comment
This commit is contained in:
parent
b545c618d0
commit
4961411061
3 changed files with 13 additions and 14 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.29 2023/01/22 16:28:32 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.30 2023/01/30 10:35:19 wiz Exp $
|
||||
|
||||
DISTNAME= librime-1.7.3
|
||||
PKGREVISION= 1
|
||||
DISTNAME= librime-1.8.3
|
||||
CATEGORIES= inputmethod chinese
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=rime/}
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.11 2022/08/05 13:02:35 adam Exp $
|
||||
$NetBSD: distinfo,v 1.12 2023/01/30 10:35:19 wiz Exp $
|
||||
|
||||
BLAKE2s (librime-1.7.3.tar.gz) = ccda7fe5c2bdd91d84cc157c1ecc9d627566e6caa5779e07944a73c013b6a655
|
||||
SHA512 (librime-1.7.3.tar.gz) = 8767d17c3d14a5a1bbb8269fab1627b907de72c288b362fdbc6191223937da21e8b18471b4ae8f83ce5afc0ec5c3ab12fbcb49930eb9969c1764c7390d9ee4b0
|
||||
Size (librime-1.7.3.tar.gz) = 2859513 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = 930aafc5967ae962f6fd70aa76f0b962107a8b7f
|
||||
BLAKE2s (librime-1.8.3.tar.gz) = 3d5cd233a758a01a0798836f0bb41811c710b6e52e93f4d44ea46b9c30abdd3e
|
||||
SHA512 (librime-1.8.3.tar.gz) = 0c8a9a50a36c195173a6759257f0d985de94f532265f9d8eba4e6675307bce64ae5a2ca8facdd3da1be72bc0814524e4f1203d8cdc569678ec6a8444231e19ab
|
||||
Size (librime-1.8.3.tar.gz) = 2623439 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = ba75c194bb245e73c45df7cdde2e17bb74e29eda
|
||||
SHA1 (patch-plugins_CMakeLists.txt) = ab0b528c0a9219c52d0a8ca596209799db9de14a
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
$NetBSD: patch-CMakeLists.txt,v 1.4 2022/04/25 22:29:15 tnn Exp $
|
||||
$NetBSD: patch-CMakeLists.txt,v 1.5 2023/01/30 10:35:19 wiz Exp $
|
||||
|
||||
* Install pkg-config pc file for more platforms.
|
||||
Install pkg-config file on all platforms.
|
||||
|
||||
--- CMakeLists.txt.orig 2021-02-07 12:37:26.000000000 +0000
|
||||
--- CMakeLists.txt.orig 2023-01-30 10:30:54.591650411 +0000
|
||||
+++ CMakeLists.txt
|
||||
@@ -180,7 +180,7 @@ configure_file(
|
||||
@@ -187,7 +187,7 @@ configure_file(
|
||||
add_custom_target(uninstall
|
||||
COMMAND ${CMAKE_COMMAND} -P ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake)
|
||||
|
||||
-if(${CMAKE_SYSTEM_NAME} MATCHES "Linux|FreeBSD|DragonFly|GNU")
|
||||
+if(${CMAKE_SYSTEM_NAME} MATCHES "Linux|FreeBSD|DragonFly|GNU|NetBSD|OpenBSD|SunOS")
|
||||
-if(${CMAKE_SYSTEM_NAME} MATCHES "Linux|FreeBSD|DragonFly|GNU" OR MINGW)
|
||||
+if(${CMAKE_SYSTEM_NAME} MATCHES ".*" OR MINGW)
|
||||
set(prefix "${CMAKE_INSTALL_PREFIX}")
|
||||
set(exec_prefix "${CMAKE_INSTALL_PREFIX}")
|
||||
set(bindir "${CMAKE_INSTALL_FULL_BINDIR}")
|
||||
|
|
Loading…
Reference in a new issue