pixman: update to 0.40.0.

log:
	Adam Jackson (17):
	      test: Fix undefined left shift in affine-test
	      test: Fix undefined left shift in pixel_checker_init
	      pixman: Fix undefined left shift in pixel_contract_from_float
	      pixman-access: Fix various undefined left shifts
	      pixman-combine: Fix various undefined left shifts
	      pixman-image: Fix undefined left shift
	      pixman-gradient-walker: Fix undefined left shift
	      pixman-sse2: Fix an undefined left shift
	      pixman-fast-path: Fix various undefined left shifts
	      pixman-bits-image: Fix various undefined left shifts
	      pixman-bits-image: Fix left shift of a negative number
	      pixman-matrix: Fix left shift of a negative number
	      test: Fix unrepresentable subtraction in stress-test
	      pixman-mmx: Fix undefined left-shifts
	      pixman-mmx: Fix undefined unaligned loads
	      pixman-sse2: Fix undefined unaligned loads
	      fast-path: Fix some sketchy pointer arithmetic

	Antonio Ospite (1):
	      pixman-compiler.h: fix building tests with MinGW

	Basile Clement (6):
	      Fix bilinear filter computation in wide pipeline
	      Implement basic dithering for the wide pipeline, v3
	      test: Check the dithering path in tolerance-test
	      demos: Add a dithering demo
	      Ordered dithering with blue noise, v2
	      Don't use GNU extension for binary numbers

	Christoph Reiter (3):
	      meson: define SIZEOF_LONG  and use -Wundef
	      meson: allow building a static library
	      meson: fix TLS support under mingw

	Chun-wei Fan (11):
	      meson.build: Fix MMX, SSE2 and SSSE3 checks on MSVC
	      meson.build: Disable OpenMP on MSVC builds
	      build: Don't assume PThreads if threading support is found
	      meson.build: Improve libpng search on MSVC
	      pixman/pixman-version.h.in: Add a PIXMAN_API macro
	      pixman/pixman.h: Mark public APIs with PIXMAN_API
	      pixman-[compiler|private].h: Export symbols for tests
	      pixman/meson.build: Define PIXMAN_API on MSVC-style compilers
	      test/solid-test.c: Include stdint.h
	      demos: Define _USE_MATH_DEFINES on MSVC-style compilers
	      thread-test.c: Use Windows Threading API on Windows

	Dylan Baker (1):
	      meson: don't use link_with for library()

	Fan Jinke (1):
	      add Hygon Dhyana support to enable X86_MMX_EXTENSIONS feature

	Federico Mena Quintero (1):
	      Initialize temporary buffers in general_composite_rect()

	Ghabry (1):
	      Enabled armv6 SIMD for 3DS (devkitARM) and arm neon SIMD for PS Vita (vit

	Jonathan Kew (2):
	      Explicitly cast byte to uint32_t before left-shifting.
	      Avoid undefined behavior (left-shifting negative value) in pixman_int_to_

	Khem Raj (1):
	      test/utils: Check for FE_INVALID definition before use

	Mathieu Duponchelle (2):
	      meson: finish porting over mmx and ssse2 flags for sun and msvc
	      meson: add missing function check (getisax)

	Matt Turner (7):
	      Post-release version bump to 0.38.5
	      lowlevel-blt-bench: Remove unused variable
	      loongson: Avoid C90 mixing-code-and-decls warning
	      Distribute the blue-noise files
	      Build xz tarballs instead of bzip2
	      Move from MD5/SHA1 to SHA256/SHA512 digests
	      Pre-release version bump to 0.40.0

	Shiyou Yin (1):
	      configure.ac: use '-mloongson-mmi' for Loongson MMI

	Yin Shiyou (1):
	      pixman-combine: Fix wrong value of RB_MASK_PLUS_ONE.
This commit is contained in:
wiz 2020-04-20 06:40:05 +00:00
parent 6b0824062e
commit 83e7e0467a
4 changed files with 12 additions and 52 deletions

View file

@ -1,10 +1,9 @@
# $NetBSD: Makefile,v 1.74 2020/03/12 19:19:52 tnn Exp $
# $NetBSD: Makefile,v 1.75 2020/04/20 06:40:05 wiz Exp $
DISTNAME= pixman-0.38.4
PKGREVISION= 1
DISTNAME= pixman-0.40.0
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XORG:=lib/}
EXTRACT_SUFX= .tar.bz2
EXTRACT_SUFX= .tar.xz
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://xorg.freedesktop.org/

View file

@ -1,12 +1,11 @@
$NetBSD: distinfo,v 1.63 2020/03/12 19:19:52 tnn Exp $
$NetBSD: distinfo,v 1.64 2020/04/20 06:40:05 wiz Exp $
SHA1 (pixman-0.38.4.tar.bz2) = 87e1abc91ac4e5dfcc275f744f1d0ec3277ee7cd
RMD160 (pixman-0.38.4.tar.bz2) = 106b73f871b5e0f8a739a47788fb9fd7a82cb8c5
SHA512 (pixman-0.38.4.tar.bz2) = 0683b7f67caa0881b23188b7e6f8487c7e0a1257a912686616b7d862efd5a9efdb51641c81ec54905a6f6b1029d796ca4e25c0909db28fc29fa3617bf09f9cf9
Size (pixman-0.38.4.tar.bz2) = 756898 bytes
SHA1 (patch-Makefile.in) = 90ddfa2f96e4b2770f3f6c283267d7fb8a3524fb
SHA1 (pixman-0.40.0.tar.xz) = c625853be8a5369cece57ab7dba558ff739a6332
RMD160 (pixman-0.40.0.tar.xz) = 49f6dedbecfff3747af47716199727818b9ca47f
SHA512 (pixman-0.40.0.tar.xz) = 8a60edb113d68791b41bd90b761ff7b3934260cb3dada3234c9351416f61394e4157353bc4d61b8f6c2c619de470f6feefffb4935bfcf79d291ece6285de7270
Size (pixman-0.40.0.tar.xz) = 634752 bytes
SHA1 (patch-Makefile.in) = e59e216839f69d0c73b40c195b2c5414a10558f4
SHA1 (patch-ba) = 9bd8a7fd0cfbd280df06d69838d3d10ab1b51e23
SHA1 (patch-bb) = d47b1857771b8addb6897d45782ba2735a7aacbd
SHA1 (patch-bc) = 3e23e6c482ea193885f3f762af355ef2f692132b
SHA1 (patch-bd) = 1b1432f4a88d5486afdb4c0cad0808d3748fa522
SHA1 (patch-pixman_pixman-vmx.c) = d96dad41d94bf8dfb956afda00a5a175a9c1f6fc

View file

@ -1,9 +1,9 @@
$NetBSD: patch-Makefile.in,v 1.1 2020/03/12 19:19:52 tnn Exp $
$NetBSD: patch-Makefile.in,v 1.2 2020/04/20 06:40:05 wiz Exp $
Skip building demos and test SUBDIRS
Shell portability
--- Makefile.in.orig 2019-04-10 17:19:26.000000000 +0000
--- Makefile.in.orig 2020-04-19 21:53:21.000000000 +0000
+++ Makefile.in
@@ -381,7 +381,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
@ -15,7 +15,7 @@ Shell portability
pkgconfig_DATA = pixman-1.pc
GPGKEY = 3892336E
@@ -964,7 +964,7 @@ release-remove-old:
$(RM) $(tar_gz) $(tar_bz2) $(HASHFILES) $(gpg_file)
$(RM) $(tar_gz) $(tar_xz) $(HASHFILES) $(gpg_file)
ensure-prev:
- @if [[ "$(PREV)" == "" ]]; then \

View file

@ -1,38 +0,0 @@
$NetBSD: patch-bd,v 1.2 2013/01/30 10:21:22 wiz Exp $
--- pixman/pixman.h.orig 2012-12-10 11:34:13.000000000 +0000
+++ pixman/pixman.h
@@ -856,25 +856,19 @@ void pixman_image_composite32
int32_t width,
int32_t height);
-/* Executive Summary: This function is a no-op that only exists
- * for historical reasons.
- *
- * There used to be a bug in the X server where it would rely on
- * out-of-bounds accesses when it was asked to composite with a
- * window as the source. It would create a pixman image pointing
- * to some bogus position in memory, but then set a clip region
- * to the position where the actual bits were.
+/* Old X servers rely on out-of-bounds accesses when they are asked
+ * to composite with a window as the source. They create a pixman image
+ * pointing to some bogus position in memory, but then they set a clip
+ * region to the position where the actual bits are.
*
* Due to a bug in old versions of pixman, where it would not clip
* against the image bounds when a clip region was set, this would
- * actually work. So when the pixman bug was fixed, a workaround was
- * added to allow certain out-of-bound accesses. This function disabled
- * those workarounds.
+ * actually work. So by default we allow certain out-of-bound access
+ * to happen unless explicitly disabled.
*
- * Since 0.21.2, pixman doesn't do these workarounds anymore, so now this
- * function is a no-op.
+ * Fixed X servers should call this function to disable the workaround.
*/
-void pixman_disable_out_of_bounds_workaround (void);
+void pixman_disable_out_of_bounds_workaround (void);
/*
* Glyphs