Removed textproc/xalan-c

This commit is contained in:
adam 2011-02-23 08:37:41 +00:00
parent 5e3ee5f7da
commit df4582393f
10 changed files with 0 additions and 776 deletions

View file

@ -1,7 +0,0 @@
Xalan (named after a rare musical instrument) fully implements the W3C
Recommendation 16 November 1999 XSL Transformations (XSLT) Version 1.0
and the XML Path Language (XPath) Version 1.0. XSLT is the first part
of the XSL stylesheet language for XML. It includes the XSL Transformation
vocabulary and XPath, a language for addressing parts of XML documents.
This package provide the C++ version of Xalan.

View file

@ -1,51 +0,0 @@
# $NetBSD: Makefile,v 1.29 2010/12/17 07:36:11 obache Exp $
#
DISTNAME= Xalan-C_1_10_0-src
PKGNAME= xalan-c-1.10
PKGREVISION= 3
CATEGORIES= textproc
MASTER_SITES= http://archive.apache.org/dist/xml/xalan-c/source/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://xml.apache.org/xalan-c/
COMMENT= XSLT processor of the Apache Project
PKG_DESTDIR_SUPPORT= user-destdir
MAKE_JOBS_SAFE= no
WRKSRC= ${WRKDIR}/xml-xalan/c
USE_TOOLS+= gmake
USE_LANGUAGES= c c++
.include "../../mk/bsd.prefs.mk"
.if ${LOWER_OPSYS} == "SunOS"
XALAN_PLATFORM= solaris
.elif ${LOWER_OPSYS} == "Darwin"
XALAN_PLATFORM= macosx
.else
XALAN_PLATFORM= ${LOWER_OPSYS}
.endif
XALAN_ENV= XALANCROOT="${WRKDIR}/xml-xalan/c" ICUROOT="${LOCALBASE}"
HAS_CONFIGURE= YES
CONFIGURE_SCRIPT= ./runConfigure
CONFIGURE_ARGS+= -C --prefix=${PREFIX:Q}
CONFIGURE_ARGS+= -p ${XALAN_PLATFORM}
CONFIGURE_ARGS+= -t icu
CONFIGURE_ARGS+= -r pthread
# 1.7.0 needs the following argument.
#CONFIGURE_ARGS+= -m inmem
CONFIGURE_ENV+= ${XALAN_ENV}
MAKE_ENV+= ${XALAN_ENV}
pre-configure:
@${CP} ${PKGSRCDIR}/mk/gnu-config/config.guess ${WRKSRC}
@${CP} ${PKGSRCDIR}/mk/gnu-config/config.sub ${WRKSRC}
.include "../../mk/pthread.buildlink3.mk"
.include "../../textproc/icu/buildlink3.mk"
.include "../../textproc/xerces-c/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,457 +0,0 @@
@comment $NetBSD: PLIST,v 1.4 2009/06/14 18:17:33 joerg Exp $
bin/Xalan
include/xalanc/DOMSupport/DOMServices.hpp
include/xalanc/DOMSupport/DOMSupport.hpp
include/xalanc/DOMSupport/DOMSupportDefault.hpp
include/xalanc/DOMSupport/DOMSupportDefinitions.hpp
include/xalanc/DOMSupport/DOMSupportException.hpp
include/xalanc/DOMSupport/DOMSupportInit.hpp
include/xalanc/DOMSupport/TreeWalker.hpp
include/xalanc/DOMSupport/XalanDocumentPrefixResolver.hpp
include/xalanc/DOMSupport/XalanNamespacesStack.hpp
include/xalanc/Harness/XalanDiagnosticMemoryManager.hpp
include/xalanc/Harness/XalanFileUtility.hpp
include/xalanc/Harness/XalanHarnessDefinitions.hpp
include/xalanc/Harness/XalanXMLFileReporter.hpp
include/xalanc/Include/AIXDefinitions.hpp
include/xalanc/Include/GCCDefinitions.hpp
include/xalanc/Include/HPUXDefinitions.hpp
include/xalanc/Include/IntelDefinitions.hpp
include/xalanc/Include/OS390Definitions.hpp
include/xalanc/Include/OS400Definitions.hpp
include/xalanc/Include/PlatformDefinitions.hpp
include/xalanc/Include/STLHelper.hpp
include/xalanc/Include/SolarisDefinitions.hpp
include/xalanc/Include/TRU64Definitions.hpp
include/xalanc/Include/VCPPDefinitions.hpp
include/xalanc/Include/XalanAutoPtr.hpp
include/xalanc/Include/XalanDeque.hpp
include/xalanc/Include/XalanList.hpp
include/xalanc/Include/XalanMap.hpp
include/xalanc/Include/XalanMemMgrAutoPtr.hpp
include/xalanc/Include/XalanMemMgrHelper.hpp
include/xalanc/Include/XalanMemMngArrayAllocate.hpp
include/xalanc/Include/XalanMemoryManagement.hpp
include/xalanc/Include/XalanObjectCache.hpp
include/xalanc/Include/XalanObjectStackCache.hpp
include/xalanc/Include/XalanSet.hpp
include/xalanc/Include/XalanVector.hpp
include/xalanc/Include/XalanVersion.hpp
include/xalanc/PlatformSupport/ArenaAllocator.hpp
include/xalanc/PlatformSupport/ArenaBlock.hpp
include/xalanc/PlatformSupport/ArenaBlockBase.hpp
include/xalanc/PlatformSupport/AttributeListImpl.hpp
include/xalanc/PlatformSupport/AttributeVectorEntry.hpp
include/xalanc/PlatformSupport/AttributeVectorEntryExtended.hpp
include/xalanc/PlatformSupport/AttributesImpl.hpp
include/xalanc/PlatformSupport/DOMStringHelper.hpp
include/xalanc/PlatformSupport/DOMStringPrintWriter.hpp
include/xalanc/PlatformSupport/DirectoryEnumerator.hpp
include/xalanc/PlatformSupport/DoubleSupport.hpp
include/xalanc/PlatformSupport/ExecutionContext.hpp
include/xalanc/PlatformSupport/FormatterListener.hpp
include/xalanc/PlatformSupport/LocalMsgIndex.hpp
include/xalanc/PlatformSupport/NamedNodeMapAttributeList.hpp
include/xalanc/PlatformSupport/NullPrintWriter.hpp
include/xalanc/PlatformSupport/PlatformSupportDefinitions.hpp
include/xalanc/PlatformSupport/PlatformSupportInit.hpp
include/xalanc/PlatformSupport/PrefixResolver.hpp
include/xalanc/PlatformSupport/PrintWriter.hpp
include/xalanc/PlatformSupport/Resettable.hpp
include/xalanc/PlatformSupport/ReusableArenaAllocator.hpp
include/xalanc/PlatformSupport/ReusableArenaBlock.hpp
include/xalanc/PlatformSupport/StdBinInputStream.hpp
include/xalanc/PlatformSupport/StringTokenizer.hpp
include/xalanc/PlatformSupport/URISupport.hpp
include/xalanc/PlatformSupport/Writer.hpp
include/xalanc/PlatformSupport/XSLException.hpp
include/xalanc/PlatformSupport/XalanAllocator.hpp
include/xalanc/PlatformSupport/XalanArrayAllocator.hpp
include/xalanc/PlatformSupport/XalanBitmap.hpp
include/xalanc/PlatformSupport/XalanCollationServices.hpp
include/xalanc/PlatformSupport/XalanDOMStringAllocator.hpp
include/xalanc/PlatformSupport/XalanDOMStringCache.hpp
include/xalanc/PlatformSupport/XalanDOMStringHashTable.hpp
include/xalanc/PlatformSupport/XalanDOMStringPool.hpp
include/xalanc/PlatformSupport/XalanDOMStringReusableAllocator.hpp
include/xalanc/PlatformSupport/XalanDecimalFormatSymbols.hpp
include/xalanc/PlatformSupport/XalanEncodingPropertyCache.hpp
include/xalanc/PlatformSupport/XalanFStreamOutputStream.hpp
include/xalanc/PlatformSupport/XalanFileOutputStream.hpp
include/xalanc/PlatformSupport/XalanICUMessageLoader.hpp
include/xalanc/PlatformSupport/XalanInMemoryMessageLoader.hpp
include/xalanc/PlatformSupport/XalanLocator.hpp
include/xalanc/PlatformSupport/XalanMemoryManagerDefault.hpp
include/xalanc/PlatformSupport/XalanMessageLoader.hpp
include/xalanc/PlatformSupport/XalanNLSMessageLoader.hpp
include/xalanc/PlatformSupport/XalanNamespace.hpp
include/xalanc/PlatformSupport/XalanNullOutputStream.hpp
include/xalanc/PlatformSupport/XalanNumberFormat.hpp
include/xalanc/PlatformSupport/XalanOutputStream.hpp
include/xalanc/PlatformSupport/XalanOutputStreamPrintWriter.hpp
include/xalanc/PlatformSupport/XalanParsedURI.hpp
include/xalanc/PlatformSupport/XalanReferenceCountedObject.hpp
include/xalanc/PlatformSupport/XalanSimplePrefixResolver.hpp
include/xalanc/PlatformSupport/XalanStdOutputStream.hpp
include/xalanc/PlatformSupport/XalanToXercesTranscoderWrapper.hpp
include/xalanc/PlatformSupport/XalanTranscodingServices.hpp
include/xalanc/PlatformSupport/XalanUTF16Transcoder.hpp
include/xalanc/PlatformSupport/XalanUnicode.hpp
include/xalanc/PlatformSupport/XalanXMLChar.hpp
include/xalanc/XMLSupport/FormatterToDOM.hpp
include/xalanc/XMLSupport/FormatterToHTML.hpp
include/xalanc/XMLSupport/FormatterToNull.hpp
include/xalanc/XMLSupport/FormatterToText.hpp
include/xalanc/XMLSupport/FormatterToXML.hpp
include/xalanc/XMLSupport/FormatterToXMLUnicode.hpp
include/xalanc/XMLSupport/FormatterTreeWalker.hpp
include/xalanc/XMLSupport/XMLParserLiaison.hpp
include/xalanc/XMLSupport/XMLSupportDefinitions.hpp
include/xalanc/XMLSupport/XMLSupportException.hpp
include/xalanc/XMLSupport/XMLSupportInit.hpp
include/xalanc/XMLSupport/XalanDummyIndentWriter.hpp
include/xalanc/XMLSupport/XalanFormatterWriter.hpp
include/xalanc/XMLSupport/XalanHTMLElementsProperties.hpp
include/xalanc/XMLSupport/XalanIndentWriter.hpp
include/xalanc/XMLSupport/XalanOtherEncodingWriter.hpp
include/xalanc/XMLSupport/XalanUTF16Writer.hpp
include/xalanc/XMLSupport/XalanUTF8Writer.hpp
include/xalanc/XMLSupport/XalanXMLSerializerBase.hpp
include/xalanc/XMLSupport/XalanXMLSerializerFactory.hpp
include/xalanc/XPath/ElementPrefixResolverProxy.hpp
include/xalanc/XPath/FormatterStringLengthCounter.hpp
include/xalanc/XPath/Function.hpp
include/xalanc/XPath/FunctionConcat.hpp
include/xalanc/XPath/FunctionContains.hpp
include/xalanc/XPath/FunctionID.hpp
include/xalanc/XPath/FunctionLang.hpp
include/xalanc/XPath/FunctionNamespaceURI.hpp
include/xalanc/XPath/FunctionNormalizeSpace.hpp
include/xalanc/XPath/FunctionStartsWith.hpp
include/xalanc/XPath/FunctionString.hpp
include/xalanc/XPath/FunctionSubstring.hpp
include/xalanc/XPath/FunctionSubstringAfter.hpp
include/xalanc/XPath/FunctionSubstringBefore.hpp
include/xalanc/XPath/FunctionTranslate.hpp
include/xalanc/XPath/MutableNodeRefList.hpp
include/xalanc/XPath/NameSpace.hpp
include/xalanc/XPath/NodeRefList.hpp
include/xalanc/XPath/NodeRefListBase.hpp
include/xalanc/XPath/XBoolean.hpp
include/xalanc/XPath/XNodeSet.hpp
include/xalanc/XPath/XNodeSetAllocator.hpp
include/xalanc/XPath/XNodeSetBase.hpp
include/xalanc/XPath/XNodeSetNodeProxy.hpp
include/xalanc/XPath/XNodeSetNodeProxyAllocator.hpp
include/xalanc/XPath/XNodeSetResultTreeFragProxy.hpp
include/xalanc/XPath/XNull.hpp
include/xalanc/XPath/XNumber.hpp
include/xalanc/XPath/XNumberAllocator.hpp
include/xalanc/XPath/XNumberBase.hpp
include/xalanc/XPath/XObject.hpp
include/xalanc/XPath/XObjectFactory.hpp
include/xalanc/XPath/XObjectFactoryDefault.hpp
include/xalanc/XPath/XObjectResultTreeFragProxy.hpp
include/xalanc/XPath/XObjectResultTreeFragProxyBase.hpp
include/xalanc/XPath/XObjectResultTreeFragProxyText.hpp
include/xalanc/XPath/XObjectTypeCallback.hpp
include/xalanc/XPath/XPath.hpp
include/xalanc/XPath/XPathAllocator.hpp
include/xalanc/XPath/XPathConstructionContext.hpp
include/xalanc/XPath/XPathConstructionContextDefault.hpp
include/xalanc/XPath/XPathDefinitions.hpp
include/xalanc/XPath/XPathEnvSupport.hpp
include/xalanc/XPath/XPathEnvSupportDefault.hpp
include/xalanc/XPath/XPathEvaluator.hpp
include/xalanc/XPath/XPathExecutionContext.hpp
include/xalanc/XPath/XPathExecutionContextDefault.hpp
include/xalanc/XPath/XPathExpression.hpp
include/xalanc/XPath/XPathFactory.hpp
include/xalanc/XPath/XPathFactoryBlock.hpp
include/xalanc/XPath/XPathFactoryDefault.hpp
include/xalanc/XPath/XPathFunctionTable.hpp
include/xalanc/XPath/XPathInit.hpp
include/xalanc/XPath/XPathParserException.hpp
include/xalanc/XPath/XPathProcessor.hpp
include/xalanc/XPath/XPathProcessorImpl.hpp
include/xalanc/XPath/XSpan.hpp
include/xalanc/XPath/XString.hpp
include/xalanc/XPath/XStringAdapter.hpp
include/xalanc/XPath/XStringAdapterAllocator.hpp
include/xalanc/XPath/XStringAllocator.hpp
include/xalanc/XPath/XStringBase.hpp
include/xalanc/XPath/XStringCached.hpp
include/xalanc/XPath/XStringCachedAllocator.hpp
include/xalanc/XPath/XStringReference.hpp
include/xalanc/XPath/XStringReferenceAllocator.hpp
include/xalanc/XPath/XToken.hpp
include/xalanc/XPath/XTokenNumberAdapter.hpp
include/xalanc/XPath/XTokenNumberAdapterAllocator.hpp
include/xalanc/XPath/XTokenStringAdapter.hpp
include/xalanc/XPath/XTokenStringAdapterAllocator.hpp
include/xalanc/XPath/XUnknown.hpp
include/xalanc/XPath/XalanDocumentFragmentNodeRefListBaseProxy.hpp
include/xalanc/XPath/XalanQName.hpp
include/xalanc/XPath/XalanQNameByReference.hpp
include/xalanc/XPath/XalanQNameByValue.hpp
include/xalanc/XPath/XalanQNameByValueAllocator.hpp
include/xalanc/XPath/XalanXPathException.hpp
include/xalanc/XPathCAPI/XPathCAPI.h
include/xalanc/XSLT/AVT.hpp
include/xalanc/XSLT/AVTPart.hpp
include/xalanc/XSLT/AVTPartSimple.hpp
include/xalanc/XSLT/AVTPartXPath.hpp
include/xalanc/XSLT/Constants.hpp
include/xalanc/XSLT/CountersTable.hpp
include/xalanc/XSLT/DecimalToRoman.hpp
include/xalanc/XSLT/ElemApplyImport.hpp
include/xalanc/XSLT/ElemApplyTemplates.hpp
include/xalanc/XSLT/ElemAttribute.hpp
include/xalanc/XSLT/ElemAttributeSet.hpp
include/xalanc/XSLT/ElemCallTemplate.hpp
include/xalanc/XSLT/ElemChoose.hpp
include/xalanc/XSLT/ElemComment.hpp
include/xalanc/XSLT/ElemCopy.hpp
include/xalanc/XSLT/ElemCopyOf.hpp
include/xalanc/XSLT/ElemDecimalFormat.hpp
include/xalanc/XSLT/ElemElement.hpp
include/xalanc/XSLT/ElemEmpty.hpp
include/xalanc/XSLT/ElemExtensionCall.hpp
include/xalanc/XSLT/ElemFallback.hpp
include/xalanc/XSLT/ElemForEach.hpp
include/xalanc/XSLT/ElemForwardCompatible.hpp
include/xalanc/XSLT/ElemIf.hpp
include/xalanc/XSLT/ElemLiteralResult.hpp
include/xalanc/XSLT/ElemMessage.hpp
include/xalanc/XSLT/ElemNumber.hpp
include/xalanc/XSLT/ElemOtherwise.hpp
include/xalanc/XSLT/ElemPI.hpp
include/xalanc/XSLT/ElemParam.hpp
include/xalanc/XSLT/ElemSort.hpp
include/xalanc/XSLT/ElemTemplate.hpp
include/xalanc/XSLT/ElemTemplateElement.hpp
include/xalanc/XSLT/ElemText.hpp
include/xalanc/XSLT/ElemTextLiteral.hpp
include/xalanc/XSLT/ElemUse.hpp
include/xalanc/XSLT/ElemValueOf.hpp
include/xalanc/XSLT/ElemVariable.hpp
include/xalanc/XSLT/ElemWhen.hpp
include/xalanc/XSLT/ElemWithParam.hpp
include/xalanc/XSLT/ExtensionFunctionHandler.hpp
include/xalanc/XSLT/ExtensionNSHandler.hpp
include/xalanc/XSLT/FunctionCurrent.hpp
include/xalanc/XSLT/FunctionDocument.hpp
include/xalanc/XSLT/FunctionElementAvailable.hpp
include/xalanc/XSLT/FunctionFormatNumber.hpp
include/xalanc/XSLT/FunctionFunctionAvailable.hpp
include/xalanc/XSLT/FunctionGenerateID.hpp
include/xalanc/XSLT/FunctionKey.hpp
include/xalanc/XSLT/FunctionSystemProperty.hpp
include/xalanc/XSLT/FunctionUnparsedEntityURI.hpp
include/xalanc/XSLT/GenerateEvent.hpp
include/xalanc/XSLT/KeyDeclaration.hpp
include/xalanc/XSLT/KeyTable.hpp
include/xalanc/XSLT/NamespacesHandler.hpp
include/xalanc/XSLT/NodeSortKey.hpp
include/xalanc/XSLT/NodeSorter.hpp
include/xalanc/XSLT/OutputContextStack.hpp
include/xalanc/XSLT/ProblemListener.hpp
include/xalanc/XSLT/ProblemListenerDefault.hpp
include/xalanc/XSLT/ResultNamespacesStack.hpp
include/xalanc/XSLT/SelectionEvent.hpp
include/xalanc/XSLT/Stylesheet.hpp
include/xalanc/XSLT/StylesheetConstructionContext.hpp
include/xalanc/XSLT/StylesheetConstructionContextDefault.hpp
include/xalanc/XSLT/StylesheetExecutionContext.hpp
include/xalanc/XSLT/StylesheetExecutionContextDefault.hpp
include/xalanc/XSLT/StylesheetHandler.hpp
include/xalanc/XSLT/StylesheetRoot.hpp
include/xalanc/XSLT/TopLevelArg.hpp
include/xalanc/XSLT/TraceListener.hpp
include/xalanc/XSLT/TraceListenerDefault.hpp
include/xalanc/XSLT/TracerEvent.hpp
include/xalanc/XSLT/VariablesStack.hpp
include/xalanc/XSLT/XResultTreeFrag.hpp
include/xalanc/XSLT/XResultTreeFragAllocator.hpp
include/xalanc/XSLT/XSLTDefinitions.hpp
include/xalanc/XSLT/XSLTEngineImpl.hpp
include/xalanc/XSLT/XSLTInit.hpp
include/xalanc/XSLT/XSLTInputSource.hpp
include/xalanc/XSLT/XSLTProcessor.hpp
include/xalanc/XSLT/XSLTProcessorEnvSupport.hpp
include/xalanc/XSLT/XSLTProcessorEnvSupportDefault.hpp
include/xalanc/XSLT/XSLTProcessorException.hpp
include/xalanc/XSLT/XSLTResultTarget.hpp
include/xalanc/XSLT/XalanAVTAllocator.hpp
include/xalanc/XSLT/XalanAVTPartSimpleAllocator.hpp
include/xalanc/XSLT/XalanAVTPartXPathAllocator.hpp
include/xalanc/XSLT/XalanElemApplyTemplatesAllocator.hpp
include/xalanc/XSLT/XalanElemAttributeAllocator.hpp
include/xalanc/XSLT/XalanElemAttributeSetAllocator.hpp
include/xalanc/XSLT/XalanElemCallTemplateAllocator.hpp
include/xalanc/XSLT/XalanElemElementAllocator.hpp
include/xalanc/XSLT/XalanElemEmptyAllocator.hpp
include/xalanc/XSLT/XalanElemLiteralResultAllocator.hpp
include/xalanc/XSLT/XalanElemTemplateAllocator.hpp
include/xalanc/XSLT/XalanElemTextAllocator.hpp
include/xalanc/XSLT/XalanElemTextLiteralAllocator.hpp
include/xalanc/XSLT/XalanElemValueOfAllocator.hpp
include/xalanc/XSLT/XalanElemVariableAllocator.hpp
include/xalanc/XSLT/XalanMatchPatternData.hpp
include/xalanc/XSLT/XalanMatchPatternDataAllocator.hpp
include/xalanc/XSLT/XalanNumberingResourceBundle.hpp
include/xalanc/XSLT/XalanSourceTreeDocumentAllocator.hpp
include/xalanc/XSLT/XalanSourceTreeDocumentFragmentAllocator.hpp
include/xalanc/XSLT/XalanSpaceNodeTester.hpp
include/xalanc/XalanDOM/XalanAttr.hpp
include/xalanc/XalanDOM/XalanCDATASection.hpp
include/xalanc/XalanDOM/XalanCharacterData.hpp
include/xalanc/XalanDOM/XalanComment.hpp
include/xalanc/XalanDOM/XalanDOMDefinitions.hpp
include/xalanc/XalanDOM/XalanDOMException.hpp
include/xalanc/XalanDOM/XalanDOMImplementation.hpp
include/xalanc/XalanDOM/XalanDOMInit.hpp
include/xalanc/XalanDOM/XalanDOMString.hpp
include/xalanc/XalanDOM/XalanDocument.hpp
include/xalanc/XalanDOM/XalanDocumentFragment.hpp
include/xalanc/XalanDOM/XalanDocumentType.hpp
include/xalanc/XalanDOM/XalanElement.hpp
include/xalanc/XalanDOM/XalanEmptyNamedNodeMap.hpp
include/xalanc/XalanDOM/XalanEntity.hpp
include/xalanc/XalanDOM/XalanEntityReference.hpp
include/xalanc/XalanDOM/XalanNamedNodeMap.hpp
include/xalanc/XalanDOM/XalanNode.hpp
include/xalanc/XalanDOM/XalanNodeList.hpp
include/xalanc/XalanDOM/XalanNodeListDummy.hpp
include/xalanc/XalanDOM/XalanNodeListSurrogate.hpp
include/xalanc/XalanDOM/XalanNotation.hpp
include/xalanc/XalanDOM/XalanProcessingInstruction.hpp
include/xalanc/XalanDOM/XalanText.hpp
include/xalanc/XalanEXSLT/XalanEXSLTCommon.hpp
include/xalanc/XalanEXSLT/XalanEXSLTCommonImpl.hpp
include/xalanc/XalanEXSLT/XalanEXSLTDateTime.hpp
include/xalanc/XalanEXSLT/XalanEXSLTDateTimeImpl.hpp
include/xalanc/XalanEXSLT/XalanEXSLTDefinitions.hpp
include/xalanc/XalanEXSLT/XalanEXSLTDynamic.hpp
include/xalanc/XalanEXSLT/XalanEXSLTDynamicImpl.hpp
include/xalanc/XalanEXSLT/XalanEXSLTMath.hpp
include/xalanc/XalanEXSLT/XalanEXSLTMathImpl.hpp
include/xalanc/XalanEXSLT/XalanEXSLTSet.hpp
include/xalanc/XalanEXSLT/XalanEXSLTSetImpl.hpp
include/xalanc/XalanEXSLT/XalanEXSLTString.hpp
include/xalanc/XalanEXSLT/XalanEXSLTStringImpl.hpp
include/xalanc/XalanExtensions/FunctionDifference.hpp
include/xalanc/XalanExtensions/FunctionDistinct.hpp
include/xalanc/XalanExtensions/FunctionEvaluate.hpp
include/xalanc/XalanExtensions/FunctionHasSameNodes.hpp
include/xalanc/XalanExtensions/FunctionIntersection.hpp
include/xalanc/XalanExtensions/FunctionNodeSet.hpp
include/xalanc/XalanExtensions/XalanExtensions.hpp
include/xalanc/XalanExtensions/XalanExtensionsDefinitions.hpp
include/xalanc/XalanSourceTree/FormatterToSourceTree.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeAttr.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeAttrNS.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeAttributeAllocator.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeAttributeNSAllocator.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeComment.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeCommentAllocator.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeContentHandler.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeDOMSupport.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeDefinitions.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeDocument.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeDocumentFragment.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeElement.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeElementA.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeElementAAllocator.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeElementANS.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeElementANSAllocator.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeElementNA.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeElementNAAllocator.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeElementNANS.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeElementNANSAllocator.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeHelper.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeInit.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeParserLiaison.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeProcessingInstruction.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeProcessingInstructionAllocator.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeText.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeTextAllocator.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeTextIWS.hpp
include/xalanc/XalanSourceTree/XalanSourceTreeTextIWSAllocator.hpp
include/xalanc/XalanTransformer/XalanCAPI.h
include/xalanc/XalanTransformer/XalanCompiledStylesheet.hpp
include/xalanc/XalanTransformer/XalanCompiledStylesheetDefault.hpp
include/xalanc/XalanTransformer/XalanDefaultDocumentBuilder.hpp
include/xalanc/XalanTransformer/XalanDefaultParsedSource.hpp
include/xalanc/XalanTransformer/XalanDocumentBuilder.hpp
include/xalanc/XalanTransformer/XalanParsedSource.hpp
include/xalanc/XalanTransformer/XalanSourceTreeWrapperParsedSource.hpp
include/xalanc/XalanTransformer/XalanTransformer.hpp
include/xalanc/XalanTransformer/XalanTransformerDefinitions.hpp
include/xalanc/XalanTransformer/XalanTransformerOutputStream.hpp
include/xalanc/XalanTransformer/XalanTransformerProblemListener.hpp
include/xalanc/XalanTransformer/XercesDOMParsedSource.hpp
include/xalanc/XalanTransformer/XercesDOMWrapperParsedSource.hpp
include/xalanc/XercesParserLiaison/Deprecated/FormatterToDeprecatedXercesDOM.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesAttrBridge.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesAttributeBridgeAllocator.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesBridgeHelper.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesBridgeNavigator.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesBridgeTypes.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesCDATASectionBridge.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesCommentBridge.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesDOMImplementationBridge.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesDOM_NodeHack.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesDocumentBridge.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesDocumentFragmentBridge.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesDocumentTypeBridge.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesElementBridge.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesElementBridgeAllocator.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesEntityBridge.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesEntityReferenceBridge.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesNamedNodeMapBridge.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesNodeListBridge.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesNotationBridge.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesProcessingInstructionBridge.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesTextBridge.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesTextBridgeAllocator.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesToXalanNodeMap.hpp
include/xalanc/XercesParserLiaison/Deprecated/XercesTreeWalker.hpp
include/xalanc/XercesParserLiaison/FormatterToXercesDOM.hpp
include/xalanc/XercesParserLiaison/XercesAttrWrapper.hpp
include/xalanc/XercesParserLiaison/XercesAttrWrapperAllocator.hpp
include/xalanc/XercesParserLiaison/XercesCDATASectionWrapper.hpp
include/xalanc/XercesParserLiaison/XercesCommentWrapper.hpp
include/xalanc/XercesParserLiaison/XercesDOMException.hpp
include/xalanc/XercesParserLiaison/XercesDOMFormatterWalker.hpp
include/xalanc/XercesParserLiaison/XercesDOMImplementationWrapper.hpp
include/xalanc/XercesParserLiaison/XercesDOMSupport.hpp
include/xalanc/XercesParserLiaison/XercesDOMWalker.hpp
include/xalanc/XercesParserLiaison/XercesDOMWrapperException.hpp
include/xalanc/XercesParserLiaison/XercesDocumentTypeWrapper.hpp
include/xalanc/XercesParserLiaison/XercesDocumentWrapper.hpp
include/xalanc/XercesParserLiaison/XercesElementWrapper.hpp
include/xalanc/XercesParserLiaison/XercesElementWrapperAllocator.hpp
include/xalanc/XercesParserLiaison/XercesEntityReferenceWrapper.hpp
include/xalanc/XercesParserLiaison/XercesEntityWrapper.hpp
include/xalanc/XercesParserLiaison/XercesLiaisonXalanDOMStringPool.hpp
include/xalanc/XercesParserLiaison/XercesNamedNodeMapAttributeList.hpp
include/xalanc/XercesParserLiaison/XercesNamedNodeMapWrapper.hpp
include/xalanc/XercesParserLiaison/XercesNodeListWrapper.hpp
include/xalanc/XercesParserLiaison/XercesNotationWrapper.hpp
include/xalanc/XercesParserLiaison/XercesParserLiaison.hpp
include/xalanc/XercesParserLiaison/XercesParserLiaisonDefinitions.hpp
include/xalanc/XercesParserLiaison/XercesProcessingInstructionWrapper.hpp
include/xalanc/XercesParserLiaison/XercesTextWrapper.hpp
include/xalanc/XercesParserLiaison/XercesTextWrapperAllocator.hpp
include/xalanc/XercesParserLiaison/XercesWrapperHelper.hpp
include/xalanc/XercesParserLiaison/XercesWrapperNavigator.hpp
include/xalanc/XercesParserLiaison/XercesWrapperNavigatorAllocator.hpp
include/xalanc/XercesParserLiaison/XercesWrapperToXalanNodeMap.hpp
include/xalanc/XercesParserLiaison/XercesWrapperTypes.hpp
lib/libxalan-c.so
lib/libxalan-c.so.110
lib/libxalan-c.so.110.0
lib/libxalanMsg.so
lib/libxalanMsg.so.110
lib/libxalanMsg.so.110.0

View file

@ -1,16 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.13 2010/12/17 07:36:11 obache Exp $
BUILDLINK_TREE+= xalan-c
.if !defined(XALAN_C_BUILDLINK3_MK)
XALAN_C_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.xalan-c+= xalan-c>=1.6nb3
BUILDLINK_ABI_DEPENDS.xalan-c?= xalan-c>=1.10nb3
BUILDLINK_PKGSRCDIR.xalan-c?= ../../textproc/xalan-c
.include "../../textproc/icu/buildlink3.mk"
.include "../../textproc/xerces-c/buildlink3.mk"
.endif # XALAN_C_BUILDLINK3_MK
BUILDLINK_TREE+= -xalan-c

View file

@ -1,9 +0,0 @@
$NetBSD: distinfo,v 1.8 2009/05/08 12:30:47 hasso Exp $
SHA1 (Xalan-C_1_10_0-src.tar.gz) = 3fc63045048176e0ab00ce8aa0d15b2c1e5d646b
RMD160 (Xalan-C_1_10_0-src.tar.gz) = 537ba0be6a14e47eb4453c2d813b31ec416835ab
Size (Xalan-C_1_10_0-src.tar.gz) = 1554940 bytes
SHA1 (patch-aa) = f3cbda9268269c83b643e5d52f183948cfc45a99
SHA1 (patch-ab) = e67667ba44e8f5cc9beb45a459f52ae1f3a5be59
SHA1 (patch-ac) = 409cd366453b50d25c79def05c48ab45d2f77dd5
SHA1 (patch-ad) = 9e892cf4dfacadd40b7dda2fcc94f65a785d92ff

View file

@ -1,105 +0,0 @@
.\" $NetBSD: testXSLT.1,v 1.2 2001/12/03 19:03:24 wiz Exp $
.Dd November 23, 2000
.Dt TESTXSLT 1
.Os
.Sh NAME
.Nm testXSLT
.Nd Command line tool for XSL transformations
.Sh SYNOPSIS
.Nm
.Fl in Ar xml_file
.Fl xsl Ar xsl_stylesheet
.Fl out Ar output_file
.Op Fl validate
.Op Fl dom
.Op Fl xml | Fl text | Fl html
.Sh DESCRIPTION
.Nm
is the command line tool for the Xalan XSLT engine.
It is used to make a transformation described in an XSL stylesheet on an
XML file. The output file can be either plain text, HTML, or it can be
just another XML file.
.Sh OPTIONS
.Bl -tag -width indent
.It Fl in Ar xml_file
Uses
.Ar xml_file
as the URl for the input file.
.It Fl xsl Ar xsl_stylesheet
Uses
.Ar xsl_stylesheet
as the URL for the XSL stylesheet.
.It Fl out Ar output_file
write output to
.Ar output_file .
.It Fl escape Ar chars
esape characters
.Ar chars ,
the default is <>&"'\en\er.
.It Fl eer
Expands entity references. Default is to not expand.
.It Fl v
Show version info.
.It Fl qc
Quiet Pattern Conflicts Warnings
.It Fl q
Quiet mode.
.It Fl indent Ar space_number
Uses
.Ar space_number
as the number of spaces to indent each level in output tree. Default is 0.
.It Fl validate
Validate XML and XSL input. Default is to not validate.
.It Fl tt
Traces the templates as they are being called.
.It Fl tg
Traces each result tree generation event.
.It Fl ts
Traces each selection event.
.It Fl ttc
Traces the template children as they are being processed.
.It Fl xml
Uses XML formatter and add XML headers.
.It Fl text
Uses plain text formatter.
.It Fl html
Uses HTML formatter
.It Fl nh
Suppress XML headers. Require
.Fl xml .
.It Fl stripcdata
Strip CDATA sections of their brackets, but do not escape. Require
.Fl xml
or
.Fl html .
.It Fl escapedata
Strip CDATA sections of their brackets, and escape. Require
.Fl xml
or
.Fl html .
.It Fl dom
Test for well-formed output --format to DOM then to XML for output.
.It Fl param Ar name Ar expr
Sets the stylesheet parameter
.Ar param
to
.Ar expr .
.El
.Sh EXAMPLES
.Bd -litteral -offset indent
.Nm
-in input.xml -xsl stylesheet.xsl -out output.html -html
.Ed
.Pp
Format
.Ar input.xml
to
.Ar output.html
using the stylesheet file
.Ar stylesheet.xsl ,
and using the HTML formatter.
.Sh AUTHORS
.An The Apache Xalan-C project Aq http://xml.apache.org
.br
This man page by
.An Emmanuel Dreyfus Aq p99dreyf@criens.u-psud.fr .

View file

@ -1,40 +0,0 @@
$NetBSD: patch-aa,v 1.5 2009/05/08 12:30:47 hasso Exp $
--- runConfigure.orig 2009-05-08 14:32:39 +0300
+++ runConfigure 2009-05-08 14:33:38 +0300
@@ -150,7 +150,7 @@ usage()
echo "runConfigure: Helper script to run \"configure\" for one of the supported platforms"
echo "Usage: runConfigure \"options\""
echo " where options may be any of the following:"
- echo " -p <platform> (accepts 'aix', 'linux', 'freebsd', 'netbsd', 'solaris',
+ echo " -p <platform> (accepts 'aix', 'linux', 'freebsd', 'dragonfly', 'netbsd', 'solaris',
'hp-10', 'hp-11', 'hp-11-ia64', 'irix', 'tru64', 'macosx', 'os390', 'os400', 'cygwin')"
echo " -c <C compiler name> (e.g. gcc, cc, xlc)"
echo " -x <C++ compiler name> (e.g. g++, CC, xlC)"
@@ -338,7 +338,7 @@ echo "Extra configure options: $configur
#
case $platform in
- aix | linux | freebsd | netbsd | solaris | hp-11 | hp-11-ia64 | irix | tru64 | macosx | os390 | os400 | cygwin)
+ aix | linux | freebsd | dragonfly | netbsd | solaris | hp-11 | hp-11-ia64 | irix | tru64 | macosx | os390 | os400 | cygwin)
# platform has been recognized
;;
*)
@@ -379,7 +379,7 @@ fi
#
# aix | linux | hp-11 | hp-11-ia64 | solaris |
-# freebsd | netbsd | irix | openserver | unixware | os390 | os400 | ptx | tru64 | macosx
+# freebsd | dragonfly | netbsd | irix | openserver | unixware | os390 | os400 | ptx | tru64 | macosx
#
if test $bitsToBuild = 64; then
bitstobuildDefines=" -DXML_BITSTOBUILD_64 "
@@ -527,6 +527,8 @@ elif test $platform = "freebsd"; then
threadingLibs="-lpthread"
threadingDefines=""
fi
+elif test $platform = "dragonfly"; then
+ threadingLibs="-lpthread"
elif test $platform = "netbsd"; then
threadingLibs="-pthread -lpthread"
elif test $platform = "os400"; then

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ab,v 1.4 2006/01/05 20:43:20 joerg Exp $
--- configure.orig 2005-12-31 00:57:54.000000000 +0000
+++ configure
@@ -1121,6 +1121,7 @@ case "${host}" in
*-*-solaris*) platform=SOLARIS ;;
*-*-linux*) platform=LINUX ;;
*-*-freebsd*) platform=FREEBSD ;;
+ *-*-dragonfly*) platform=DRAGONFLY ;;
*-*-netbsd*) platform=NETBSD ;;
*-*-irix*) platform=IRIX ;;
*-*-aix*) platform=AIX ;;

View file

@ -1,40 +0,0 @@
$NetBSD: patch-ac,v 1.5 2009/05/08 12:30:47 hasso Exp $
--- samples/runConfigure.orig 2009-05-08 14:24:05 +0300
+++ samples/runConfigure 2009-05-08 14:26:54 +0300
@@ -35,7 +35,7 @@ usage()
echo "Usage: runConfigure \"options\""
echo " where options may be any of the following:"
echo " -p <platform> (accepts 'aix', 'linux', 'freebsd', 'netbsd', 'solaris',
- 'hp-10', 'hp-11', 'irix', 'tru64', 'macosx')"
+ 'hp-10', 'hp-11', 'irix', 'tru64', 'macosx', 'dragonfly')"
echo " -c <C compiler name> (e.g. gcc, cc, xlc)"
echo " -x <C++ compiler name> (e.g. g++, CC, xlC)"
echo " -d (specifies that you want to build debug version)"
@@ -156,7 +156,7 @@ echo "Extra configure options: $configur
#
case $platform in
- aix | linux | freebsd | netbsd | solaris | hp-10 | hp-11 | irix | tru64 | macosx)
+ aix | linux | freebsd | netbsd | solaris | hp-10 | hp-11 | irix | tru64 | macosx | dragonfly)
# platform has been recognized
;;
*)
@@ -193,7 +193,7 @@ fi
#
# aix | linux | hp-11 | solaris |
-# hp-10 | freebsd | netbsd | irix | openserver | unixware | os400 | ptx | tru64 | macosx
+# hp-10 | freebsd | netbsd | irix | openserver | unixware | os400 | ptx | tru64 | macosx | dragonfly
#
if test $bitsToBuild = 64; then
bitstobuildDefines=" -DXML_BITSTOBUILD_64 "
@@ -304,6 +304,8 @@ elif test $platform = "netbsd"; then
elif test $platform = "hp-10"; then
threadingLibs="-lcma"
threadingDefines="-DXML_USE_DCE"
+elif test $platform = "dragonfly"; then
+ threadingLibs="-lpthread"
fi

View file

@ -1,39 +0,0 @@
$NetBSD: patch-ad,v 1.5 2009/05/08 12:30:47 hasso Exp $
--- Makefile.incl.in.orig 2009-05-08 14:46:22 +0300
+++ Makefile.incl.in 2009-05-08 14:46:58 +0300
@@ -263,6 +263,34 @@ ifeq ($(PLATFORM), FREEBSD)
endif
+#=============== DRAGONFLY SPECIFIC OPTIONS ======================
+
+ifeq ($(PLATFORM), DRAGONFLY)
+
+ SUPPORTED = TRUE
+ ALLLIBS = ${LIBS} -L/usr/local/lib
+ SHLIBSUFFIX=.so
+ PIC_OPTION = -fPIC
+
+ PLATFORM_COMPILE_OPTIONS = -D${PLATFORM} ${PIC_OPTION} ${WCSTOMBS}
+
+ # We need the ICU library if we are using the ICUBridge
+ ifdef XALAN_USE_ICU
+ LD_RPATH_PRE = -Wl,-rpath,
+ PLATFORM_LIB_LINK_OPTIONS = $(LD_RPATH_PRE)${ICUROOT}/lib
+ PLATFORM_LIB_LINK_OPTIONS += -licuuc -licudata -lgcc
+ ALLLIBS += -L${ICUROOT}
+ endif
+
+ CC1 = $(CXX) $(CXXFLAGS) $(PLATFORM_COMPILE_OPTIONS)
+ CC4 = $(CC) $(CFLAGS) $(PLATFORM_COMPILE_OPTIONS)
+ MAKE_SHARED = $(CXX) $(CXXFLAGS) -D${PLATFORM} -shared ${PIC_OPTION} ${LDFLAGS}
+ LINK = $(CXX) -D${PLATFORM} ${PIC_OPTION} ${LDFLAGS}
+
+ MAKE_SHARED_LOC=$(MAKE_SHARED)
+
+endif
+
#=============== NETBSD SPECIFIC OPTIONS ======================
ifeq ($(PLATFORM), NETBSD)