fuse-pod: remove

Dead upstream since 2007, does not build, unused in pkgsrc.
This commit is contained in:
wiz 2024-02-01 09:34:33 +00:00
parent e205d7a585
commit ec1e3e5c09
9 changed files with 3 additions and 95 deletions

View File

@ -1,4 +1,4 @@
$NetBSD: CHANGES-2024,v 1.812 2024/02/01 09:29:26 wiz Exp $
$NetBSD: CHANGES-2024,v 1.813 2024/02/01 09:34:33 wiz Exp $
Changes to the packages collection and infrastructure in 2024:
@ -1075,3 +1075,4 @@ Changes to the packages collection and infrastructure in 2024:
Removed audio/py-libmtag [wiz 2024-02-01]
Updated graphics/pngcrush to 1.8.13nb1 [wiz 2024-02-01]
Updated sysutils/recoll to 1.37.2 [wiz 2024-02-01]
Removed filesystems/fuse-pod [wiz 2024-02-01]

View File

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.57 2023/03/12 11:55:59 js Exp $
# $NetBSD: Makefile,v 1.58 2024/02/01 09:34:33 wiz Exp $
#
COMMENT= File systems, and file system related packages
@ -27,7 +27,6 @@ SUBDIR+= fuse-mp3fs
SUBDIR+= fuse-ntfs-3g
SUBDIR+= fuse-obexfs
SUBDIR+= fuse-pcachefs
SUBDIR+= fuse-pod
SUBDIR+= fuse-sparsebundlefs
SUBDIR+= fuse-sshfs
SUBDIR+= fuse-svnfs

View File

@ -1,13 +0,0 @@
FUSEPod is a userspace filesystem which mounts your iPod into a directory
for easy browsing of your songs on your iPod.
Features
========
* Read and Write support
* Viewing/Removing playlists
* Configurable directory layout
* Transparent copying of files onto iPod
* Tracks have tags in extended attributes
* Discovers where your iPod is mounted
* Statistics file

View File

@ -1,24 +0,0 @@
# $NetBSD: Makefile,v 1.55 2024/01/28 13:24:35 wiz Exp $
#
DISTNAME= fusepod-0.5.1
PKGNAME= fuse-pod-0.5.1
PKGREVISION= 49
CATEGORIES= filesystems
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=fusepod/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://fusepod.sourceforge.net/
COMMENT= FUSE-based filesystem for iPod
LICENSE= gnu-gpl-v2
GNU_CONFIGURE= yes
USE_LANGUAGES+= c c++03
USE_TOOLS+= gmake pkg-config
.include "../../audio/libgpod/buildlink3.mk"
.include "../../audio/taglib/buildlink3.mk"
.include "../../mk/fuse.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,3 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2007/05/04 23:48:33 agc Exp $
bin/fusepod
man/man1/fusepod.1

View File

@ -1,8 +0,0 @@
$NetBSD: distinfo,v 1.6 2022/01/22 18:45:13 pho Exp $
BLAKE2s (fusepod-0.5.1.tar.bz2) = 761fcac8d17829efc153b43e1b38337a346c3f48e0219a0a00f6870bf65ffcf6
SHA512 (fusepod-0.5.1.tar.bz2) = 3a4d526bdd2cd7f2cc28458898399fc2c50aca989a19d2bc2d9921eaf841195eaa0f9f6a86ac5ebccc8ab56117464a64081e510afef1456817297eebcd7465f8
Size (fusepod-0.5.1.tar.bz2) = 78547 bytes
SHA1 (patch-aa) = a2897d44503c6018c7aec02773a0aeee307197ea
SHA1 (patch-ab) = 923f7f7449c85d2ea537845b779aebec6aede1e8
SHA1 (patch-src_fusepod__util.h) = 71485be8dfdecc1f2be61d1c5c08ac9d3447c0c5

View File

@ -1,19 +0,0 @@
$NetBSD: patch-aa,v 1.2 2022/01/22 18:45:13 pho Exp $
NetBSD librefuse used to have a wrong prototype for init() in FUSE 2.5
API. Already fixed in HEAD.
--- src/fusepod.cpp.orig 2006-08-07 14:39:18.000000000 +0000
+++ src/fusepod.cpp
@@ -672,7 +672,11 @@ static vector<string> get_string_desc ()
return paths;
}
+#if defined(__NetBSD__) && FUSE_H_ < 20211204
+void * fusepod_init (fuse_conn_info *connection) {
+#else
void * fusepod_init () {
+#endif
syncing = false;
syncing_file = "";

View File

@ -1,13 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2007/05/04 23:48:33 agc Exp $
--- src/fusepod_ipod.cpp 2007/05/04 23:28:59 1.1
+++ src/fusepod_ipod.cpp 2007/05/04 23:30:15
@@ -417,7 +417,7 @@
stats << "FUSEPod Version: " << PACKAGE_VERSION << endl;
stats << "ITunesDB Version: " << this->ipod->version << endl;
- stats << "Real Mountpoint: " << this->ipod->mountpoint << endl;
+ stats << "Real Mountpoint: " << this->mount_point << endl;
Playlist * mpl = itdb_playlist_mpl (ipod);
stats << "iPod Name: " << (mpl && mpl->name ? string(mpl->name) : "Unknown") << endl;

View File

@ -1,12 +0,0 @@
$NetBSD: patch-src_fusepod__util.h,v 1.1 2011/11/24 14:10:37 joerg Exp $
--- src/fusepod_util.h.orig 2011-11-24 00:19:43.000000000 +0000
+++ src/fusepod_util.h
@@ -17,6 +17,7 @@
#include <vector>
#include <string>
+#include <strings.h>
using std::string;
using std::vector;