Add const-poisoning in external interface, to allow OpenPTC to compile.

Bump NetBSD revision level of the package accordingly.
This commit is contained in:
agc 2002-07-16 14:48:03 +00:00
parent c75fe1231c
commit fce7a6d9eb
4 changed files with 33 additions and 3 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.8 2001/06/30 11:09:50 zuntum Exp $
# $NetBSD: Makefile,v 1.9 2002/07/16 14:48:03 agc Exp $
DISTNAME= Hermes-1.3.2
WRKSRC= ${WRKDIR}/Hermes-1.3.2
PKGREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://dark.x.dtu.dk/~mbn/clanlib/download/
@ -9,6 +9,8 @@ MAINTAINER= root@garbled.net
HOMEPAGE= http://www.clanlib.org/hermes/
COMMENT= Library for conversion of pixel graphics
WRKSRC= ${WRKDIR}/Hermes-1.3.2
USE_BUILDLINK_ONLY= YES
USE_LIBTOOL= yes
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.2 2001/04/21 09:54:16 wiz Exp $
$NetBSD: distinfo,v 1.3 2002/07/16 14:48:03 agc Exp $
SHA1 (Hermes-1.3.2.tar.gz) = d1a0edd8814ac3e9e699fd33843e60879d285083
Size (Hermes-1.3.2.tar.gz) = 258439 bytes
SHA1 (patch-aa) = 459804a7fe816c4b2d37bc0461d923352f99c129
SHA1 (patch-ac) = 680c52e97a7645a38245c7351fc79119828f97a9
SHA1 (patch-ad) = 480f7ef8dd9ec2ebb7b273328be163ae152d8226
SHA1 (patch-ae) = b45652212ece5a7c70f86717ed81ba9993e03e9a

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1 2002/07/16 14:48:04 agc Exp $
--- src/H_Pal.h 2002/07/16 14:39:53 1.1
+++ src/H_Pal.h 2002/07/16 14:40:15
@@ -31,7 +31,7 @@
Copy the contents of the palette parameter provided into the internal
palette. The user palette has to be 256*4 bytes long.
*/
-HERMES_C void HERMES_API Hermes_PaletteSet(HermesHandle handle,int32 *palette);
+HERMES_C void HERMES_API Hermes_PaletteSet(HermesHandle handle, const int32 *palette);
/*

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.1 2002/07/16 14:48:04 agc Exp $
--- src/Palette.c 2002/07/16 14:40:39 1.1
+++ src/Palette.c 2002/07/16 14:41:06
@@ -122,7 +122,7 @@
-void HERMES_API Hermes_PaletteSet(HermesHandle handle,int32 *palette)
+void HERMES_API Hermes_PaletteSet(HermesHandle handle,const int32 *palette)
{ HermesListElement *element=Hermes_ListLookup(PaletteList,handle);
HermesPalette *pal;