19b8053d03
patches which were applied upstream or deprecated. USE_TOOLS+=groff to fix generation of a few .html files on OpenBSD. Depends on libgcrypt instead of openssl now. From ChangeLog: from 2.4.12 to 2.4.13 - adding initialization value for two variables to avoid inappropriate warning when compiling with -Wall option - reducing UNIX_PATH_MAX by the system when not defined from 108 to 104 bytes to accommodate BSD systems - fixing assignment operator of class criterium that was not returning any value as it should - removing useless boolean expression that always succeeds in logical AND expression - adding support for back-slash of quoting characters in DCF files - fixed compilation issues with clang / FreeBSD, Thanks to Neil Darlow's server ;-) - fixed compilation warning due to deprecated symbols in libgcrypt header files - replaced gnu make specific rules by legacy ones to avoid automake warning about them - removed old unused stuff from misc sub-directory - adding warning at compilation time if libgcrypt used is older than 1.6.0 - adding warning at execution time if hash computation is requested with slices greater than 256 Gio and ligbcrypt dynamically or statically linked is older than 1.6.0 - adding alternative methods in list_entry API class to return dates as number of seconds - fixed bug in hour-shift (-H option) when comparing dates from an old extracted catalogue (archive format 7 or older). - fixed documentation bug about the meaning of the compression ratio - fixed a display bug about the "compression flag" wrongly displayed for uncompressed files - fixed unhandled exception when giving non number argument to -1 option from 2.4.11 to 2.4.12 - for correctness fixed delete vs delete[] on vector of char (not incidence reported) - fixed out of range access in routine used to read very old archive format - fixed error in logical expression leading a sanity test to be useless - removed duplicated variable assignment - updated FAQ - fixed typo and spelling errors - fixed bug (reported by Torsten Bronger) in the escape layer leading libdar to wrongly reporting a file as corrupted at reading time - fixed bug in the sparse file detection mechanism that lead the minimum size hole detection to become a multiple of the default value or specified one. This implied a less efficient reduction of sparse files because smaller holes in files were ignored - fixed and updated man page about --go-into option - updated full-from-diff target in /etc/darrc default file - added a debug option in hash_file class (option only used from testing tools) to troubleshoot sha1/md5 hash problem on slices larger than (2**38)+63 bytes, bug reported by Mike Lenzen and understood by Yuriy Kaminskiy at libgcrypt. Note: This bug is still open due to an integer overflow in libgcrypt. - backported from current development code an additional and more simple way to read an archive using the libdar API. This API extension is not used by dar command-line tools for now. - Fixing installation of libdar header files on Darwin, where "DARwin" macros were not filtered out from the generated libdar header files. - Fixing self reported bug 'generic_file.cpp line 309' met while comparing an archive with a filesystem - Update code in order to compile with gcc-4.8.2 in g++11 mode (partial implementation and adaptation of Fabian Stanke's patch) - Fixing bug met while performing a verbose archive listing in sequential read mode - Added Ryan Schmidt's Patch to properly display status at end of ./configure script under BSD systems (in particular Mac OS X) - Updating configure.ac script to fix warning reported by autoconf when generating the ./configure script - Addressed portability problem with BSD systems that do not provide a -d option to the 'cp' command, preventing proper installation of the Doxygen documentation. Fix based on patch provided by Jan Gosmann. from 2.4.10 to 2.4.11 - Modified behavior of 'dar -h' and 'dar -V', both now return 0 as exist status instead of 1 (which means syntax error). - Fixed bug: -Q is now available with -V under the collapsed form -QV or -VQ - fixed typo in documentation - fixed memory leakage met when dar fails a merging operation because the resulting archive is specified in an directory that does not exist. - fixed bug met when isolating a differential backup in sequential read mode - fixed bug about slice file permission not taking care about umask variable when the --hash feature is used. - fixed performance issue when reading an archive over a pair of piles using dar_slave (possibly over ssh) when the archive makes use of escape marks and when no encryption is used - added target "full-from-diff" in /etc/darrc default file - fixed bug avoiding reading an truncated archive in direct access mode with the help of an external catalogue. - new and better implementation of archive extraction in sequential read mode - fixing bug (segfault) met when hitting CTRL-C while reading an archive in sequential mode - fixing libdar.pc for pkg-config for the cflags given to external applications - fixed memory allocation/desallocation mismatches (delete vs delete [] ) concerning four vector of chars. - fixed error in logical expression leading a sanity test to be useless
52 lines
1.5 KiB
C++
52 lines
1.5 KiB
C++
$NetBSD: patch-src_libdar_mask__list.hpp,v 1.3 2014/05/14 04:35:20 rodent Exp $
|
|
|
|
--- src/libdar/mask_list.hpp.orig 2014-04-21 10:02:16.000000000 +0000
|
|
+++ src/libdar/mask_list.hpp
|
|
@@ -70,46 +70,10 @@ namespace libdar
|
|
|
|
private:
|
|
|
|
- // we need to change to lexicographical order relationship for the '/' character be the most lower of all. This way
|
|
- // the first entry listed from a set a file sharing the same first characters will be the one corresponding
|
|
- // to the directory with this common prefix.
|
|
-
|
|
- class my_char
|
|
- {
|
|
- public:
|
|
- const my_char & operator = (const char x) { val = x; return *this; };
|
|
-
|
|
- bool operator < (const my_char & x) const
|
|
- {
|
|
- if(val == '/')
|
|
- if(x.val == '/')
|
|
- return false;
|
|
- else
|
|
- return true;
|
|
- else
|
|
- if(x.val == '/')
|
|
- return false;
|
|
- else
|
|
- return val < x.val;
|
|
- };
|
|
-
|
|
- operator char() const
|
|
- {
|
|
- return val;
|
|
- };
|
|
-
|
|
- private:
|
|
- char val;
|
|
- };
|
|
-
|
|
- std::vector <std::basic_string<my_char> > contenu;
|
|
+ std::vector <std::string > contenu;
|
|
U_I taille;
|
|
bool case_s;
|
|
bool including; // mask is used for including files (not for excluding files)
|
|
-
|
|
- static std::list<std::basic_string<my_char> > convert_list_string_char(const std::list<std::string> & src);
|
|
- static std::basic_string<my_char> convert_string_char(const std::string & src);
|
|
- static std::string convert_string_my_char(const std::basic_string<my_char> & src);
|
|
};
|
|
|
|
/// @}
|