pkgsrc/net/ncftp2/patches/patch-ab
jlam 90709cc4df Use devel/readline/Makefile.readline to get readline support on systems
without libedit readline emulation.  Don't accidentally link against
ncurses.

The ncurses dependency was removed a while back, but I'm not entirely sure
that was correct.  I don't think the curses library is enough to get this
package to work on pre-1.5 NetBSD systems.  I also don't know if this will
work with Solaris curses either.  We'll have to wait for bug reports.
2001-05-16 20:27:23 +00:00

16 lines
346 B
Text

$NetBSD: patch-ab,v 1.5 2001/05/16 20:27:23 jlam Exp $
--- Complete.c.orig Fri Oct 18 01:10:31 1996
+++ Complete.c Thu Jul 8 15:33:42 1999
@@ -241,7 +241,11 @@
static int
CompareStrings(char **a, char **b)
{
+#if defined(__FreeBSD__) || defined(__NetBSD__)
+ return strcoll(*a, *b);
+#else
return strcmp(*a, *b);
+#endif
}
static void