pkgsrc/databases/couchdb/patches/patch-ab
jperkin 8aaa84db56 Update databases/couchdb to 1.3.0. Changes since 1.2.1:
Version 1.3.0
-------------

HTTP Interface:

 * No longer rewrites the X-CouchDB-Requested-Path during recursive calls to the
   rewriter.
 * Limit recursion depth in the URL rewriter. Defaults to a maximum of 100
   invocations but is configurable.
 * Fix _session for IE7.
 * Added Server-Sent Events protocol to db changes API. See
   http://www.w3.org/TR/eventsource/ for details.
 * Make password hashing synchronous when using the /_config/admins API.
 * Include user name in show/list ETags.
 * Experimental support for Cross-Origin Resource Sharing (CORS). See
   http://www.w3.org/TR/cors/ for details.

Replicator:

 * The replicator will use a new server-wide UUID in checkpoint IDs to
   improve the chances of an efficient resume.

Storage System:

 * Fixed unnecessary conflict when deleting and creating a
   document in the same batch.

View Server:

 * Additional response headers may be varied prior to send().
 * GetRow() is now side-effect free.

Futon:

 * Disabled the link to the Futon test suite. These tests were causing problems
   when run from a browser, and are now available via the CLI instead.
 * Added view request duration to Futon.
 * Disable buttons for actions that the user doesn't have permissions to.

Security:

 * Passwords are now hashed using the PBKDF2 algorithm with a configurable work
   factor.

Test Suite:

 * Moved the JS test suite to the CLI.
 * Improved tracebacks printed by the JS CLI tests.
 * Improved the reliability of a number of tests.

UUID Algorithms:

 * Added the utc_id algorithm.

URL Rewriter & Vhosts:

 * Database name is encoded during rewriting (allowing embedded /'s, etc).
 * Reset rewrite counter on new request, avoiding unnecessary request failures
   due to bogus rewrite limit reports.

Build System:

 * C/C++ compiler detection has been improved.
 * Autoconf v2.63 is now required if building from Git checkout directly. See
   DEVELOPERS file for more details.
 * Fixed issue in couchdb script where stopped status returns before process
   exits.

Version 1.2.2
-------------

HTTP Interface:

 * Reset rewrite counter on new request, avoiding unnecessary request failures
   due to bogus rewrite limit reports.

Build System:

 * Fixed issue in couchdb script where stopped status returns before process
   exits.
2013-04-24 12:22:37 +00:00

93 lines
3.5 KiB
Text

$NetBSD: patch-ab,v 1.4 2013/04/24 12:22:38 jperkin Exp $
Install into examples, not sysconfdir.
--- etc/couchdb/Makefile.in.orig 2013-03-30 14:46:47.000000000 +0000
+++ etc/couchdb/Makefile.in
@@ -99,7 +99,7 @@ am__uninstall_files_from_dir = { \
|| { echo " ( cd '$$dir' && rm -f" $$files ")"; \
$(am__cd) "$$dir" && rm -f $$files; }; \
}
-am__installdirs = "$(DESTDIR)$(localconfdir)"
+am__installdirs = "$(DESTDIR)$(localegdir)"
DATA = $(localconf_DATA) $(noinst_DATA)
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
transform = @program_transform_name@
@@ -240,6 +240,7 @@ launchddir = @launchddir@
libdir = @libdir@
libexecdir = @libexecdir@
localconfdir = @localconfdir@
+localegdir = @localegdir@
localdatadir = @localdatadir@
localdocdir = @localdocdir@
localedir = @localedir@
@@ -331,25 +332,25 @@ clean-libtool:
-rm -rf .libs _libs
install-localconfDATA: $(localconf_DATA)
@$(NORMAL_INSTALL)
- @list='$(localconf_DATA)'; test -n "$(localconfdir)" || list=; \
+ @list='$(localconf_DATA)'; test -n "$(localegdir)" || list=; \
if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(localconfdir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(localconfdir)" || exit 1; \
+ echo " $(MKDIR_P) '$(DESTDIR)$(localegdir)'"; \
+ $(MKDIR_P) "$(DESTDIR)$(localegdir)" || exit 1; \
fi; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
echo "$$d$$p"; \
done | $(am__base_list) | \
while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(localconfdir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(localconfdir)" || exit $$?; \
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(localegdir)'"; \
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(localegdir)" || exit $$?; \
done
uninstall-localconfDATA:
@$(NORMAL_UNINSTALL)
- @list='$(localconf_DATA)'; test -n "$(localconfdir)" || list=; \
+ @list='$(localconf_DATA)'; test -n "$(localegdir)" || list=; \
files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
- dir='$(DESTDIR)$(localconfdir)'; $(am__uninstall_files_from_dir)
+ dir='$(DESTDIR)$(localegdir)'; $(am__uninstall_files_from_dir)
tags: TAGS
TAGS:
@@ -391,7 +392,7 @@ check-am: all-am
check: check-am
all-am: Makefile $(DATA)
installdirs:
- for dir in "$(DESTDIR)$(localconfdir)"; do \
+ for dir in "$(DESTDIR)$(localegdir)"; do \
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
done
install: install-am
@@ -558,20 +559,20 @@ local_dev.ini: local.ini
fi
install-data-hook:
- if test ! -f "$(DESTDIR)$(localconfdir)/local.ini"; then \
- cp $(srcdir)/local.ini "$(DESTDIR)$(localconfdir)/local.ini"; \
+ if test ! -f "$(DESTDIR)$(localegdir)/local.ini"; then \
+ cp $(srcdir)/local.ini "$(DESTDIR)$(localegdir)/local.ini"; \
fi
if test ! "$(mkdir_p)" = ""; then \
- $(mkdir_p) "$(DESTDIR)$(localconfdir)/default.d"; \
- $(mkdir_p) "$(DESTDIR)$(localconfdir)/local.d"; \
+ $(mkdir_p) "$(DESTDIR)$(localegdir)/default.d"; \
+ $(mkdir_p) "$(DESTDIR)$(localegdir)/local.d"; \
else \
echo "WARNING: You may have to create these directories by hand."; \
- mkdir -p "$(DESTDIR)$(localconfdir)/default.d"; \
- mkdir -p "$(DESTDIR)$(localconfdir)/local.d"; \
+ mkdir -p "$(DESTDIR)$(localegdir)/default.d"; \
+ mkdir -p "$(DESTDIR)$(localegdir)/local.d"; \
fi
uninstall-local:
- rm -f "$(DESTDIR)/$(localconfdir)/local.ini"
+ rm -f "$(DESTDIR)/$(localegdir)/local.ini"
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.