pkgsrc/devel/hdf5/patches/patch-hl_c++_examples_Makefile.in
adam 1bcf58e4aa Changes 1.8.10:
* The following new C function has been added:
	H5Pget_mpio_no_collective_cause
* The following new Fortran subroutine has been added:
	h5pget_mpio_actual_io_mode_f
* The syntax of the following high-level C function has changed:
	H5TBAget_fill
This function’s return type has been changed to h5tri_t. A return value of 1 indicates that a fill value is present, 0 indicates that no fill value is present, and a negative value indicates an error. (The former return type was herr_t.)
Note that H5TBAget_fill and a companion function H5TBAget_title, both in the HDF5 Table (H5TB) high-level API, are undocumented. These functions will be added to the HDF5 Reference Manual shortly after HDF5 Release 1.8.10.

Changed Command-line Tool
* h5import has been updated to accept an input file created by h5dump.
2012-12-09 00:07:38 +00:00

15 lines
564 B
Text

$NetBSD: patch-hl_c++_examples_Makefile.in,v 1.2 2012/12/09 00:07:38 adam Exp $
Fix paths to examples.
--- hl/c++/examples/Makefile.in.orig 2011-05-10 14:20:48.000000000 +0000
+++ hl/c++/examples/Makefile.in
@@ -401,7 +401,7 @@ CXX_API = yes
# Where to install examples
# Note: no '/' after DESTDIR. Explanation in commence.am
-EXAMPLEDIR = ${DESTDIR}$(exec_prefix)/share/hdf5_examples/hl/c++
+EXAMPLEDIR = ${DESTDIR}$(prefix)/share/examples/hdf5/hl/c++
# Assume that all tests in this directory are examples, and tell
# conclude.am when to build them.